Showing results for 
Search instead for 
Did you mean: 
Moto Sr Moderator
Moto Sr Moderator
Posts: 28,298
Registered: ‎02-02-2016
Location: US
Views: 1,679
Message 51 of 58

Re: Outgoing calls displayed as Private Number

@msdad wrote:

This is NOT solved. My Moto X Pure Edition is less than a week old. My carrier has modified the settings for my phone to not show as Private Number. It doesn't matter who I call, it still shows as Private. There is an issue somehow with the phone. I need to know what settings need to be changed so that my calls show as coming from me (especially with family, friends and my husband, who has a ringtone set for when I call. 

Who is your carrier?


In all cases in the past, the issue was smaller foreign carriers that had an error in their network signalling protocols. 


This forum is for the Moto G - I have not seen this issue reported on the Moto X pure by anyone yet. 

* Search box is your friend * I don't respond to PM if question belongs in forum
Paper Tape
Posts: 6
Registered: ‎05-23-2016
Location: US
Views: 1,673
Message 52 of 58

Re: Outgoing calls displayed as Private Number

Sorry, I clicked on the Moto X image so I assumed that's where I still was when I searched the issue. Our carrier is Ting, who runs on the Sprint Network (in fact the SIM card shows as Sprint and Sprint always shows in the upper left corner of the screen since we're running on their network. I'll repost the question again and make sure I'm in the Moto X section. 


What's DOS?
Posts: 1
Registered: ‎09-23-2016
Location: IT
Views: 1,519
Message 53 of 58

Re: Outgoing calls displayed as Private Number

After upgrade to Android 6, the problem persist. Now, tell me if Android 6 release included a bug fix in the dialer to acknowledge that the network requests the number be hidden. I think no. The problem is Motorola, now Lenovo. With other smartphones, with the same sim card, NO PROBLEM.


Posts: 17
Registered: ‎01-26-2017
Location: IN
Views: 1,363
Message 54 of 58

Re: Outgoing calls displayed as Private Number

Show / Hide number on outgoing calls android phone


For Android 7.0 Nougat:

hide caller id moto g4 plus.JPG

Phone app > More > Settings > Calling account > Select SIM 1 / SIM 2 > Additional settings > Caller ID


For Marshmallow device:

Show caller ID in Android 6.0 marshmallow.JPG

Phone app > More > Settings > Call settings > More settings > Select SIM 1 / SIM 2 > Show my Caller ID > Show number / Hide number


What's DOS?
Posts: 1
Registered: ‎01-16-2018
Location: RU
Views: 913
Message 55 of 58

Re: Outgoing calls displayed as Private Number

the instructions have nothing to do with the problem and do not solve it obviously, I had this problem in stock Lollipop of Moto G 1st gen, same problem with Marshmallow is still NOT SOLVED 

Paper Tape
Posts: 1
Registered: ‎04-16-2018
Location: IT
Views: 701
Message 56 of 58

Re: Outgoing calls displayed as Private Number

Same here. Moto E first gen, after update to android 5 some dialled numbers as well some received phone calls show Private number. Called my network operator in Italy (Three-Wind now merged) and replied there is nothing they can/will do about it.
I did not try switching to a different operator I'm also contemplating rooting the phone and flash it with unsupported OS (7 or 8) to be able to use SD card as internal memory since it's always running out of space even without apps installed (just the regular pre installed apps update) and at the moment nothing can be moved to external SD with android 5.
Fanfold Paper
Posts: 3
Registered: ‎10-08-2019
Location: RS
Views: 213
Message 57 of 58

Re: Outgoing calls displayed as Private Number

Same problem on brand new Motorola One Vision.

Motorola sucks from me too, as their support has no respect for the customers. They just mark as solved and that's it.

Fanfold Paper
Posts: 12
Registered: ‎08-18-2015
Location: LV
Views: 138
Message 58 of 58

Re: Outgoing calls displayed as Private Number

Very late reply - I wrote to Bite, they asked for my SIM card number and somehow fixed it through technical support, but when pressed for details, they were silent.

P.S. I am using a Samsung S9 for the last 10 months, so I guess it's time to move on. Smiley Happy
Former Moto G2 2014 user (2015-2018), now using Samsung

And We're back...

Move delayed but still coming

Learn More