cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
edeab2201
What's DOS?
Posts: 2
Registered: ‎09-06-2014
Location: Peru
Views: 906
Message 1 of 5

US Dual-SIM Availability?

I'm getting confused because most, if not all news sites, stated that the Moto G 2nd Gen was available in a dual-SIM version. However, I'm not sure how I can obtain one in the US.



Is there a dual-SIM version of the Moto G 2nd Gen available in the US with US bands?



Thanks

Moto Sr Moderator
Moto Sr Moderator
Posts: 2,695
Registered: ‎03-08-2010
Location: United States
Views: 906
Message 2 of 5

Re: US Dual-SIM Availability?

I remember that the 1st-Gen moto g with dual-sim was available for purchase on Amazon at some point.

Motorola Admin Motorola Admin
Motorola Admin
Posts: 16,872
Registered: ‎02-03-2016
Location: US
Views: 906
Message 3 of 5

Re: US Dual-SIM Availability?

It won't be offered in the US in a Dual SIM version. 

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Highlighted
kbmaverick
What's DOS?
Posts: 6
Registered: ‎12-26-2013
Views: 906
Message 4 of 5

Re: US Dual-SIM Availability?


Matt (Forums Manager) said:


It won't be offered in the US in a Dual SIM version. 


View original


Which is sad, because quite a few Americans like myself travel for a living and would love to buy a no-contract, dual-sim phone directly from Motorola. 



Since Motorola has decided that American's don't need dual-sim phones, we end up buying an overpriced one in Europe or Brazil.  A lot of the dual-sim phones sold on Amazon are from India, which uses slightly different data frequencies from those used by the networks in Europe or Brazil.

edeab2201
What's DOS?
Posts: 2
Registered: ‎09-06-2014
Location: Peru
Views: 906
Message 5 of 5

Re: US Dual-SIM Availability?


Matt (Forums Manager) said:


It won't be offered in the US in a Dual SIM version. 


View original


Ah that's very unfortunate. Any word when the dual-SIM model will be available? I guess I will need to import one...this is very very unfortunate...