Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto X PhonesMOTO X™ 1st Gen
All Forum Topics
Options

242 Posts

07-31-2012

India

0 Signins

0 Page Views

  • Posts: 242
  • Registered: ‎07-31-2012
  • Location: India
  • Views: 0
  • Message 1 of 16

Recent Apps Bug v5.1

2015-07-24, 11:24 AM

So I noticed this bug since the day I installed the 5.1 update but I was hoping that it was just a temporary glitch and would go away after factory reset and cache wipes but it still persists. What happens is I am hardly ever able to restore an app from the recent apps menu (Square soft key) on the first attempt, the app window just gains focus, similar to a window getting selected on a desktop OS. All the subsequent attempts are successful however only if the the app window is in focus, usually indicated by the top bar turning white. Here are a couple of screenshots.





One app in particular never restores and instead crashes with an error message is the Google Messenger(SMS) app.




Anyone else facing this or similar issues with recent apps?

Reply
Options

682 Posts

07-12-2011

Germany

173 Signins

1560 Page Views

  • Posts: 682
  • Registered: ‎07-12-2011
  • Location: Germany
  • Views: 1560
  • Message 2 of 16

Re: Recent Apps Bug v5.1

2015-07-24, 11:53 AM

I just tried opening a bunch of apps from the recent apps menu, & did not have any problem. Also I don't get the out of focus effect. I could open any app be it at the front or behind, & don't get the colour change you showed. Strange why it is different.



I've included a screenshot to show you what mine looks like



 


Reply
Options

242 Posts

07-31-2012

India

0 Signins

0 Page Views

  • Posts: 242
  • Registered: ‎07-31-2012
  • Location: India
  • Views: 0
  • Message 3 of 16

Re: Recent Apps Bug v5.1

2015-07-24, 12:16 PM

Do you use the Google Messenger app or the stock Messaging app? If the Google one could you try and restore it from recents and see if it restores alright?



I don't get why Motorola did not make Google Messenger app the stock messaging app when they even included that awful Hangouts app as a stock app. The problem that arises here is if you want to use Google's Messenger app and set it as default, you can't disable the stock Messenger app so it still keep running in the background.

Reply
Options

682 Posts

07-12-2011

Germany

173 Signins

1560 Page Views

  • Posts: 682
  • Registered: ‎07-12-2011
  • Location: Germany
  • Views: 1560
  • Message 4 of 16

Re: Recent Apps Bug v5.1

2015-07-24, 14:22 PM

AC2K14 said:


Do you use the Google Messenger app or the stock Messaging app? If the Google one could you try and restore it from recents and see if it restores alright?



I don't get why Motorola did not make Google Messenger app the stock messaging app when they even included that awful Hangouts app as a stock app. The problem that arises here is if you want to use Google's Messenger app and set it as default, you can't disable the stock Messenger app so it still keep running in the background.


View original


I emailed an answer while out, but in case it did not make it, I use the stock messaging app.


Reply
Options

172 Posts

02-10-2010

Vancouver, BC, Canada

410 Signins

3291 Page Views

  • Posts: 172
  • Registered: ‎02-10-2010
  • Location: Vancouver, BC, Canada
  • Views: 3291
  • Message 5 of 16

Re: Recent Apps Bug v5.1

2015-07-24, 19:39 PM
I can't reproduce this issue, either. And I'm using the newer Messenger app from the Play Store, not the stock Messaging app. I do have occasional crashes with it but it's very rare and in fact I can't remember the last time it happened.

Maybe try uninstalling and reinstalling Messenger to see if that helps?
_________________________________________________________________
ThinkPad T510 : i5-540M : 8GB PC-10600 : 500GB 7200rpm : 15.6" HD+ : Intel 6300 : Win7 Pro 64 : 9Cell
Ordered 2/Feb/2010 : Shipped 22/Feb/2010 : Received 3/Mar/2010
Reply
Options

242 Posts

07-31-2012

India

0 Signins

0 Page Views

  • Posts: 242
  • Registered: ‎07-31-2012
  • Location: India
  • Views: 0
  • Message 6 of 16

Re: Recent Apps Bug v5.1

2015-07-25, 16:00 PM

Mutnat said:

I can't reproduce this issue, either. And I'm using the newer Messenger app from the Play Store, not the stock Messaging app. I do have occasional crashes with it but it's very rare and in fact I can't remember the last time it happened. Maybe try uninstalling and reinstalling Messenger to see if that helps?View original


The Google Messenger app itself is very stable, never ever crashed for me. It just fails to restore with that message whenever I try to restore it from Recent Apps.



Think I will just go ahead a do a full factory reset, since the last time I did it iirc I let Google restore apps and settings. I'll just go ahead and delete all stored settings on Google's server by turning off Backup and Restore before I reset, just to be safe. Will report back after everything is up and running.

Reply
Options

62 Posts

11-10-2014

Brazil

1 Signins

9 Page Views

  • Posts: 62
  • Registered: ‎11-10-2014
  • Location: Brazil
  • Views: 9
  • Message 7 of 16

Re: Recent Apps Bug v5.1

2015-07-25, 19:01 PM

It has nothing to do with any messenger app. It happens even while on safe mode. https://forums.motorola.com/posts/8f34da4016



Please read the whole thread and try to reproduce the bug the way I describe and tell us if you have it or not.

Reply
Options

242 Posts

07-31-2012

India

0 Signins

0 Page Views

  • Posts: 242
  • Registered: ‎07-31-2012
  • Location: India
  • Views: 0
  • Message 8 of 16

Re: Recent Apps Bug v5.1

2015-07-25, 19:58 PM

friends_addict said:


It has nothing to do with any messenger app. It happens even while on safe mode. https://forums.motorola.com/posts/8f34da4016



Please read the whole thread and try to reproduce the bug the way I describe and tell us if you have it or not.


View original


Thanks for the heads up. Wish you had posted here before I went through the whole Factory Reset process though. Anyways it still did fix a couple of other glitches I was facing. Namely this Boot logo issue like I posted in this thread https://forums.motorola.com/posts/f7568c0856. The boot logo got restored to the new materialized one after the reset and I guessed it would because while performing the reset wipe the system specifically reported that it was wiping my custom flashed clogo. Then after the first run and some services update the whole boot logo/clogo got changed along with the boot animation to the new stitches one as reported in thread https://forums.motorola.com/posts/a70c3d5c60.



But the main issue of the Recent Apps glitch still remains. And just as suggested in the thread friends_addict linked https://forums.motorola.com/posts/8f34da4016 the temporary solution i.e. using the Home circle softkey instead of the Back triangle softkey works.

Reply
Options

189 Posts

03-18-2015

United States

16 Signins

180 Page Views

  • Posts: 189
  • Registered: ‎03-18-2015
  • Location: United States
  • Views: 180
  • Message 9 of 16

Re: Recent Apps Bug v5.1

2015-07-26, 2:44 AM
I can use either triangle or circle to go home, squre still works as expected. So the behavior looks like apps dependent.
Reply
Options

682 Posts

07-12-2011

Germany

173 Signins

1560 Page Views

  • Posts: 682
  • Registered: ‎07-12-2011
  • Location: Germany
  • Views: 1560
  • Message 10 of 16

Re: Recent Apps Bug v5.1

2015-07-26, 5:37 AM

omegaz said:

I can use either triangle or circle to go home, squre still works as expected. So the behavior looks like apps dependent.View original


Same for me. I tried these exact instructions on several apps:-



Ok after playing around a bit I saw something interesting. Go to an app and then come back to your home screen by pushing the back button. Then press the recent app button and select the same app (it happens if you select a different app too), and tell me what happened? Did it open? In my phone, it didn't!



And in every case the apps opened perfectly every time.



FYI, a while ago I did a Factory reset without backup & restore on, as per Alpha Dogs detailed instructions, and many "quirks" vanished after I had reinstalled all my none-standard apps.



 


Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms