cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Magendanz
Paper Tape
Posts: 4
Registered: ‎08-07-2019
Location: US
Views: 371
Message 1 of 4

Attempted upgrade to Android Pie causes hard brick?

Today I went to upgrade my Cricket Moto G6 Play (XT1922-9) to Android Pie, which is available for the XT1922-9 but only for the RETUS channel. I ran the batch file (converted from flashfile.xml) in fastboot and received a "Preflash validation failed" on the boot, recovery and system partitions. Now the device only boots to the bootloader because it fails to validate the boot image. Likewise, recovery mode is inaccessible because it can't validate the recovery image. (Interestingly enough, neither of these images were actually flashed.)

Now the locked device seems effectively bricked. Motorola wouldn't allow me to unlock the bootloader because it's Cricket, and trying to flash the latest Oreo ROM for the Cricket channel also fails validation in both fastboot and with RSD Lite 6.2.4. (I had OCPS27.91-62-10 installed, but that doesn't seem to be available for download, so I tried OCPS27.91-62-19.)

So am I really stuck on the bootloader with no inability to flash known-good (and properly signed) OEM firmware?

Magendanz
Paper Tape
Posts: 4
Registered: ‎08-07-2019
Location: US
Views: 370
Message 2 of 4

Re: Attempted upgrade to Android Pie causes hard brick?

Here's what I flashed:  XT1922-9_JETER_RETUS_9.0_PPP29.118-17-1_cid50_subsidy-DEFAULT_regulatory-DEFAULT_CFC.xml.zip

 

And here's where I started:

 

 

#fastboot getvar all

version: 0.5
version-bootloader: moto-msm8920-B9.47
product: jeter
board: jeter
secure: yes
hwrev: P4
radio: 8
storage-type: emmc
emmc: 16GB SAMSUNG QE63MB RV=08 PV=03 FV=0000000000000003
ram: 2GB SAMSUNG LP3 DIE=8Gb M5=01 M6=06 M7=00 M8=1F
cpu: MSM8920
serialno: ZL5228WKCT
cid: 0x0001
channelid: 0x89
uid: 8178B89300000000000000000000
securestate: oem_locked
iswarrantyvoid: no
max-download-size: 535822336
reason: Volume down key pressed
imei: [redacted]
meid:
date: 10-13-2018
sku: XT1922-9
carrier_sku: XT1922-9
battid:
iccid:
cust_md5:
max-sparse-size: 268435456
current-time:
ro.build.fingerprint: motorola/jeter_a/jeter:8.0.0/OCPS27.91-62-10/12:user/release-keys
poweroffalarm: 0
ro.build.version.full: Blur_Version.27.221.12.jeter_a.a.en.US
ro.build.version.qcom: LA.UM.6.6.r1-04400-89xx.0
version-baseband: M8920_10.04.11.48R JETER_NA_CUST
kernel.version: Linux version 3.18.71-perf-gd9dd66a (hudsoncm@ilclbld34) (gcc version 4.8 (GCC)) #1 SMP PREEMPT Fri Nov 2 08:19:50 CDT 2018
sbl1.git: git=MBM-NG-VB9.47-0-g5f65866
rpm.git: git=02a0726-dirty
tz.git: git=5fda3f8-dirty
devcfg.git: git=5fda3f8-dirty
keymaster.git: git=5fda3f8
cmnlib.git: git=5fda3f8
cmnlib64.git: git=5fda3f8
prov.git: git=5fda3f8-dirty
aboot.git: git=MBM-NG-VB9.47-0-g323cc33
frp-state: no protection (0)
ro.carrier: cricket
current-slot:
slot-suffixes: _a
slot-count: 1
slot-successful:_a: INVALID
slot-successful:_b: INVALID
slot-bootable:_a: INVALID
slot-bootable:_b: INVALID
slot-retry-count:_a: unknown
slot-retry-count:_b: unknown
all: listed above
Finished. Total time: 0.170s

 

Magendanz
Paper Tape
Posts: 4
Registered: ‎08-07-2019
Location: US
Views: 251
Message 3 of 4

Re: Attempted upgrade to Android Pie causes hard brick?

Seriously, is there no way to flash OEM firmware via fastboot on a locked Motorola device?

 

On any other device, this would be trivial.  Why are we gettiing "Preflash validation failed" errors for OEM signed images?

Grisalho52
Fanfold Paper
Posts: 1
Registered: ‎01-30-2018
Location: BR
Views: 207
Message 4 of 4

Re: Attempted upgrade to Android Pie causes hard brick?

Olá boa noite,
Seu aparelho entra em modo fastboot? Qual a última firmwere que estava no seu aparelho, baixe ela e descompactar dentro da pasta adb .... Os comando a serem digitados.

fastboot oem fb_mode_set
fastboot flash partition gpt.bin
fastboot flash bootloader bootloader.img
fastboot flash logo logo.bin
fastboot flash boot boot.img
fastboot flash recovery recovery.img
fastboot flash dsp adspso.bin
fastboot flash oem oem.img
fastboot flash system system.img_sparsechunk.0
fastboot flash system system.img_sparsechunk.1
fastboot flash system system.img_sparsechunk.2
fastboot flash system system.img_sparsechunk.3
fastboot flash system system.img_sparsechunk.4
fastboot flash system system.img_sparsechunk.5
fastboot flash system system.img_sparsechunk.6
fastboot flash system system.img_sparsechunk.7
fastboot flash system system.img_sparsechunk.8
fastboot flash system system.img_sparsechunk.9
fastboot flash system system.img_sparsechunk.10
fastboot flash modem NON-HLOS.bin
fastboot flash fsg fsg.mbn
fastboot erase cache
fastboot erase userdata
fastboot erase customize
fastboot erase clogo
fastboot oem fb_mode_clear

Depois fastboot Reboot.
E por favor faça em linha por linha os comandos, não esquecer pegar a firmwere do seu aparelho mais recente. Se der certo poste aqui.
Top Kudoed Authors