cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
woffs
What's DOS?
Posts: 2
Registered: ‎08-21-2012
Location: Germany
Views: 704
Message 1 of 5

defy mini: sip calls always with loudspeaker

Hi,


when initiating or answering internet voice calls (SIP), always the loudspeaker is active, regardless of the state of the loudspeaker-on-off button. Calls are done with the builtin standard phone app. Mobile (GSM) calls are doing without problems, and the loudspeaker-on-off button works as expected.


regards,


WofFS

josp
What's DOS?
Posts: 4
Registered: ‎04-01-2013
Location: Spain
Views: 704
Message 2 of 5

Re: defy mini: sip calls always with loudspeaker


Hello, I have the very same problem with my recently purchased Defy Mini XT320: loudspeaker is always enabled for regular internet calls (Gingerbread SIP stack), and cannot be disabled. 

By the way, I'd say that sound quality is quite poor (interruptions) compared to X-Lite softphone. 



Did you find any solution, WofFS? 

 



Details of my phone (bought in Amazon UK): 



- Kernel 2.6.38.6+ buildsrv@lxdex2 #1  (compilation number 0A.21.21)



- Flex version: WE_RTGB_v14_0512_FLEXTNBST



- Software version: TNBST_4_0A.21.21RPS



 

Highlighted
josp
What's DOS?
Posts: 4
Registered: ‎04-01-2013
Location: Spain
Views: 704
Message 3 of 5

Re: defy mini: sip calls always with loudspeaker


Just to let you know, this the response I got from Motorola (after being asked to perform a factory data reset) 




"We would like to inform you that we have transferred your case to our IT department, which has confirmed that this is a known issue and the SIP feature on the Motorola Defy Mini can only be used via loudspeaker.



We apologize for any inconvenience this may cause you and we would suggest to visit Play Store in order to download a third party SIP application.



Thank you for allowing us to be of service to you."



 


josp
What's DOS?
Posts: 4
Registered: ‎04-01-2013
Location: Spain
Views: 704
Message 4 of 5

Re: defy mini: sip calls always with loudspeaker


I will add that the recommended app by Motorola support, Zoiper, will use the correct speaker. 



I don't think that defaulting to the loudspeaker is a bug. I would say it's designed that way, in order to avoid the problem that appears when you take the phone close to your head and the "head detector" is triggered. 


 


In any VoIP call, if you cover the "head detector" (the light detector next to the logo), the audio is severely crippled, the sound disappears for moments, like in periodical waves. That happens with the integrated SIP stack, or any other app that makes use of the head detector (Zoiper seems to try to avoid that at first, but fails sometimes).


 


This is the real problem this phone has, so, instead of fixing it, they decided to avoid it by using the loudspeaker by default, so you don't need to take the phone close to your head. 



The final message by Motorola, as expected: 

 



We would like to thank you very much for your feedback and let your know that your report has been passed to our IT department, however at this moment the phone is working as designed and we are not able to offer you an alternative for SIP calls. We sincerely apologize for any inconvenience this may cause you.





BTW, the same problem happens with Skype, so I guess it's not something related to SIP only. 

 



PS: OK, I've just found that this more or less common: 



https://code.google.com/p/csipsimple/wiki/FAQ?wl=en#Audio_routing_troubleshooting



https://code.google.com/p/csipsimple/wiki/FAQ?wl=en#When_screen_goes_off_sound_quality_is_bad



https://code.google.com/p/android/issues/detail?id=9781

 



 




"It seems that, even with "Wifi Sleep Policy" set to "Never", the wifi on some Android devices will enter Power Save mode (a.k.a. PSP mode) when the screen turns off.


 


PSP mode apparently causes the wifi device to sleep, but wake up periodically and ask its access point to deliver packets that were addressed to to the device while it was asleep. This necessarily causes additional, "spiky" network latency. This additional latency means that some network-oriented applications experience problems when the screen turns off.


 


Most notably, Internet telephony apps simply cannot make a call over wifi with the screen off. As soon as the screen goes off, the call becomes heavily garbled or mute in both directions. Here's the associated bug on Sipdroid:


 


http://code.google.com/p/sipdroid/issues/detail?id=268


 


Sipdroid has kludged a solution for this problem by forcing the screen to be on while a wifi call is in progress. Fring may do the same, but I do not use Fring enough to know. The best that any Internet telephony app could ever do in this situation is use a large buffer to smooth out the audio, but the resulting delay would always be similar to calling China from the United States."



 


Zoiper with "Disable Proximity sensor " audio option is a solution, although sound quality is clearly worse than X-Lite softphone in Windows. 




 

josp
What's DOS?
Posts: 4
Registered: ‎04-01-2013
Location: Spain
Views: 704
Message 5 of 5

Re: defy mini: sip calls always with loudspeaker


The tweaked version of sipdroid linked here also works for me, when combined with "turn on screen" in wifi settings to avoid Power Saving Poll mode destroying audio (Zoiper uses much more CPU than sipdroid): 

https://code.google.com/p/sipdroid/issues/detail?id=366#c111



3 years later and these bugs in android are still driving us mad.