Motorola Community

Older Devices ArchiveMOTOROLA ELECTRIFY™
All Forum Topics
Options

1 Posts

07-23-2013

United States

0 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎07-23-2013
  • Location: United States
  • Views: 0
  • Message 1 of 2

Battery Problem

2013-07-23, 22:43 PM


The other night I plugged in my phone, and in the morning when I unplugged it, it had 100% battery. I never used it, but about 2-3 hours later it died. I went to turn it on and it did, but it only lasted a minute at most even when plugged in. I brought it in to the local store (not where it was purchased) to ask a few questions. They said I needed a new battery, and gave me one. The battery was at 100%, but died within the hour, even though it was charging. The phone will still turn on for a short time if plugged in, but dies shortly after. Please help?

Reply
Options

13984 Posts

02-02-2016

US

322 Signins

2684 Page Views

  • Posts: 13984
  • Registered: ‎02-02-2016
  • Location: US
  • Views: 2684
  • Message 2 of 2

Re: Battery Problem

2013-07-24, 23:54 PM


My guess is that a factory data reset might resolve your issue, but we typically leave that as a path of last resort.



Is there any way for you to take your device into USC for some diagnostics?

Comment in the spirit of COMMUNITY: "Share experiences / expertise, engage in the discussions, and offer advice and suggestions."
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete