Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Older Devices ArchiveMOTOROLA ELECTRIFY™ M
All Forum Topics
Options

24 Posts

02-15-2013

United States

0 Signins

0 Page Views

  • Posts: 24
  • Registered: ‎02-15-2013
  • Location: United States
  • Views: 0
  • Message 1 of 32

How to fix broken USB SD mounting (Jelly Bean)

2013-02-15, 2:01 AM


First the facts (pre-Jelly Bean):



1) Electrify-M



2) Preloaded with 4.04



3) Settings -> Storage -> Menu -> USB Connection Setting -> option 1 (USB Storage) of 3 options



4) Connect phone to XP 32bit box, 32 GB SD card appears as drive I:



All was well with Ice Cream Sanwitch.



Then early this morning, I installed Jelly Bean.  I waited a day because a friend's M was turned into a brick after the update was installed.  He got a new M today because of that.



After the download and install, I then attempted to connect the phone to the computer.  Discovered that the three USB connections were now reduced to two.  The USB storage one was gone.  Only the MTP and PTP options remained. But, mounted on drive I: was the directory from the phone containing the Motorola Device Manager.  But, it refused to install.



After going thru tech support, it was determined that the MDM from Ice Cream Sandwich was not removed, or overwritten, by the Jelly Bean installer.  Oops,. software bug.  USC turned in a ticket for that.  After manually removing the old MDM, the new MDM would install.  The computer had to be rebooted in order for it to take affect, even though the installer didn't ask that it be done.  While the MDM software directory is no longer mounted on the computer, neither is the SD card.  It stays mounted on the phone.  I do not run Media Center, nor will I as I do not like/want it.  Besides, wasn't needed for 4.0.4.



Changed the USB connection to PTP and that works just fine.  A XT901 device is created on the system and one can get at the camera/pictures, but nothing else.  Going back to MTP mounts nothing.  Called tech support and other ticket has been turned in for this issue.



So, does anyone know how to get the SD card to mount on the XP computer, so that it works like it did under 4.0.4, or did the Google/Android developers screw the pooch on this one?



The last thing I want to do is having to remove the microSD card and use a USB adapter in order to be able to transfer files to it, specifically new/updated music files.



Sorry that this posting was wordy, but needed to supply all the facts.

Reply
Options

20127 Posts

02-03-2016

United States of America

2604 Signins

65398 Page Views

  • Posts: 20127
  • Registered: ‎02-03-2016
  • Location: United States of America
  • Views: 65398
  • Message 2 of 32

Re: How to fix broken USB SD mounting (Jelly Bean)

2013-02-15, 17:15 PM


The Mass Storage mode, as you say, is not supported on Jelly Bean. Your post is complicated so I have to ask -- is there any actual task you can't accomplish using the Jelly Bean processes?

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Options

24 Posts

02-15-2013

United States

0 Signins

0 Page Views

  • Posts: 24
  • Registered: ‎02-15-2013
  • Location: United States
  • Views: 0
  • Message 3 of 32

Re: How to fix broken USB SD mounting (Jelly Bean)

2013-02-15, 19:23 PM


While your response may be the best answer, it doesn't explain the stupid reason as to why it was pulled from Jelly Bean.



That was a very important feature for me.  Now I have to pull the SD card every time I need to update it, or retrieve files from it.  Stupid, really stupid.



So, to answer your question, yes there is a task I can't accomplish using the Jelly Bean processes and that is transferring file back and forth from the phone to the computer while the phone is connected to the computer via the USB port.



Did I say that pulling this feature was stupid.



So, how does one complain to the idiots at Google/Android about this?  And yes, the decision was/is idiotic.  Sue, me - I'll prove it.  If you get the impression that I am pissed about its removal, you would be correct.



Oh there is another task I discovered that doesn't have an option.  Don't know if Ice Cream Sandwich allowed it, or not, as I've only had the phone 4 weeks.  That is if a text fails to send, there isn't an option to resend it.  There was on the Crackberry that I had and I used it.  Not so Jelly Bean.

Reply
Options

20127 Posts

02-03-2016

United States of America

2604 Signins

65398 Page Views

  • Posts: 20127
  • Registered: ‎02-03-2016
  • Location: United States of America
  • Views: 65398
  • Message 4 of 32

Re: How to fix broken USB SD mounting (Jelly Bean)

2013-02-15, 19:43 PM


MrVideo said:


 

yes there is a task I can't accomplish using the Jelly Bean processes and that is transferring file back and forth from the phone to the computer while the phone is connected to the computer via the USB port.View original


If you put your phone in MPT mode (Media device), you should then be able to got to My Computer > Electrify M > SD Card on your PC and move files back and forth. Is that not working?

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Options

24 Posts

02-15-2013

United States

0 Signins

0 Page Views

  • Posts: 24
  • Registered: ‎02-15-2013
  • Location: United States
  • Views: 0
  • Message 5 of 32

Re: How to fix broken USB SD mounting (Jelly Bean)

2013-02-15, 20:25 PM


Does not work.  I would have seen that, as I have Explorer up constantly.  As indicated in the initial posting, when in PTP mode, the XT901 is created and filled with the sub-directories dealing with the camera.  Go back to MTP and nada.  The XT901 directory is now empty.



An Electrify-M directory is not created under My Computer.

Reply
Options

24 Posts

02-15-2013

United States

0 Signins

0 Page Views

  • Posts: 24
  • Registered: ‎02-15-2013
  • Location: United States
  • Views: 0
  • Message 6 of 32

Re: How to fix broken USB SD mounting (Jelly Bean)

2013-02-15, 20:56 PM


BTW, if that is how MTP mode was supposed to work under Ice Cream Sandwich, it didn't there either.  That is why that I am upset that the mass storage mode was removed.  There needs to be a backup if MTP doesn't work.



Not only that, how is a user supposed to know how these USB connection modes are supposed to work when the available mauals to not explain the options at all.  A vague manual is a useless manual.



 

Reply
Options

22 Posts

01-26-2013

United States

0 Signins

0 Page Views

  • Posts: 22
  • Registered: ‎01-26-2013
  • Location: United States
  • Views: 0
  • Message 7 of 32

Re: How to fix broken USB SD mounting (Jelly Bean)

2013-02-16, 1:20 AM


 



Try going into Apps > Settings > Storage > Menu (upper-right three vertical dots) > USB computer connection and ensure that Media device (MTP) is selected.


 


Here is some additional information that may also help. Note that this hasn’t been updated since Jelly Bean/4.1 in that is still references Mass Storage as being an option. Google removed that functionally with 4.1 (it wasn’t a Motorola decision).


 

Reply
Options

24 Posts

02-15-2013

United States

0 Signins

0 Page Views

  • Posts: 24
  • Registered: ‎02-15-2013
  • Location: United States
  • Views: 0
  • Message 8 of 32

Re: How to fix broken USB SD mounting (Jelly Bean)

2013-02-16, 2:24 AM


GaryP said:


 



Try going into Apps > Settings > Storage > Menu (upper-right three vertical dots) > USB computer connection and ensure that Media device (MTP) is selected.



As indicated by the previous posts, I have indeed been sitting on MTP when trying to do this.  That feature is not working with my XP SP3 OS.



I never implied that Motorola had anything to do with the removal, as indicated above, I did say in a round-about way, that it was Google that did it.  I need to bitch at them because they removed an option that worked for me.

Reply
Options

24 Posts

02-15-2013

United States

0 Signins

0 Page Views

  • Posts: 24
  • Registered: ‎02-15-2013
  • Location: United States
  • Views: 0
  • Message 9 of 32

Re: How to fix broken USB SD mounting (Jelly Bean)

2013-02-16, 2:32 AM


GaryP said:


 


Here is some additional information that may also help.  [URL removed]



Thanks for the link.  It basically says that foe XP users, Windows Media Player needs to be installed and at least be at version 11.



I do not want WMP on the system.  I do not like WMP.  I use better software.  The Mass Storage mode allowed connecting the phone without having to have WMP infecting the computer.

Reply
Options

20127 Posts

02-03-2016

United States of America

2604 Signins

65398 Page Views

  • Posts: 20127
  • Registered: ‎02-03-2016
  • Location: United States of America
  • Views: 65398
  • Message 10 of 32

Re: How to fix broken USB SD mounting (Jelly Bean)

2013-02-16, 17:18 PM


You don't have to use it as your media manager -- you simply need to load it.

Please do not PM me - if you have issues, search the forums for threads on your topic and post there, or start a new thread. Thanks!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms