Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Older Devices ArchiveMOTOROLA ELECTRIFY™ M
All Forum Topics
Options

2027 Posts

12-04-2009

United States

39 Signins

756 Page Views

  • Posts: 2027
  • Registered: ‎12-04-2009
  • Location: United States
  • Views: 756
  • Message 11 of 19

Re: What are your Electrify M Issues

2013-05-03, 14:14 PM


If in roaming... *228 should not be used.

Reply
Options

2027 Posts

12-04-2009

United States

39 Signins

756 Page Views

  • Posts: 2027
  • Registered: ‎12-04-2009
  • Location: United States
  • Views: 756
  • Message 12 of 19

Re: What are your Electrify M Issues

2013-05-03, 15:18 PM


Key Pointers to keeping a Healthy phone are: 



  • do a Power Cycle daily


    • power Off/On to reboot




  • do a Battery Pull simulator weekly


    • hold the Power Button followed by the addition of the Volume Down Button a second later until the phone shuts Off


    • it then auto powers up again.


    • The phone may do a screen print during this if the Power button and Volume down are pressed at the same time but will still cycle after a few more seconds of continual buttons pressed.




  • clear the Cache frequently


    • email Apps, browsers, social media Apps, etc.




  • Uninstall unused 3rd Party Apps.

Reply
Options

3 Posts

05-03-2013

United States

0 Signins

0 Page Views

  • Posts: 3
  • Registered: ‎05-03-2013
  • Location: United States
  • Views: 0
  • Message 13 of 19

Re: What are your Electrify M Issues

2013-05-03, 15:38 PM
Well, first, USCellular performs tbe *228 on these phones. Second, they recommend if you leave "your normal calling area" that you perform the *228.

Second, the power-cycle thing. They said it to me yesterday, but it's not in the manual. We should be told that when we get the phones, because we've all been told how bad it is for computers to be turned on/off daily.
Reply
Options

2027 Posts

12-04-2009

United States

39 Signins

756 Page Views

  • Posts: 2027
  • Registered: ‎12-04-2009
  • Location: United States
  • Views: 756
  • Message 14 of 19

Re: What are your Electrify M Issues

2013-05-03, 15:54 PM


Snowflake said:

Well, first, USCellular performs tbe *228 on these phones. Second, they recommend if you leave "your normal calling area" that you perform the *228. Second, the power-cycle thing. They said it to me yesterday, but it's not in the manual. We should be told that when we get the phones, because we've all been told how bad it is for computers to be turned on/off daily.View original


I agree with you... just do this before you leave, and not out of their (strong signal) tower area.

Reply
Options

3 Posts

05-03-2013

United States

0 Signins

0 Page Views

  • Posts: 3
  • Registered: ‎05-03-2013
  • Location: United States
  • Views: 0
  • Message 15 of 19

Re: What are your Electrify M Issues

2013-11-26, 22:49 PM


 



Yep, this is exactly what has happened to my Electrify M...


 


NOW FOR THE 3rd TIME!


 


USCellular's service is patient and understanding, and dammit I want to love this phone. When it's stable and functioning, it's awesome. But now it's going to go in again, and I'll get another , but neither Motorola nor USC can tell me what's going on. 


 


I spend more time on hold and in my USC store than I do any other store, and that's not a good thing...


 


 



Snowflake said:


I'm on my second M since Dec 2012, and just started experiencing the same issues I had on my first: I have constant connectivity issues, I can't trust my phone, I can't hear the sound to radio apps when I am connected. Even performing restarts, *228, and turns on/off only temporarily fix things. When I make calls, I can hear the call connect, and hear the first bit of conversation, then nothing. 



While USCellular has great service, and Motorola has stood behind their product, it took them a month to get me a replacement the first time, and I'm about to go through it again. The S4 is looking really good right about now.


View original


 

Reply
Options

1 Posts

03-24-2014

Spain

0 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎03-24-2014
  • Location: Spain
  • Views: 0
  • Message 16 of 19

Re: What are your Electrify M Issues

2014-03-24, 17:22 PM


Motorola obviously has an issue with this phone.  I can relate to each and every issue!!  Recently, I had to replace my phone..which was no longer under warranty.  Contacting customer support got me just another number to call.  My phone has shown me the DEAD android...I think that is very interesting.  When I called my cellular provider in regard to my issues, I was told that this particular phone has been causing a lot of issues for several people.  Recall??



I have since gone to a Galaxy s4.  Unfortunately, I wasn't "eligible" for an upgrade, but since Motorola didn't make it through my contract period, I was left with no choice put to fork out MORE money for a phone I should have never had to replace!

Reply
Options

1 Posts

04-12-2014

Germany

0 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎04-12-2014
  • Location: Germany
  • Views: 0
  • Message 17 of 19

Re: What are your Electrify M Issues

2014-04-12, 21:28 PM
My M has had the same issues twice. My WiFi will never stay connect instead it drops constantly. Also I can't hear anything through the ear speaker when someone calls, but they can hear me just fine. Sometimes if I turn on speaker phone I can hear them, but then the phone turns speaker off and like the WiFi it will come back on for a second then off again!!! What really irritates me is this has happened to 2 electrify M's. The first one was under warranty, but my second phone is not. I do have insurance but at this point I don't want to pay $100 for another pos phone. Going to be upgrading as soon as my contracts out to a Samsung or iPhone not sure which. I can definitely say I will never own a Motorola phone again!
Reply
Options

3 Posts

09-18-2015

Canada

0 Signins

0 Page Views

  • Posts: 3
  • Registered: ‎09-18-2015
  • Location: Canada
  • Views: 0
  • Message 18 of 19

Re: What are your Electrify M Issues

2015-09-18, 8:25 AM

i have almost the same issue, when i am in a area where the signal is strong the xt901 could detect it, but when i am in the area the signal is weak, the phone would lost connection, it's terrible now ....



BTW, my xt901 would detect wifi signal very well, only the phone signal is weak.



i am looking for information online now, but i still can not get any useful words. Any suggestions or solution will be appreciated.



 

Reply
Options

2027 Posts

12-04-2009

United States

39 Signins

756 Page Views

  • Posts: 2027
  • Registered: ‎12-04-2009
  • Location: United States
  • Views: 756
  • Message 19 of 19

Re: What are your Electrify M Issues

2015-09-18, 13:12 PM
US Cellular do software updates with their towers. After an update they did last Spring my phone did the same thing. The last phone update also effected it.

Did you call USC tech. service to see if they have any help to offer.

I finally got a newer model phone.

Sorry, not much help.

POKO
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms