Motorola Community

Older Devices ArchiveMOTOROLA MOTOACTV™
All Forum Topics
Options

2 Posts

07-14-2013

Australia

0 Signins

0 Page Views

  • Posts: 2
  • Registered: ‎07-14-2013
  • Location: Australia
  • Views: 0
  • Message 1 of 1

MotoCast Fails Install + Reset Won't Clear Data

2013-07-14, 16:47 PM


Hello All,



Amadist all the other background noise, I am thankful that a forum is still provided for MOTOACTV support and I hope that this post falls under the eyes of someone who can guide me to a fix. So let's get to it --



Hardware

Computer - ThinkPad T420

OS - Windows 7 Pro 64

MOTOACTV - 8GB North American model

USB Cable - Yes, I *always* connect with the original Motorola cable that came with the device (and have tried multiple other 3rd-party cables that have worked with the device previously, as well)



Software

MOTOACTV Firmware - Currently 1.7.10 N8 (also had 1.7.12, more about that later)

MotoCast 2.0.31 Installed (Download directly from MyMotoCast.com)

Motorola Device Manager 2.3.9 Installed (upgraded from 2.3.5 via MotoCast after install)

Device is not and has never been rooted (100% sure)

***MotoHelper_2.1.40_Driver_5.5.0 is ***NOT*** listed as an install in windows Programs and Features



Services

MotoCast.exe (User)

MotoCast-thumbnailer.exe (User)

MotoHelperAgent.exe (User)

MotoHelperService.exe (SYSTEM)



Problem Description



Starting a few weeks ago, MOTOACTV was longer invoking Motorola Media Link (mml.exe) when connected to computer. Further, upon manually launching mml.exe, it would display that no motorola device was detected.



I have uninstalled and reinstalled the software several times from separate, repeat downloads of the MotoCast installer, direct from MyMotoCast.com (to ensure the file was not corrupted), always ending up with the same result - the device install fails with a "Driver Not Found" error in Windows and ends up listed in Device Manager under "Other Devices" as "F100" (the MotoActv's model name, I know). I have also tried invoking the install from the device itself, during one of many repeat attempts of issuing a Factory Reset through the device, which ends up yielding the same results, and of which the reset appears to delete user data, but does not delete my music files, confirmed by checking and available memory and seeing only about 500MB of free space left with about 6.5GB of music... another perplexing issue in and of itself...



One interesting note on the drivers --  ever since the initial uninstall of the program software, the MotoHelper driver has never been listed again in the windows list of Programs and Features. FYI, I always use Revo Uninstaller free on Advanced mode for my uninstalls -- deleting all of the leftover registry entries and files -- to truly "erase" the program (or as best as I am able to tell).



After all this, more googling, forum research (here, xda, etc.) eventually led to the procurement of fastboot, adb, and a stock rom to try and aid in an ultimately valid/full reset. Stuff I've tried in fastboot from the command line in windows:

fastboot -w (to erase all userdata)

fastboot erase userdata (to erase the userdata partition)

I found this link to more fastboot commands, but I am hesitant to get too aggressivel

Curiously enough, when trying to issue any "format" commands in fastboot, they all fail -- probably because I'm not logged in as root I take it?

I also downloaded and ran a .bat-driven re-flash of a stock 1.7.10 N8 rom, thinking that might help,  following some guidance on xda (NOTE: I'm *NOT* looking to root; in fact, I could care less about root, I just want the thing to work as advertised. If I have to later, I will, but only if instructed to do so by a Motorola employee)



Upon continually plugging the device in, uninstalling it's "F100" placeholder under "Other Devices" in Device Manager, reinstalling the software, factory resetting, trying things in fastboot, lather, rinse, repeat, I've reached the point of what Einstein called insanity -- doing the same thing over again and expecting different results.



Conclusion



So, as you can see, I've been through quite a bit to try and get this thing cleared and restored to a state that will allow it to work again. I'm quite sure, other than the MotoHelper_Driver.... not being listed as installed in Windows, that this is an issue with the device itself, and all that needs be done are the right commands in fastboot or adb, or whatever other command line or development tool needs to be used, in order to restore this thing to a working state.



I'd really appreciate the guidance of a high-level tech on this issue. Thanks for reading guys. Hopefully someone can help.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete