cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
grahamf
What's DOS?
Posts: 3
Registered: ‎10-02-2013
Location: United States
Views: 1,747
Message 1 of 2

Can't charge - stuck in reboot loop

I fell into this situation after leaving the phone to charge overnight.  For some reason it didn't charge properly and I now have a situation where the phone has absolutely no charge at all.



If I try to charge it, initially the green LED promisingly comes on.  Then after a while (variable - but appears to be when the charge level reaches around 4% to 5%), the phone boots up, stops charging and fairly quickly decides to shut down again - presumably because there isn't enough charge in the battery?  Then the LED starts flashing red for a while.  Eventually it will go green again and the cycle repeats - apparently indefinitely.



Does anyone have any suggestions for breaking this loop to allow the phone to charge up?



The behaviour is the same regardless of whether I try to charge via a PC or direct from the mains.  I've also tried to use the few seconds that it runs to turn off all of the radios etc. to give it a bit longer before it shuts down again - in the hope that it would somehow start charging while it's in the booted up but not charging state.

grahamf
What's DOS?
Posts: 3
Registered: ‎10-02-2013
Location: United States
Views: 1,747
Message 2 of 2

Re: Can't charge - stuck in reboot loop

As luck would have it not long after posting this I seem to have managed to fix it myself.



Just in case it helps someone else, here's what I did.



I had a hunch that the problem was the boot/stop charging/shutdown and that apart from that I had a good electrical connection and the battery was capable of accepting a charge.



So, for several iterations, I intercepted the boot at the initial M logo display and stopped it by pressing the down volume and power buttons simultaneously.  Unfortunately I can't remember how many iterations I went through, but I think it was at least 4 or 5.  On the first occasion once the phone stopped booting the green LED came back on but on subsequent repetitions it didn't - the LED just stayed off completely.  Then eventually I allowed the boot to proceed and found that it was showing 7% charge and continued charging - so then I just let it drop back to standby and continue charging and it carried on all the way up to 100%.



So - for the moment at least - all is well again.