cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rhyous1
What's DOS?
Posts: 1
Registered: ‎12-22-2011
Views: 622
Message 1 of 3

Xoom won't charge

A couple weeks ago the Xoom stopped charging. I took it to work to look at it and then it just started charging at work.

I brought it home and it was charging again at home too. I thought it must have been some fluke.

Only now it is doing it again. I have tried dozens of outlets, and they work for any other device but not for the Xoom. It won't charge.

The pin inside looks fine.

Like I said, it did this before and then started again, so I am not sure if anything actually "went out". If the charger or the Xoom had died, how did it start working again?

A bunch of people online have complained about this but no real solution other than "it might be the charger".

Is this a known issue with the charger or the xoom?

mortes
What's DOS?
Posts: 3
Registered: ‎12-21-2011
Location: Germany
Views: 622
Message 2 of 3

Re: Xoom won't charge

I had a similiar problem with my Nexus S. I plugged it in to recharge over night. The next morning the device had powered off because it didn't recharge at all. I tried it at a different outlet and it worked the first moment until I placed it on the cupboard. It took me some time to find out that the recharge cable had a cable break at some point. Replacing it fixed the problem.


Of course you could try to stabelize the specific point of the cable with tape as well. Anyway, I'd guess it's the same issue.

liam_slack
What's DOS?
Posts: 1
Registered: ‎03-15-2012
Location: United States
Views: 622
Message 3 of 3

Re: Xoom won't charge

It's a known issue to me. I just went two weeks trying to get someone at Motorola to respond adequately to the same issue (they wanted me to go to the Verizon store and ask to borrow a charger to troubleshoot it). When I refused, they sent me a new charger. Now my Xoom will charge with EITHER charger -which indicates to me that there is an issue with the tablet itself, in that it clitches and refuses to accept a charge.


Unfortunately I can't complain until it stops working again. Which, in my opinion, it inevitably will. A cursory Google search turns up a great many others having charging issues with their Xooms, but according to Motorola, they "can't say for sure if this issue is known or common." Apparently the good folks at Motorola can build a device to run a Google OS, but can't figure out how to use their search engine.


As for me, I've now had a Droid on which the touch screen inexplicably failed, and a tablet which refuses to charge at random. In short, I've never been closer to moving to iOS.