Motorola Community

Moto G PhonesMoto G4 / Moto G4 Plus / Moto G4 Play
All Forum Topics
Options

3 Posts

01-08-2017

US

11 Signins

98 Page Views

  • Posts: 3
  • Registered: ‎01-08-2017
  • Location: US
  • Views: 98
  • Message 91 of 245

Re: Moto G4 SIM card not detected/dissapears

2017-01-15, 3:38 AM
Tried my sim in wife's phone overnight and was still working in am. Ended up contacting Straight Talk and after 3 phone calls/2 hours on the phone with 3 different reps finally got the phone activated with her sim card. Now to see if it will stay connected now that it's activated.
Reply
Options

6 Posts

01-02-2017

US

22 Signins

229 Page Views

  • Posts: 6
  • Registered: ‎01-02-2017
  • Location: US
  • Views: 229
  • Message 92 of 245

Re: Moto G4 SIM card not detected/dissapears

2017-01-17, 1:37 AM

 Update on the cause for my sim error.  It was due to using ATT's "turn off data" under account management.  The phone should and still worked for a bit after a reset but gets a "no sim detected error".

 

My billing cycle was up 2 days ago, I re-enabled data on that device and has not happened again.  So there is data point for you Lenovo. That's still some kind of bug that you can't disable data at the carrier level.

Reply
Options

3 Posts

01-08-2017

US

11 Signins

98 Page Views

  • Posts: 3
  • Registered: ‎01-08-2017
  • Location: US
  • Views: 98
  • Message 93 of 245

Re: Moto G4 SIM card not detected/dissapears

2017-01-17, 2:43 AM

Wife's phone still working great since sim activation.

Reply
Options

3 Posts

02-05-2015

US

113 Signins

662 Page Views

  • Posts: 3
  • Registered: ‎02-05-2015
  • Location: US
  • Views: 662
  • Message 94 of 245

Re: Moto G4 SIM card not detected/dissapears

2017-01-17, 16:04 PM

All,

 

I work for Lenovo in Services, and wanted to share my solution for this problem.  I bought the G4 Plus directly from Moto, preloaded with an AT&T nano SIM card.  I had the exact same symptoms for the G4 Plus that I bought for my mother-in-law:  after about an hour, I'd get SIM card error.

 

I almost returned the phone before even giving it to her, but decided to try and move her old phone's micro SIM card to the new phone (even though the card is 4 years old), and that worked.  I'm sure it's because the SIM card was already activated on the AT&T network.  I wondered if it was a hardware issue since I was no longer using the plastic nano adapter, but I doubt that can be the issue since the SIM card stayed connected for about an hour (consistently), then lost its connection.  It's been working for 4 days now, so I'm hoping that it's a permanent fix!

 

I also bought G4 Pluses for my parents back in August, and couldn't get them activated on the Verizon network (not Moto's problem...was Verizon's).  They were their first smartphones ever (yes, in 2016!), so I didn't have existing SIM cards to try.  I spent 2 hours at a store before they finally took SIM cards from existing phones, put them into the new phones, got them activated on the network, then put my parents' new SIM cards back in.

 

I hope this helps, though it sounds like some folks on this thread had working phones for several weeks, then they all of a sudden stopped working.  Maybe this will help new G4 users.

Reply
Options

28 Posts

01-17-2017

NZ

35 Signins

758 Page Views

  • Posts: 28
  • Registered: ‎01-17-2017
  • Location: NZ
  • Views: 758
  • Message 95 of 245

Re: Moto G4 SIM card not detected/dissapears

2017-01-18, 7:50 AM

Mine randomly disconnects the SIM in slot 1.  Slot 2 is empty.

Do you think I should go to the 2Degrees shop and get them to try a different SIM?

It's hard to know if it has fixed the problem as I can't reproduce it on demand, it just happens a couple of times a day at random.

 

Reply
Options

5 Posts

01-10-2017

US

8 Signins

76 Page Views

  • Posts: 5
  • Registered: ‎01-10-2017
  • Location: US
  • Views: 76
  • Message 96 of 245

Re: Moto G4 SIM card not detected/dissapears

2017-01-18, 19:22 PM

I'm sure unrelated to most issues posted here but my issue was, it appears, to be hardware related to the SIM card port on the first phone I received.  I returned the phone to Amazon and ordered an identical phone.  The second phone recognized and attached to the AT&T network immediately.  It has been running now for a few hours so I'm hopeful that it was related to hardware and not software.

 

Good luck.

Reply
Options

28 Posts

01-17-2017

NZ

35 Signins

758 Page Views

  • Posts: 28
  • Registered: ‎01-17-2017
  • Location: NZ
  • Views: 758
  • Message 97 of 245

Re: Moto G4 SIM card not detected/dissapears

2017-01-21, 5:40 AM

(with the risk of duplicate posting) my SIM finally died and I went back to the store for a replacement.

Hoping the new one keeps working (tho my pessimistic inner voice says; if one was bad, the store prolly has a whole batch of bad SIMs) and I am hoping my phone just keeps on working correctly from now on.

 

 

Reply
Options

11 Posts

01-28-2017

US

42 Signins

121 Page Views

  • Posts: 11
  • Registered: ‎01-28-2017
  • Location: US
  • Views: 121
  • Message 98 of 245

Re: Moto G4 SIM card not detected/dissapears

2017-01-28, 19:48 PM

I had this problem with three G4s in a row from CC.  The phones and the sim cards turned out to be OK.  The fix for me was to go to my CC account and turn on $2.50/month worth of data time.  My phone then received 38 megs of up-dates and worked fine.  I then went into my G4 phone settings and turned off data and background data.  The phone now works without using any data time.  I am going to keep paying the $2.50 a month for data so if I'm not in a WiFi area I can turn data back on in my phone and access the internet if I need to.

 

If this helps you let me know.

Reply
Options

1 Posts

02-08-2017

IN

2 Signins

13 Page Views

  • Posts: 1
  • Registered: ‎02-08-2017
  • Location: IN
  • Views: 13
  • Message 99 of 245

Re: Moto G4 SIM card not detected/dissapears

2017-02-08, 8:17 AM

My Sim was not getting detected. I have a 4G Micro SIM and use only one Slot (Slot 1) in my Moto G4 plus phone. My location is India.

I tried the advice below and rebooted in Safe Mode. Went to Settings ->Sim Cards. Enabled SIM slot 1 (It was off for some reason) and started getting network coverage. 

 

Thanks.

 


wrote:

Most issues with previous gen G you mention have been tracked to cut down SIM cards. 

 

Since your problem is reproducible, try restarting in safe mode. To reboot into safe mode, tap the power button until you see power off on screen. Then tap and hold power off (on screen) and a new menu will appear to reboot into safe mode.

 

If that improves things, some app is the culprit. If not, try a phone factory data reset. If the problem persists, then your phone may need service. 


 

Reply
Options

2 Posts

02-12-2017

IN

3 Signins

84 Page Views

  • Posts: 2
  • Registered: ‎02-12-2017
  • Location: IN
  • Views: 84
  • Message 100 of 245

Re: Moto G4 SIM card not detected/dissapears

2017-02-12, 4:52 AM

Hi CMLZ,

If you are getting the above error for your Motorola smart phone, then carefully follow the given steps to solve it. 

  • Slide from top to bottom and hit the button in the top right.
  • Open the settings page and select dual SIM settings.
  • Touch and disable SIM 1.
  • Retouch on it and enable SIM 1
  • This method worked like a charm for me, hopefully it would work the same for you. If you are still having the problem, you should check out something more.

Also Try This

  • Remove the inactive SIM and put it in the other slot.
  • After enabling the SIM, Restart your phone. Check the functionality of SIM slot using a new SIM.
  • Check if the SIM is inserted correctly or not, if not, try placing it in the correct position.

I found this helpful information here..

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete