cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Senior MotoAgent
Senior MotoAgent
Posts: 3,991
Registered: ‎12-04-2017
Location: IN
Views: 647
Message 21 of 68

Re: G4 play proximity sensor not working after update


@DavidLópezArce wrote:

Please keep me posted too in case you find out a solution for this problem. Is really annoying.


Sorry to hear about the ongoing issue, may I know if you have tried the above steps if yes, could you share us your observation on this?

 

Thanks,

Swaraj

Motorola Support

Senior MotoAgent
Senior MotoAgent
Posts: 3,991
Registered: ‎12-04-2017
Location: IN
Views: 645
Message 22 of 68

Re: G4 play proximity sensor not working after update


@Pronab77 wrote:

Hi Swaraj,

Facing same issue. Tried weeping out part also but issue is still same. I have updated my IMEI #. Please help me to fix the issue.


Hi, Pronab77.

 

Could you please describe the issue, and let us know -- when are you facing this issue? Are you able to replicate in safe mode? Also, let us know if you have already tested in device help app-- if yes, share us your observation.

 

Thanks,

Swaraj

Motorola Support

Pronab77
Fanfold Paper
Posts: 6
Registered: ‎02-17-2018
Location: IN
Views: 638
Message 23 of 68

Re: G4 play proximity sensor not working after update

Thanks for the reply Swaraj.

The issue started after the OS upgradation. When ever I try to make call or received a call the screen goes black. Even I am unable to disconnect the call. After observing for few days I called your customer care, they have suggested all above steps and I performed those steps but still no success. Also the customer care suggested that it may happen due to some app so I formatted my phone. And now it has only the basic default apps. Really struggling with the issue. Also device help test is showing nagative for proximity sensor, rest all are working fine. Please help.

Senior MotoAgent
Senior MotoAgent
Posts: 3,991
Registered: ‎12-04-2017
Location: IN
Views: 628
Message 24 of 68

Re: G4 play proximity sensor not working after update


@Pronab77 wrote:

Thanks for the reply Swaraj.

The issue started after the OS upgradation. When ever I try to make call or received a call the screen goes black. Even I am unable to disconnect the call. After observing for few days I called your customer care, they have suggested all above steps and I performed those steps but still no success. Also the customer care suggested that it may happen due to some app so I formatted my phone. And now it has only the basic default apps. Really struggling with the issue. Also device help test is showing nagative for proximity sensor, rest all are working fine. Please help.


Hi, Pronab77.

 

Thank you for your response, this is strange-- If you did a factory data reset and tested BEFORE installing or restoring ANY apps, and the problem persists, then service/repair is next step so that our repair engineer team can diagnose your device and help you accordingly.

 

Thanks,

Swaraj

Motorola Support

DavidLópezArce
Fanfold Paper
Posts: 10
Registered: ‎05-12-2018
Location: MX
Views: 612
Message 25 of 68

Re: G4 play proximity sensor not working after update

Yes, I tried everything that people already did.
I noticed that if I start my phone in safe mode, and I try a call, the proximity sensor works well.
I think one app is making nosie. I tried that after my phone clean (wipe and reinstalled).
Same case.

Senior MotoAgent
Senior MotoAgent
Posts: 3,991
Registered: ‎12-04-2017
Location: IN
Views: 596
Message 26 of 68

Re: G4 play proximity sensor not working after update


@DavidLópezArce wrote:

Yes, I tried everything that people already did.
I noticed that if I start my phone in safe mode, and I try a call, the proximity sensor works well.
I think one app is making nosie. I tried that after my phone clean (wipe and reinstalled).
Same case.


Hi, DavidLópezArce.

 

Thank you for writing us, as we know that it is working in safe mode which redirects the case to third-party apps. Well if you could try factory data reset without restoring any apps, this might address your concern and resolve the issue in your case.

 

Thanks,

Swaraj

Motorola Support

Dabola
Punch Card
Posts: 9
Registered: ‎05-07-2018
Location: NO
Views: 554
Message 27 of 68

Re: G4 play proximity sensor not working after update

Hello again, Swaraj!

Have you found out anything more I could try to circle in the problems?   I am 99% sure it has nothing to do with third party applications, as long as it's the same in Safe Mode.   I have actually swithced off several apps:  Hangouts, Youtube, Maps,  Google inndata for japanese, korean, pinyin, zhuyin, indian, Google play music, Google play movies,  Gmail, FM-radio, Disk, CQATest  and Cloud Print.  This shouldn't make any problem?  

 

It's strange.  Others get problems when they call out.  For me its opposite; only when others are calling and the screen are not active.  Let me repeat;  Your advice to clear the Cache Partition helped (but not solved the problem);   After that I am able to activate the screen by the >Power button.  Then >Return back to active call and >Reply.  I am 100% sure that the power button had no effect the previous weeks before wiping the Cache Partition.  What does that tell us?  

 

helmarfernandes
Paper Tape
Posts: 6
Registered: ‎11-08-2017
Location: BR
Views: 547
Message 28 of 68

Re: G4 play proximity sensor not working after update

Here is how is working (or not working) on my phone.


When I call someone, once the phone starts dialling the screen turns off.

When someone calls me I can see it and answer. Once I answer (even before getting the phone close to my ear) the screen turns off.

When I get a Whatsapp voice message and click "play" the screen turns off and the sound gets very low so that we only can hear if we bring the phone close to the ear (doesn't look like a safety feature?)

 

That's it. Very annoying and persistent since the 7.1 update.

Pronab77
Fanfold Paper
Posts: 6
Registered: ‎02-17-2018
Location: IN
Views: 510
Message 29 of 68

Re: G4 play proximity sensor not working after update

Hi Swaraj,

Really not happy with the solution you suggested. I  am looking for the specific answer, before the upgration my phone was working perfectly but why after upgrading it is behaving like that.

 

And also can you please suggest me a way to go back to my old original OS.

Senior MotoAgent
Senior MotoAgent
Posts: 3,991
Registered: ‎12-04-2017
Location: IN
Views: 440
Message 30 of 68

Re: G4 play proximity sensor not working after update


@Dabola wrote:

Hello again, Swaraj!

Have you found out anything more I could try to circle in the problems?   I am 99% sure it has nothing to do with third party applications, as long as it's the same in Safe Mode.   I have actually swithced off several apps:  Hangouts, Youtube, Maps,  Google inndata for japanese, korean, pinyin, zhuyin, indian, Google play music, Google play movies,  Gmail, FM-radio, Disk, CQATest  and Cloud Print.  This shouldn't make any problem?  

 

It's strange.  Others get problems when they call out.  For me its opposite; only when others are calling and the screen are not active.  Let me repeat;  Your advice to clear the Cache Partition helped (but not solved the problem);   After that I am able to activate the screen by the >Power button.  Then >Return back to active call and >Reply.  I am 100% sure that the power button had no effect the previous weeks before wiping the Cache Partition.  What does that tell us?  

 


Hi,

 

It would be great if you can share us a video showing the actual issue for us to further look into the same.

 

 

-Swaraj

Top Kudoed Authors