cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Pakool121
Blue Screen Again
Posts: 1
Registered: ‎07-10-2019
Location: IN
Views: 512
Message 1 of 8

Many apps not working on wifi since update moto G4 plus

Since they new update I am facing problems to open apps while connected through wifi, first I thought its internet service providers fault, but than I realise its just not working in my perticular handset, and this happens after an os update, using moto G4 plus. Some apps are like - Netflix, Amazon, Kindle, unacademy app, and so on. Kindly remove the fault 

Senior MotoAgent
Senior MotoAgent
Posts: 6,032
Registered: ‎12-04-2017
Location: IN
Views: 489
Message 2 of 8

Re: Many apps not working on wifi since update moto G4 plus


@Pakool121 wrote:

Since they new update I am facing problems to open apps while connected through wifi, first I thought its internet service providers fault, but than I realise its just not working in my perticular handset, and this happens after an os update, using moto G4 plus. Some apps are like - Netflix, Amazon, Kindle, unacademy app, and so on. Kindly remove the fault 


Hi Pakool121,

 

Could you perform clear cache/data on all the apps --make sure the app is updated to the latest version available on the Play Store and test again to see if that makes any difference? You can also try testing with different WiFi connection to see if that helps?

 

Let us know how it goes?

 

Regards,

Swaraj

Motorola Support

If you need a reference in updating your profile, please click this link. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943
Highlighted
jcolls
What's DOS?
Posts: 1
Registered: ‎07-11-2019
Location: GB
Views: 486
Message 3 of 8

Re: Many apps not working on wifi since update moto G4 plus

Seems to be the same issue reported here: https://forums.lenovo.com/t5/Moto-G6-Moto-G6-Plus-Moto-G6/Certain-apps-not-working-on-home-WiFi-Moto...

 

For me personally I think the problem is related to a router conflict and something to do with IPv6.

 

I can connect via wifi on other networks and use the apps that I can't connect to on my wifi.  I can also conenct to the apps via 3/4G which rules out any problem with the Apps themselves. 

 

Other phones on my wifi can connect to the apps fine.   So it does point to a conflict between my local wifi and my phone.

The problem occurred when updating to Pie.   We have two Moto's (G6 and G7) and both have the same problem.

 

 

 

 

 

Amazon_Customer
Serial Port
Posts: 52
Registered: ‎10-06-2018
Location: GB
Views: 456
Message 4 of 8

Re: Many apps not working on wifi since update moto G4 plus

Moto G4 is still on Android 7.0 and working o.k. 

 


@jcolls wrote:

Seems to be the same issue reported here: https://forums.lenovo.com/t5/Moto-G6-Moto-G6-Plus-Moto-G6/Certain-apps-not-working-on-home-WiFi-Moto...

 

For me personally I think the problem is related to a router conflict and something to do with IPv6.

 

I can connect via wifi on other networks and use the apps that I can't connect to on my wifi.  I can also conenct to the apps via 3/4G which rules out any problem with the Apps themselves. 

 

Other phones on my wifi can connect to the apps fine.   So it does point to a conflict between my local wifi and my phone.

The problem occurred when updating to Pie.   We have two Moto's (G6 and G7) and both have the same problem.

 

 

 

 

 


There was an article from 2017 that mentions problems with android phones and IPv6 DNS settings. (Google 'android IPv6 / DNS settings Sean' which seems to describe these problems )

Pakool_121
Paper Tape
Posts: 2
Registered: ‎07-10-2019
Location: US
Views: 445
Message 5 of 8

Re: Many apps not working on wifi since update moto G4 plus

yes, I performed few tricks like updating the app and clear cache or rebooting the wifi/ phone but found that it's just this mobile of mine which is not working on wifi for certain apps while in others phones are working normally, this problem occurred when I updated my phone with the latest software.

Senior MotoAgent
Senior MotoAgent
Posts: 6,032
Registered: ‎12-04-2017
Location: IN
Views: 396
Message 6 of 8

Re: Many apps not working on wifi since update moto G4 plus


@Pakool_121 wrote:

yes, I performed few tricks like updating the app and clear cache or rebooting the wifi/ phone but found that it's just this mobile of mine which is not working on wifi for certain apps while in others phones are working normally, this problem occurred when I updated my phone with the latest software.


Thanks for reverting, so it only happens on your Home Router correct? We would suggest contacting your local Network provider to rest your Home router and device and try again. In the meantime, let me have this escalated to our team.

 

Please help us with your device build number, make & model of your router along with the settings and update your profile with your device IMEI.

 

Need help updating your profile: https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943

 

Let us know if you have any questions?


Regards,

Swaraj

Motorola Support

 

If you need a reference in updating your profile, please click this link. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943
Pakool_121
Paper Tape
Posts: 2
Registered: ‎07-10-2019
Location: US
Views: 391
Message 7 of 8

Re: Many apps not working on wifi since update moto G4 plus

The first thing I did was complaining to my internet service provider, it found out that it's just my phone which is having an issue, rest of the other devices are working fine in same network. This makes me conclude that it's the phone which is not normally working

Senior MotoAgent
Senior MotoAgent
Posts: 6,032
Registered: ‎12-04-2017
Location: IN
Views: 332
Message 8 of 8

Re: Many apps not working on wifi since update moto G4 plus


@Pakool_121 wrote:

The first thing I did was complaining to my internet service provider, it found out that it's just my phone which is having an issue, rest of the other devices are working fine in same network. This makes me conclude that it's the phone which is not normally working


Thanks, let me have one of our team members take a look into this for you. Please share additional information as requested earlier. Also, kindly have your device tested with different WiFi router just to rule out the possibilities to see if it works in Safe Mode.

 

Keep us posted!

 

Regards,

Swaraj

Motorola Support

 

 

If you need a reference in updating your profile, please click this link. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943
Top Kudoed Authors