cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
robtimus
What's DOS?
Posts: 1
Registered: ‎07-25-2018
Location: NL
Views: 1,442
Message 271 of 280

Re: Moto g4 with no sound

Weird enough, this worked for me. I used Youtube...

 

https://www.quora.com/My-Moto-E-speakers-are-not-working-How-can-I-fix-it

 

Solution 2

Play any song and click the power button (not to power off your device). Now hit the device on your lap a couple of times such that the speakers only get touched. This sounds a bit creepy/crazy but bharat Mei thapad se he kaam chalta hai. This will surely work, I'm 99.99% sure. If your device falls under that 0.01% category follow the third solution.

Rasalom
What's DOS?
Posts: 1
Registered: ‎08-04-2018
Location: US
Views: 1,332
Message 272 of 280

Re: Moto g4 with no sound

robtimus is right... If you smack the phone around, the sound will work. I tested his theory on mine since nothing else worked, and my sound started working. What I also found out was that if you squeeze the phone, or press on it like you're going to break it in half, the sound will respond to your pressure and work or not work. Right now, if I squeeze my phone in my hand, the sound will stop as long as I squeeze it. If I release the pressure, the sound comes back on instantly. There's something wrong with the phone motherboard, most likely. Most important, this proves it's a physical issue, not something users are doing to their phones on purpose or with software. This is a phone defect and anyone with this issue should be given a new phone to compensate for bad design flaws.

focarroll
What's DOS?
Posts: 1
Registered: ‎08-16-2018
Location: US
Views: 1,176
Message 273 of 280

Re: Moto g4 with no sound

Hi,

 

I also have this problem except this occurred after I dropped my phone on the ground. Can someone please help me, and if not, lead me to someone who can?

 

Thanks

Stefan101
What's DOS?
Posts: 2
Registered: ‎06-26-2018
Location: DE
Views: 1,157
Message 274 of 280

Re: Moto g4 with no sound

I sent my phone in and they said they can repair it for 195 €.

SantiagoHdzC
What's DOS?
Posts: 1
Registered: ‎09-30-2018
Location: MX
Views: 745
Message 275 of 280

Re: Moto g4 with no sound

I tested in safe mode and it worked, but I need to use my apps, I think it is not a comfortable solution, another? Please

Moto Sr Moderator
Moto Sr Moderator
Posts: 27,234
Registered: ‎02-02-2016
Location: US
Views: 736
Message 276 of 280

Re: Moto g4 with no sound


@SantiagoHdzC wrote:

I tested in safe mode and it worked, but I need to use my apps, I think it is not a comfortable solution, another? Please


One of your apps is the problem, you need to determine which one. There is no easy way other then to uninstall each one that could be related to sound. 

 

I find it easier to reset, and start from scratch. Testing after each app is installed. If you do this, do not restore a backup as it just installs the problem app. 


* Search box is your friend * I don't respond to PM if question belongs in forum
MsCherryDrop
Paper Tape
Posts: 1
Registered: ‎10-17-2018
Location: GB
Views: 549
Message 277 of 280

Re: Moto g4 with no sound

I have had this same issue for 3 days. No sound and unable to make calls. I solved a video playback issue with a factory reset, there are currently no 3rd party apps on the phone and sound only works with Bluetooth (not useful when I need the phone to make calls etc). I've done all the troubleshooting I can find and performed the Device Help tests. Still nothing. Oddly enough, the sound works on the startup sequence when the phone was reset so it can't be a hardware issue and has to be a software issue. Version 7.0 is used on this phone and just stopped working for no reason when several apps updated (again, no 3rd party apps on phone so now out of options). I even ejected my SD card as that caused issues on my old Samsung but it had no effect.  Any help would be appreciated.

geistverfasser
What's DOS?
Posts: 1
Registered: ‎11-22-2018
Location: US
Views: 233
Message 278 of 280

Re: Moto g4 with no sound

This is definitely a software issue.

I've had my G4 Plus since early 2016 with no sound issues. I've never dropped it. No way it's hardware or damage.

Within the past few days, all audio stopped working.

No audio. Can't listen to voicemail--they won't even play, not that I just can't hear the sound.

I can't watch videos I've taken with the phone--they won't even play, and I get an error message.

I can't record anything with the microphone.

It's as though all audio playback and recording failed all at once.

I pretty much use Google's apps exclusively, or a handful of free apps from major developers. (I've never paid for an app in my life.)

A full reset worked to restore sound, but I opted to reinstall all the apps n stuff. This very quickly nerfed the audio after everything was updated.

Again, this is a software issue with the phone.
khpos
Paper Tape
Posts: 2
Registered: ‎12-05-2018
Location: US
Views: 126
Message 279 of 280

Re: Moto g4 with no sound Success??

Lots of "me too" comments and useless reset procedures I think I found the cause and the fix on my phone. It was pretty clear to me it was a hardware issue from the getgo. Pressing on the back would make the problem come and go. Your problem may be different , but I saw quit a few comments about pressing on the back to get intermittent sound.

 

The following process could easily mess up your phone so proceed at your own peril. It takes some steady hands, proper tools (2 screw drivers) and a very good magnifying glasses to make this work. I will provide an outline of what I did, if it isn't sufficient detail for you should probably not try this.

 

I removed the back cover and then the back with its 16 screws (for details on how to remove the back: https://www.ifixit.com/Guide/Motorola+Moto+G4+Play+Charging+Port+Replacement/106129) Yes, there is a screw under a thin plastic tape cover to the right and below the camera. Removing this small "tape" cover will make it clear you messed around with the phone and void any warranty if you still have any. I am sure that is why that tape cover is there. Use the right tools for the job, please. 

 

Now, if you take the back cover off (very carefully) you will see some (8 or so??) gold looking  pads on that back that match up with tiny (Yes itty bitty TINY) spring connectors on the motherboard. Four of them appear to be for the speaker and I believe these spring connectors loose their electrical connection. That is why if you press on the back you may get your music back.

 

Grab your magnifying glass. It needs to be a good one. Above the camera on the motherboard there is a 1/2" x 3/8" metal cover (is this the speaker?, I think so) and immediatley next to it (bottom left and top left) are 2 tiny (did I mention they are small) metal springy things that connect to pads on the plastic back. If you look at the back you will see that the corresponding metal pads hook up to two other pads. Find the 2 other corresponding spring connectors on the motherboard. They are 3/16" to the left of the speaker. You have now identified 4 spring loaded connectors for the speaker. I first tried to clean the pads for a better connection. That did not really work.

 

Now comes the tricky thing and you will need some very strong magnifying glasses and a very small flat screw driver. If you look close you will see that the metal springs are attached on one side and open on the other side. Look at the clearance of the open side, put the small screwdriver under the open side and ever so gently lift it up just a very small amount. If you mess this up you are probably screwed, so be VERY carefull. Do this 4 times for the 4 spring connectors. There is probbaly only one that is causing the problem, but I could not find out which one, so I did all 4. If you do not see the open side of the spring connectors get a better magnifying glass. It is critical you see what you are doing.

 

Now put the back on and put in the 3 or 4 screws around the area that you just fixed. This will pull the 4 spring connectors together. Switch on the phone and see if that solved your problem. If you still need to press on the back to get sound try again and pull the spring connectors up just a hair more.

 

If you don't feel very comfortable working on this don't try it. It will be very easy to mess up your phone. A good repair shop should be able to this as well in 20 minutes.

 

Good luck and let me know if this works for you.

khpos
Paper Tape
Posts: 2
Registered: ‎12-05-2018
Location: US
Views: 112
Message 280 of 280

Re: Moto g4 with no sound Success??

Deleted

Top Kudoed Authors