cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lmaia
Blue Screen Again
Posts: 1
Registered: ‎01-21-2019
Location: PT
Views: 174
Message 1 of 2

Moto G5 cant connect to network 802.1x EAP

I bought 10 motorola G5, I connected all to a network 802.1x EAP, but three of them cant connect, it says "disabled" under the network name. Although this three can connect to a public network so its not a hardware problem. All the equipament its installed with oreo 8.1.

 

1. The configuration is the same as all the other 7 equipaments.

2. I tried also enter with different credentials, but the problem is the same.

3. I have tried to reset the network definitions, also did a factory reset, I hard reset multiple times, but still cant connect to the network.

4. Also tried to connect to the network without SIM card, but no luck either.

5. Also created a rule for the phone to have access with is mac addrees on the dhcp but still cant connect.

6. I took some screenshoots (attached) for debbugging, so you guys can take a look and maybe understand what the problem is.

Screenshot_20181212-121825.png

 

Screenshot_20181212-121835.png

 

Screenshot_20181212-121844.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

I tried almost every solution possible, except doing root to the phone. 

Hope you guys can help me. 

Thx in advanced.

Senior MotoAgent
Senior MotoAgent
Posts: 1,034
Registered: ‎10-08-2015
Location: IN
Views: 158
Message 2 of 2

Re: Moto G5 cant connect to network 802.1x EAP

Hi lmaia,

 

Welcome to Forums,

 

As per my knowledge, Android devices don't have the same protocols defined in other OS technologies have and the way the OS developer thinks. The Android Smartphones are wireless chipset devices, and it does not depend on the OS installed in a mobile device to have better compatibility, not like servers or routers.

 

When you setup a Corporate WiFi network, basically you command the system to use some protocols to connect to, included in the WPA2 system definitions. The system checks all of them until finding the right one to connect which need CA & SSL certifications.

 

Having said that Android doesn't have the same protocols defined in WPA2 system definitions, so if you try to connect to it by using the main Android interface, you will have an authentication error or security pop-ups.

 

Which means you might want to contact local IT if you are seeking any corporate company connection for which you need to download drivers, certifications in order to have internet access.

 

Request you to check the same & let us know.

 

Thanks & Regards
Nikh
Lenovo-Moto Support

Top Kudoed Authors