cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
vamsi_una
Paper Tape
Posts: 1
Registered: ‎01-11-2019
Location: IN
Views: 294
Message 1 of 4

Moto G5s plus charging issue: Charging stops and starts and again

Hi all,

I have my moto g5s Plus which suddenly has stopped charging.
Till now i have used only provided charger and today i checked with other charger it charges for very short time then stops and then after sometimes charges again.
I tried charging the device after poweroff but same issue persists.
The device is charging for sometimes and stops so if i leave it with port plugged in, it gets charged but in pulses so charging increase very slowly.

Any known issue ?

Is it a software or hardware issue ?

Senior MotoAgent
Senior MotoAgent
Posts: 903
Registered: ‎10-08-2015
Location: IN
Views: 258
Message 2 of 4

Re: Moto G5s plus charging issue: Charging stops and starts and again


@vamsi_una wrote:

Hi all,

I have my moto g5s Plus which suddenly has stopped charging.
Till now i have used only provided charger and today i checked with other charger it charges for very short time then stops and then after sometimes charges again.
I tried charging the device after poweroff but same issue persists.
The device is charging for sometimes and stops so if i leave it with port plugged in, it gets charged but in pulses so charging increase very slowly.

Any known issue ?

Is it a software or hardware issue ?


Hi vamsi_una,

 

Welcome to Forums,

 

Sorry for the inconvenience caused. The Motorola Turbocharger will charge the device at a faster rate when the device is below 78%. If the device is already at 78% or higher, it will charge at regular speed. Battery charging rate will start to slow down when the battery temperature reaches 44C or above. Once the device cools down, charging rate will go back to normal for Turbocharging. If your device is below 78%, but it does not begin Turbocharging when you plug it into the Turbo Charger, try unplugging and plugging back in using one fluid motion.

 

However, we request you to find this link & let us know.

 

Thanks & Regards
Nikh
Lenovo-Moto Support

 

AriefGusman
What's DOS?
Posts: 1
Registered: ‎01-12-2019
Location: ID
Views: 83
Message 3 of 4

Re: Moto G5s plus charging issue: Charging stops and starts and again

No no, I know what's happening with him/her. Because I have the same issue. It's happened since a week ago. So, when we plug our phone with the charger. It's showed up notification by "charging" on the screen, 2 seconds later, charging connection suddenly become off, there is no charging connection, and 2 seconds later, suddenly our phone in charging position again automatically BUT, (we use our original charger) They don't charge it in TurboPower mode, please help us. I have tried any models of charger and my battery condition is 10%.

vamsi_una1
What's DOS?
Posts: 1
Registered: ‎01-11-2019
Location: US
Views: 47
Message 4 of 4

Re: Moto G5s plus charging issue: Charging stops and starts and again


@AriefGusman wrote:

No no, I know what's happening with him/her. Because I have the same issue. It's happened since a week ago. So, when we plug our phone with the charger. It's showed up notification by "charging" on the screen, 2 seconds later, charging connection suddenly become off, there is no charging connection, and 2 seconds later, suddenly our phone in charging position again automatically BUT, (we use our original charger) They don't charge it in TurboPower mode, please help us. I have tried any models of charger and my battery condition is 10%.



Exactly.....you described my situation perfectly...and i too am having this issue since last week....
i guess moto people need to look the issue......now i need to plug in my charger for full night to get some workable charging...!!!

it charges for some duration which might be of seconds or minutes..and then stops charging...then after some duration again it starts charging...and this keep on happening....someone need to help us....

i though its hardware issue...but since you are facing same i believe its software issue.....but i belive the turbo techniqe is failure and that has caused this problem... :-/

Top Kudoed Authors