Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto G PhonesMoto G5 / Moto G5 Plus
All Forum Topics
Options

12 Posts

09-21-2015

United States of America

11 Signins

116 Page Views

  • Posts: 12
  • Registered: ‎09-21-2015
  • Location: United States of America
  • Views: 116
  • Message 1 of 7

Select USB Configuration doesn't hold

2017-04-24, 18:06 PM

When I connect via USB, the phone file system isn't initially visible in a File Manager (Windows 10). When I go to Developer Options to Select USB Configuration, MTP is already selected, but until I reselect it, the phone file system remains invisible. If I reselect it, the file system becomes visible. Is there a way to lock this feature so it works consistently?

/Tom

Reply
Answer
Options

28352 Posts

02-02-2016

United States of America

5842 Signins

132780 Page Views

  • Posts: 28352
  • Registered: ‎02-02-2016
  • Location: United States of America
  • Views: 132780

Re: Select USB Configuration doesn't hold

2017-05-02, 1:11 AM

wrote:

Let me restate. When I connect via USB, my phone connects as "Charge This Device" in notifications. I then switch it to "Transfer Files." How can I set it to use "Transfer Files" as the default?


You can't. Google set things this way as a security feature - so any usb port/charger is not secretly transferring files. 


* Search box is your friend * I don't respond to PM if question belongs in forum
Reply

Replies(6)
Options

3454 Posts

10-05-2016

Philippines

544 Signins

43827 Page Views

  • Posts: 3454
  • Registered: ‎10-05-2016
  • Location: Philippines
  • Views: 43827
  • Message 2 of 7

Re: Select USB Configuration doesn't hold

2017-04-24, 21:27 PM

Hi Tom_Marinello,

 

 When you plugged in your phone to your PC, where you able USB notification and set it to MTP through Notification bar of the phone?

 

Regards,
Jess
Motorola Support

Reply
Options

12 Posts

09-21-2015

United States of America

11 Signins

116 Page Views

  • Posts: 12
  • Registered: ‎09-21-2015
  • Location: United States of America
  • Views: 116
  • Message 3 of 7

Re: Select USB Configuration doesn't hold

2017-04-24, 22:57 PM

On this PC (Windows 7 Pro), I was able to connect right away, but the Notification Bar only displays "USB Debugging connected" & "Tap to disable USB debuging"

Reply
Options

471 Posts

03-08-2013

Germany

450 Signins

5250 Page Views

  • Posts: 471
  • Registered: ‎03-08-2013
  • Location: Germany
  • Views: 5250
  • Message 4 of 7

Re: Select USB Configuration doesn't hold

2017-04-25, 6:49 AM

Did you try with a 2.0 port or 3.0 port?

Reply
Options

28352 Posts

02-02-2016

United States of America

5842 Signins

132780 Page Views

  • Posts: 28352
  • Registered: ‎02-02-2016
  • Location: United States of America
  • Views: 132780
  • Message 5 of 7

Re: Select USB Configuration doesn't hold

2017-04-25, 12:41 PM

wrote:

On this PC (Windows 7 Pro), I was able to connect right away, but the Notification Bar only displays "USB Debugging connected" & "Tap to disable USB debuging"


If you dont have the pull down usb option to switch from charge to file transfer then cable or usb port is the problem.  

 

Usb debugging setting will not force phone into mtp mode. 


* Search box is your friend * I don't respond to PM if question belongs in forum
Reply
Options

12 Posts

09-21-2015

United States of America

11 Signins

116 Page Views

  • Posts: 12
  • Registered: ‎09-21-2015
  • Location: United States of America
  • Views: 116
  • Message 6 of 7

Re: Select USB Configuration doesn't hold

2017-05-02, 1:06 AM

Let me restate. When I connect via USB, my phone connects as "Charge This Device" in notifications. I then switch it to "Transfer Files." How can I set it to use "Transfer Files" as the default?

Reply
Answer
Options

28352 Posts

02-02-2016

United States of America

5842 Signins

132780 Page Views

  • Posts: 28352
  • Registered: ‎02-02-2016
  • Location: United States of America
  • Views: 132780
  • Message 7 of 7

Re: Select USB Configuration doesn't hold

2017-05-02, 1:11 AM

wrote:

Let me restate. When I connect via USB, my phone connects as "Charge This Device" in notifications. I then switch it to "Transfer Files." How can I set it to use "Transfer Files" as the default?


You can't. Google set things this way as a security feature - so any usb port/charger is not secretly transferring files. 


* Search box is your friend * I don't respond to PM if question belongs in forum

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms