cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Senior MotoAgent
Senior MotoAgent
Posts: 6,017
Registered: ‎12-04-2017
Location: IN
Views: 3,462
Message 11 of 30

Re: USB connection and turbocharging problem for Moto X4


@jithendra3wrote:

 I am using Moto X4 (Super Black, 64 GB, 4 GB RAM) and I m facing a problem is that when I m connecting my phone with my computer. It starts charging. There is no notification on my phone about usb connection. 

I want to trasfer data to my computer. What is the solution so that I can change charging to media transfer option.

 

And also I m facing Turbo charging problem , my phone is always going in "Charging Slowly" mode when connected for charging even when the battery is fully drained.

BTW I am using the USB cable that came along with Moto X4 only.


Sorry to hear about that, please try the above steps and let us know if that helps. In regards to "charging slow issues" may I know if you are able to notice "Turbocharging" on your screen? Could you try to calibrate your battery-- To do so, please force restart your device by the press and hold the power key unless your device is rebooted-- connect to the charger and let it charge till  100% leave it for an extra hour. Repete the process. Hope this helps.

 

Thanks,

-Swaraj

If you need a reference in updating your profile, please click this link. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943
jithendra3
Fanfold Paper
Posts: 4
Registered: ‎03-29-2018
Location: IN
Views: 3,460
Message 12 of 30

Re: USB connection and turbocharging problem for Moto X4

No, the above steps about usb connection didnt work and also I cant see turbocharging on my screen

Senior MotoAgent
Senior MotoAgent
Posts: 6,017
Registered: ‎12-04-2017
Location: IN
Views: 3,431
Message 13 of 30

Re: USB connection and turbocharging problem for Moto X4


@jithendra3wrote:

No, the above steps about usb connection didnt work and also I cant see turbocharging on my screen


Thank you for trying the steps, could you please share us few screen shots/pictures when you you try to connect your device via USB? What does it appear?

 

Regarding Turbocharging are you using origional charger and cable? Try to turn off your device and try and let us know if that still appears. Also, please share us few screen shots of the battery graph for us to look further.

 

Meanwhile, please update your profile with current phone, carrier and serial number -- this will help me investigate. Please make sure that the options under Settings > Motorola Privacy is on as well, and let me know (just reply here) if it's okay for me to look at your apps to see if they are a source of problems.

Update your profile -link

 

Thanks,

-Swaraj

If you need a reference in updating your profile, please click this link. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943
hello_motoG5
What's DOS?
Posts: 1
Registered: ‎04-25-2018
Location: US
Views: 3,273
Message 14 of 30

Re: USB CONNECTION PROBLEM

I used a different USB cable, and it worked! The original USB cable was working a few days ago, but when it broke, it worked for charging only. I couldn't transfer any files or photos with that old cable. Now I use a new cable. 

icanreachit
What's DOS?
Posts: 9
Registered: ‎05-06-2017
Location: US
Views: 3,020
Message 15 of 30

Re: USB CONNECTION PROBLEM

I was able to get the problem to go away by switching from a USB 3.0 port to a USB 2.0 port. Problem re-arrose when I switched back to a 3.0, and dissappeared again when I went 2.0. Same cable, same protocol on phone. No software changes on PC or phone. 

 

Guessing it's a coding issue that can be easily addressed by Lenovo next patch.

Moto Sr Moderator
Moto Sr Moderator
Posts: 28,232
Registered: ‎02-02-2016
Location: US
Views: 2,992
Message 16 of 30

Re: USB CONNECTION PROBLEM


@icanreachit wrote:

I was able to get the problem to go away by switching from a USB 3.0 port to a USB 2.0 port. Problem re-arrose when I switched back to a 3.0, and dissappeared again when I went 2.0. Same cable, same protocol on phone. No software changes on PC or phone. 

 

Guessing it's a coding issue that can be easily addressed by Lenovo next patch.


There was a USB 3.0 problem reported to google in the past - i thought it affected only mac computers, but maybe it was Windows also. It affected all brands and was something google had to fix - sounds like it may still be there. 


* Search box is your friend * I don't respond to PM if question belongs in forum
DGCA3
Fanfold Paper
Posts: 11
Registered: ‎07-03-2017
Location: US
Views: 2,931
Message 17 of 30

Re: USB CONNECTION PROBLEM

Ditto here. Won't connect to a 3.0, but will connect to 2.0 USB on the PC.
Moto Sr Moderator
Moto Sr Moderator
Posts: 28,232
Registered: ‎02-02-2016
Location: US
Views: 2,923
Message 18 of 30

Re: USB CONNECTION PROBLEM

USB 3.0 issues seem to affect most phones even with latest version of android

 

https://productforums.google.com/forum/#!topic/phone-by-google/EBTGfybo9cw

 

 


* Search box is your friend * I don't respond to PM if question belongs in forum
roshanr216
What's DOS?
Posts: 1
Registered: ‎06-06-2018
Location: IN
Views: 2,822
Message 19 of 30

Re: USB connection and turbocharging problem for Moto X4

i have same problem.
with my moto x play.
is your problem solved?
if yes then how?
ajayinagl
What's DOS?
Posts: 1
Registered: ‎08-15-2018
Location: IN
Views: 2,310
Message 20 of 30

Re: USB CONNECTION PROBLEM

This is also not working for me, I have to restart each time when ever I want to connect it with my PC. I don't know why. My friend has also the same problem, I guess this phone has this demerit. can we upgrade to latest version which will have this feature solved.

Top Kudoed Authors