cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JennaP
Paper Tape
Posts: 1
Registered: ‎01-09-2019
Location: US
Views: 141
Message 31 of 33

Re: "Invalid SIM CARD" for Moto G5 Plus after Android 8.1 update.

This topic should not be marked solved.  I have tried everything suggested and am still getting "Invalid SIM Card."

 

Error started out intermittently in November and a week ago permamanetly.  I've rebooted about a thousand times, cleared the cache, factory reset, even had Boost (Sprint) send me a brand new SIM card.

 

Same "Invalid SIM Card"

 

I need to be able to make actual phone calls with my phone. Anyone know if a real fix being worked on?

 

lugnuts
What's DOS?
Posts: 1
Registered: ‎01-12-2019
Location: US
Views: 94
Message 32 of 33

Re: "Invalid SIM CARD" for Moto G5 Plus after Android 8.1 update.

I started having this issue last night when I restarted my phone. it was working fine then I restarted it and after 2 minutes I get "invalid SIM card" tried everything in this thread and nothing has worked. even tried making a phone call and after hanging up it went back to invalid.

 

Come on Lenovo this issue is all over the internet with no solution from you. its ovbiously a software issue and in most cases it started after the 8.1 update., could the issue be with your 8.1 update? maybe send out a software update that actually fixes the problem

bhspam
What's DOS?
Posts: 1
Registered: ‎01-15-2019
Location: US
Views: 54
Message 33 of 33

Re: "Invalid SIM CARD" for Moto G5 Plus after Android 8.1 update.

I am also having this issue. I updated to 8.1 and then a week later started getting Invalid SIM card errors. I went and bought a new SIM card and swapped it out with Sprint. It has worked for a month and now I am getting the Invaild SIM card errors again. I have rebooted 20 times. The phone will connect to the spirint network for about 4 minutes and text will come in and then I will get the error message Invalid SIM and I will loose all connection to the network until I reboot the phone again. The SIM card can connect and work but not longer the 4 minutes. I really cant trust this phone to work reliably. I found a bunch of people complaining about this issue but I have not found a single person who has said they figure out a fix. This seems like a software bug in Android 8.1 but I can not find any confirmation from Motorolla. Anyone have any information? Is this a software bug should I just give up and get rid of the phone?

Top Kudoed Authors