cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
steved999
Fanfold Paper
Posts: 6
Registered: ‎12-11-2018
Location: US
Views: 333
Message 1 of 3

"Plugged in, can't charge right now"

Monday morning with the battery down to 22%, I plugged in the phone using the charger that came with it and it charged up to 78% and then stopped and actually started to drain a little.  I left it plugged in for a few hours and the screen would come on and off as it tried to charge but couldn't.  I unplugged the charger and after a minute plugged it back it and would see the Turbo Power Connected message and it would appear to be charging.  After a minute, it would stop charging and try again.  If I leave it like this, the battery % will not increase.  I checked the battery settings and saw the message "Plugged in, can't charge right now".

I tried this over and over all afternoon using my charger and my wife's charger (same model phone) and got the same result.  Sometimes I would gain a couple of %, sometimes nothing.  I tried the charger for my old Moto G3 phone and it seemed to charge a couple of % before cutting off, but then would stop charging as well.  I tried this while the phone was on and while it was off.  When off, the charging icon would show, then after a few seconds the Turbo Power Connected message would appear and the screen would turn off.  Then the screen would turn back on within 30 seconds and it would repeat the cycle of attempted charging but without a gain in battery %.

Finally I took the USB portion of the charging cable and plugged it into my computer and it started charging with the message indicating that it was a "slow charge".  I can't recall the exact wording.  After about 2 hours it was charged to 100%.

Tuesday morning 10 hours after my full charge, two of which I was checking email and listening to podcasts, the battery was still at 87%, so there are no apps causing excessive drain and the battery is holding its charge as usual.  That night, with the battery at 67%, I decided to try using the charger again and it worked uninterrupted to 100%

Now, it is Thursday evening and with the level at 48%, I tried to charge again and as only able to get up to 52% before I got the "Plugged in, can't charge right now" message.  I then plugged it unto the computer using the USB cable again and was able to slow charge it to 87%.  I tried the supplied charger again and that worked up untl 92% before I got the message.  Now it is back on the USB port of the computer where I will let it go to 100%

So, it appears that the only consistent way to charge my phone is by using the computer as any regular charger (the one supplied with the phone, my wife's same model phone and another Motorolla charger from an old phone) won't work properly.  My wife's G5 Plus charges fine using all three.  I've tried everything I can think of short of a factory reset: phone on, phone off, safe mode, clear cache.

I am running Oreo 8.1.0 with the October 1, 2018 security patch.  I regularly clear the cache after each update and even did so yesterday in case that would help.  This started not long after my update to Oreo and security patch.

The message "Plugged in, can't charge right now" is fairly specific.  Perhaps some Android developer can determine under what conditions that message may be displayed?

Steve

Porphyrius
802.11n
Posts: 491
Registered: ‎10-16-2018
Location: GB
Views: 312
Message 2 of 3

Re: "Plugged in, can't charge right now"

My Moto doesn't have the,"Fast Charge" chip so I use the old style Standard charger or a USB to Micro USB Charger/Data cable and a cheap Wall slug USB.

 

You can get the plugs at loads of places.

 

https://www.walmart.com/c/kp/usb-adapter-plugs-parts

 

https://www.walmart.com/ip/Maxxima-6-Outlet-Dual-USB-2-4A-Grounded-Adapter-Plug-490-Joules-Surge-Pro...

 

I'm not impressed with the,"Fast Charge" options on any of the new phones.

 

In saying that my older Moto G3 charges pretty fast on a standard charger and gives a good battery life Smiley Happy

 

My 2 cents.

 

HTH Smiley Happy

Senior MotoAgent
Senior MotoAgent
Posts: 3,905
Registered: ‎03-05-2018
Location: US
Views: 251
Message 3 of 3

Re: "Plugged in, can't charge right now"

Hi steved999,

 

I saw you posted on this existing thread and I replied on your post there. I will lock this thread so we can avoid cluttering on the site. Thanks.



Closing thread.

 

Edit: Thanks Porphyrius for the suggestions. 

 

Best regards,
Rich
Motorola Support

 

Top Kudoed Authors