cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Vcator
Paper Tape
Posts: 3
Registered: ‎02-18-2018
Location: GB
Views: 17,531
Message 1 of 6

Connected to WIFI, but No internet

The WiFi icon says I'm connected to WiFi- no problem.

 

From new (or a factory reset), the Moto G5s connects to the Internet . . . . for about 1hr, and then disconnects from the Internet, but remains connected to WiFi.    I do a factory reset, and again it works for about 1hr, and then disconnects.

[All other devices using WiFi are connected to the Internet]

 

Fixes on the Internet suggest changing to a static IP address under Advance Settings, but this hasn't worked.

[I set the static IP address to 192.168.100, and the icon says Status=Connected, but interestingly the hub does not show that IP address as connected.  Could it be that Android 7.1.1 thinks its connected to Wifi (but not connected to internet), when actually it isn't ?]

 

 

This is my second Moto G5s - the first one connected to the Internet without any issues . . .  but 3 months later failed to charge so got sent back.

 

OS is 7.1.1

Security patch 1 Dec 2017

 

Build npps26.102-49.1

 

Anyone any thoughts ?

Senior MotoAgent
Senior MotoAgent
Posts: 5,743
Registered: ‎12-04-2017
Location: IN
Views: 17,461
Message 2 of 6

Re: Connected to WIFI, but No internet


@Vcator wrote:

The WiFi icon says I'm connected to WiFi- no problem.

 

From new (or a factory reset), the Moto G5s connects to the Internet . . . . for about 1hr, and then disconnects from the Internet, but remains connected to WiFi.    I do a factory reset, and again it works for about 1hr, and then disconnects.

[All other devices using WiFi are connected to the Internet]

 

Fixes on the Internet suggest changing to a static IP address under Advance Settings, but this hasn't worked.

[I set the static IP address to 192.168.100, and the icon says Status=Connected, but interestingly the hub does not show that IP address as connected.  Could it be that Android 7.1.1 thinks its connected to Wifi (but not connected to internet), when actually it isn't ?]

 

 

This is my second Moto G5s - the first one connected to the Internet without any issues . . .  but 3 months later failed to charge so got sent back.

 

OS is 7.1.1

Security patch 1 Dec 2017

 

Build npps26.102-49.1

 

Anyone any thoughts ?


Thank you for sharing information, this is strange that it works for an hour on FDR. Could you confirm as your device says connected, though it is not on your wifi router? Or does it get connected to the router and does not have internet? Please update your profile with current phone, carrier, and serial number, IMEI -- this will help me investigate. Please make sure that the options under Settings > Motorola Privacy are on as well, and let me know (just reply here) if it's okay for me to look at your apps to see if they are a source of problems.

 

Can you also, test in Safe Mode. To go into Safe Mode, press the physical power key, then press and hold the pop-up "Power off" key until the Safe Mode instructions pop up.

 

Thanks,

Swaraj

 

 

Vcator
Paper Tape
Posts: 3
Registered: ‎02-18-2018
Location: GB
Views: 17,451
Message 3 of 6

Re: Connected to WIFI, but No internet

Hi Swaraj,

Yes, it says connected to WiFi, but no internet.

 

 

Its a brand new Moto G5s.   It replaced the previous G5s which connected to the Internet OK.

 

Motorola says  "Unable to retrieve device information. Please confirm your IMEI/MEID or serial number and try again"

 

Carrier is O2

 

btw because this was a brand new phone, the only apps I loaded was gmail.

 

In 'Safe Mode' it connects to wifi, but no connection to Internet

 

Vcator
Paper Tape
Posts: 3
Registered: ‎02-18-2018
Location: GB
Views: 17,448
Message 4 of 6

Re: Connected to WIFI, but No internet SOLVED

Looking really carefully when trying to re-set the wifi I notices a splash screen appear for about 0.1 seconds.

 

Running this a few times I could see that this is a BT Splash Screen. . . which turns out to be their Smart setup.

 

Disable Smart set-up, and 'Bobs your Uncle', Internet connects :-)

 

BY Home Hub 5

Advanced Settings>> Home Network>> Smart Setup>> disable

Darshan1247
Paper Tape
Posts: 1
Registered: ‎10-16-2018
Location: IN
Views: 9,149
Message 5 of 6

Re: Connected to WIFI, but No internet SOLVED

How to disable the smart setup for to link router
Nagu1137
What's DOS?
Posts: 1
Registered: ‎01-01-2019
Location: IN
Views: 5,788
Message 6 of 6

Moto g5s plus wifi issue

My phone connects to the home wifi but sometimes shows that wifi has no internet options even though all other devices are able to access internet services.  This has been frequently happening.

Please solve my problem

I saw few threads but ciylcoul fix my issue please solve.i had reset my phone and still same problem

Top Kudoed Authors