Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto G PhonesMoto G5S / Moto G5S Plus
All Forum Topics
Options

11 Posts

04-17-2021

Australia

12 Signins

35 Page Views

  • Posts: 11
  • Registered: ‎04-17-2021
  • Location: Australia
  • Views: 35
  • Message 11 of 22

Re:Do not disturb rules not working for my MotoG5S

2021-05-22, 6:06 AM

Hello Tom,

Thanks for your reply.

Perhaps I have misunderstood what DND does.

 

I was hoping that when I turn DND on, I can still get visual and audible alerts from starred contacts. My understanding of DND activation is turning on the mute option. Otherwise, if I don't turn on the mute button, I get all alerts.

 

My goal is to have a mode where the phone only alerts me of starred contacts, the notification should be visual AND audible, and nothing else can get through eg from non-starred contacts or other apps.

 

Is that possible? Or how do I go about activating the DND mode?

 

Also: When I tap the DND icon (the grey circle with a white horizontal bar across it and a diagonal line through it) at night before going to bed, I have set it to finish at a certain time, such as 7am the next morning. I expect this means the DND rules will end at that time and the phone will not be on mute anymore at 7am the next day.

 

I recall this used to be the case. However, it doesn't seem to do that anymore and stays on silent until I notice and manually turn off DND.

 

Please assist.

Thanks

Stephanie

Reply
Options

5712 Posts

02-11-2016

United States of America

3336 Signins

79006 Page Views

  • Posts: 5712
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 79006
  • Message 12 of 22

Re:Do not disturb rules not working for my MotoG5S

2021-05-25, 3:16 AM

@ Time_traveller wrote:

Hello Tom,

Thanks for your reply.

Perhaps I have misunderstood what DND does.

 

I was hoping that when I turn DND on, I can still get visual and audible alerts from starred contacts. My understanding of DND activation is turning on the mute option. Otherwise, if I don' turn on the mute button, I get all alerts.

 

My goal is to have a mode where the phone only alerts me of starred contacts, the notification should be visual AND audible, and nothing else can get through eg from non-starred contacts or other apps.

 

Is that possible? Or how do I go about activating the DND mode?

 

Also: When I tap the DND icon (the grey circle with a white horizontal bar across it and a diagonal line through it) at night before going to bed, I have set it to finish at a certain time, such as 7am the next morning. I expect this means the DND rules will end at that time and the phone will not be on mute anymore at 7am the next day.

 

I recall this used to be the case. However, it doesn' seem to do that anymore and stays on silent until I notice and manually turn off DND.

 

Please assist.

Thanks

Stephanie

 

Stephanie,

 

First, If you manually enable DND from the quick toggles you should have 2 options Until you turn it off or until a specific time. However, the rules you set in the DND menu are separate. I know that sounds confusing. If you use the quick toggle it's going to use the timing rule you set there. However, if you set up a schedule in the Settings > Sounds > Do Not Disturb,  for say sleeping, it will automatically turn itself on and off based on that schedule. I'd say leave the phone set to audible ring, then set up a schedule for sleeping, Personally, I have mine set to weekdays starting at 10PM and ending at 7AM the next time. Now, I also have it set up to override the end time based on my current alarm. I get up at different times each morning. Give it a try and let me know if it works for you.

 

Thanks,

Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

11 Posts

04-17-2021

Australia

12 Signins

35 Page Views

  • Posts: 11
  • Registered: ‎04-17-2021
  • Location: Australia
  • Views: 35
  • Message 13 of 22

Re:Do not disturb rules not working for my MotoG5S

2021-06-10, 9:49 AM

Hello

So sorry for the long delay.

 

You are correct, it is indeed confusing. I have tried to set the DND settings in Settings instead of the quick toggle. For the Time setting, I set it to turn on DND at certain times of the day. When DND is on, the starred contact apears on my phone screen when they try to call me, but there is no sound. I have already set Priority rules to "Priority only allows calls and messages from starred contacts only". I do not know where to set the volume settings for such calls: the starred contact calls appear, but make no sound. I'd like there to be sound as well. 

 

Stephanie

Reply
Options

5712 Posts

02-11-2016

United States of America

3336 Signins

79006 Page Views

  • Posts: 5712
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 79006
  • Message 14 of 22

Re:Do not disturb rules not working for my MotoG5S

2021-06-10, 14:33 PM

@ Time_traveller wrote:

Hello

So sorry for the long delay.

 

You are correct, it is indeed confusing. I have tried to set the DND settings in Settings instead of the quick toggle. For the Time setting, I set it to turn on DND at certain times of the day. When DND is on, the starred contact apears on my phone screen when they try to call me, but there is no sound. I have already set Priority rules to "Priority only allows calls and messages from starred contacts only". I do not know where to set the volume settings for such calls: the starred contact calls appear, but make no sound. I' like there to be sound as well. 

 

Stephanie

 

Stephanie,

 

The setting for volume while in DND is the same global volume setting. If you have your phone set to silent from the volume bar that shows up when you press the volume up or down buttons. Then the phone will not make any sound for any calls. If you have it set to vibrate, then the phone will vibrate for calls, the same if you have it set to ring. 

 

Do-no-disturb doesn't change the volume options, it just blocks the entire notification so the phone doesn't alert you.  So if you set your phone to ring using the volume keys or going to Settings > Sound > Drag the Ring & Notification volume slider all the way to the right, and then you enable DND. If one of your starred contacts calls you then the phone will give the visual notification and it will give you the audible ring. 

 

Give it a try and let me know.

 

Thanks,

Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

11 Posts

04-17-2021

Australia

12 Signins

35 Page Views

  • Posts: 11
  • Registered: ‎04-17-2021
  • Location: Australia
  • Views: 35
  • Message 15 of 22

Re:Do not disturb rules not working for my MotoG5S

2021-06-11, 3:34 AM

Hello Tom,

 


Thanks for your reply. I'd like to make sure I understood correctly:

The ring volume settings is global for the entire phone, not just inside DND. This means if the phone is on silent/do not ring, then it will not ring, no matter who calls or whether or not DND is activated, even if a starred contact calls/messages me. However, if the phone is set to audible ring while DND is turned on, then, my phone will notify me and audibly ring when a starred contact calls/messages me.

 


Is that correct?

 


Because i tried changing the ring volume with the slider while DND is on: it cannot be moved while DND is on, and the slider is already set at maximum volume. The ring volume can only be adjusted when DND is off. I have attached screenshots of my phone settings.

 

Just to mention again, I wish to receive audible alerts for calls and messages from starred contacts even when the rest of my phone is on silent. If this is not yet possible, it would be a great feature to have.

Screenshot_20210611-130532.png Screenshot_20210611-115912.png Screenshot_20210611-115941.png
Reply
Options

5712 Posts

02-11-2016

United States of America

3336 Signins

79006 Page Views

  • Posts: 5712
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 79006
  • Message 16 of 22

Re:Do not disturb rules not working for my MotoG5S

2021-06-11, 14:38 PM

@ Time_traveller wrote:

Hello Tom,

 


Thanks for your reply. I' like to make sure I understood correctly:

The ring volume settings is global for the entire phone, not just inside DND. This means if the phone is on silent/do not ring, then it will not ring, no matter who calls or whether or not DND is activated, even if a starred contact calls/messages me. However, if the phone is set to audible ring while DND is turned on, then, my phone will notify me and audibly ring when a starred contact calls/messages me.

 


Is that correct?

 


Because i tried changing the ring volume with the slider while DND is on: it cannot be moved while DND is on, and the slider is already set at maximum volume. The ring volume can only be adjusted when DND is off. I have attached screenshots of my phone settings.

 

Just to mention again, I wish to receive audible alerts for calls and messages from starred contacts even when the rest of my phone is on silent. If this is not yet possible, it would be a great feature to have.

 

 

Stephanie,

 

So in the screenshot you shared, did you choose to enable DND from the quick settings? In this case, it looks like it's set to Alarms only. Try setting a DND schedule, to allow calls from starred contacts. Then don't manually enable DND, but allow the schedule to activate it. Prior to that make sure your phone is set to audible ring. Then have one of your starred contacts call you and see if it works then.

 

Thanks,

Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

11 Posts

04-17-2021

Australia

12 Signins

35 Page Views

  • Posts: 11
  • Registered: ‎04-17-2021
  • Location: Australia
  • Views: 35
  • Message 17 of 22

Re:Do not disturb rules not working for my MotoG5S

2021-06-13, 12:45 PM

Hello Tom,

You are correct in that, initially I turned on DND via the quick toggle.

 

I have now made a schedule and when the schedule turned on automatically, I successfully got an audible ring when a starred contact called me.

 

Now, may I ask: what is the difference between the quick toggle and the settings--> DND? The layout looks exactly the same except the title at the top of the screen.

 

Suppose during the day I have an unexpected meeting, in other words, not something I can schedule a recurring timed event for. I want to activate DND whenever I want, without making a schedule for it, but still let starred contact notices come through. Is that possible?

 

Edit:
I also noticed another problem. If I set the ring to audible during DND on, there are sounds when I send messages too, no matter who I send messages to. For example, when I send a message to someone on Whatsapp with the ring on audible, there is a tone when my message is sent. This is not good. In the evenings I turn on (either manually via the quick toggle or via the automatic schedule) DND so there are NO sounds EXCEPT rings from a starred contact. That means no media and no tones when I send messages. I noticed now that I can get the phone to ring successfully when starred contacts call me, unfortunately this also means my phone makes sounds when I send messages too.

Reply
Options

5712 Posts

02-11-2016

United States of America

3336 Signins

79006 Page Views

  • Posts: 5712
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 79006
  • Message 18 of 22

Re:Do not disturb rules not working for my MotoG5S

2021-06-15, 14:22 PM

@ Time_traveller wrote:

Hello Tom,

You are correct in that, initially I turned on DND via the quick toggle.

 

I have now made a schedule and when the schedule turned on automatically, I successfully got an audible ring when a starred contact called me.

 

Now, may I ask: what is the difference between the quick toggle and the settings--> DND? The layout looks exactly the same except the title at the top of the screen.

 

Suppose during the day I have an unexpected meeting, in other words, not something I can schedule a recurring timed event for. I want to activate DND whenever I want, without making a schedule for it, but still let starred contact notices come through. Is that possible?

 

Edit:
I also noticed another problem. If I set the ring to audible during DND on, there are sounds when I send messages too, no matter who I send messages to. For example, when I send a message to someone on Whatsapp with the ring on audible, there is a tone when my message is sent. This is not good. In the evenings I turn on (either manually via the quick toggle or via the automatic schedule) DND so there are NO sounds EXCEPT rings from a starred contact. That means no media and no tones when I send messages. I noticed now that I can get the phone to ring successfully when starred contacts call me, unfortunately this also means my phone makes sounds when I send messages too.

 

Thanks for this update. It looks like we're making some progress. The quick toggle just blocks everything, whereas the schedule has exceptions built-in. I know that's confusing, but it's how Google has designed it. The same with other notifications on your phone. If an app has a tone for sending messages then it will still play. Unfortunately, it's a take-it-or-leave-it type of setup that we have little to no control over. I will definitely pass your feedback along though about the tones from apps when in DND with audible ring/notifications turned on.

 

Thanks,

Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

11 Posts

04-17-2021

Australia

12 Signins

35 Page Views

  • Posts: 11
  • Registered: ‎04-17-2021
  • Location: Australia
  • Views: 35
  • Message 19 of 22

Re:Do not disturb rules not working for my MotoG5S

2021-06-21, 1:56 AM

Hello Tom.

I have observed the behavior of the phone on DND mode for the past few days.

 

Scheduled DND is confusingly different to quick toggle. Because of the way it is made, I cannot temporarily turn off an automatically activated DND schedule with the quick toggle and turn it back on and expect it to resume. For example, sometimes when it turns on in the evening, I want to temporarily turn it off so I can be alerted to a normal message/call I am expecting from a number that is not in my contacts or a non-starred contact. I tried to temporarily turn it off using the quick toggle, then when I am done taking the expected call, I turn it back on using the quick toggle.

 

BUT this does not get over ridden by alarms, even though I set it to be over ridden. So the next morning I get missed calls, even from my starred contact since DND is on (via quick toggle).

 

It also doesn't to turn OFF when I have an alarm sound before the DND is set to end. It seems quick toggle activated DND cannot be stopped or ended by alarms like scheduled ones. This means the next day I get missed calls. This morning I missed many calls just today and it was very bad.

 

Note: you cannot turn off a DND in the settings temporarily and turn it back on on the same day and expect it to resume. It will only turn on at the specified "on time", for example 10pm. If you turned it off temporarily after it turned on, even in settings, then try to turn it back on 10 minutes later, it will turn on but DND will not be activated until the next "10pm" rolls around, which would be 24 hours later.

 

Consider this scenario:

I set the DND to turn on using a schedule so it turns on every night at 9:30pm (no sound at all except from starred contacts) and turns off at 9am the next day (sound from everyone). Sometimes I set an alarm to sound at 8:30am, and also the phone is supposed to ring if a starred contact calls me. This means if nothing out of the ordinary happens, DND should turn off when

-an alarm sounds or

-a starred contact calls me or

-Scheduled DND finishes,

whichever is earliest.

 

At 9:30pm, DND turns on. That means there are no sounds no matter if I get a call or message from anyone (other than my starred contact). I am in the middle of discussing something with someone on WhatsApp, or online and I am expecting a call or message from them within the next 30 minutes. This doesn't happen regularly, so I do not make the schedule "turn on at 10pm". But DND is on, so I turn DND off, (no matter which method). Once the discussion is over, I turn it back on. Since 9:30pm for this 24hour period is passed, the settings DND will not reactivate DND. Thus the only way to not be disturbed by sounds is to turn it on, so I use the quick toggle to turn it back on. This means it will let not turn OFF automatically when:

-the alarm sounds or

-when a starred contact calls me or

-when DND was scheduled to end.

And so it remains on until I decide to look at my phone, causing me to miss calls either the next morning or the night before.

 

Seems like I can either have DND on and leave it on me wait for it to turn off automatically, or turn it on be off manually. This all or nothing rigidity is really bad. Any help?

Reply
Options

5712 Posts

02-11-2016

United States of America

3336 Signins

79006 Page Views

  • Posts: 5712
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 79006
  • Message 20 of 22

Re:Do not disturb rules not working for my MotoG5S

2021-06-23, 13:40 PM

@ Time_traveller wrote:

Hello Tom.

I have observed the behavior of the phone on DND mode for the past few days.

 

Scheduled DND is confusingly different to quick toggle. Because of the way it is made, I cannot temporarily turn off an automatically activated DND schedule with the quick toggle and turn it back on and expect it to resume. For example, sometimes when it turns on in the evening, I want to temporarily turn it off so I can be alerted to a normal message/call I am expecting from a number that is not in my contacts or a non-starred contact. I tried to temporarily turn it off using the quick toggle, then when I am done taking the expected call, I turn it back on using the quick toggle.

 

BUT this does not get over ridden by alarms, even though I set it to be over ridden. So the next morning I get missed calls, even from my starred contact since DND is on (via quick toggle).

 

It also doesn' to turn OFF when I have an alarm sound before the DND is set to end. It seems quick toggle activated DND cannot be stopped or ended by alarms like scheduled ones. This means the next day I get missed calls. This morning I missed many calls just today and it was very bad.

 

Note: you cannot turn off a DND in the settings temporarily and turn it back on on the same day and expect it to resume. It will only turn on at the specified "on time", for example 10pm. If you turned it off temporarily after it turned on, even in settings, then try to turn it back on 10 minutes later, it will turn on but DND will not be activated until the next "10pm" rolls around, which would be 24 hours later.

 

Consider this scenario:

I set the DND to turn on using a schedule so it turns on every night at 9:30pm (no sound at all except from starred contacts) and turns off at 9am the next day (sound from everyone). Sometimes I set an alarm to sound at 8:30am, and also the phone is supposed to ring if a starred contact calls me. This means if nothing out of the ordinary happens, DND should turn off when

-an alarm sounds or

-a starred contact calls me or

-Scheduled DND finishes,

whichever is earliest.

 

At 9:30pm, DND turns on. That means there are no sounds no matter if I get a call or message from anyone (other than my starred contact). I am in the middle of discussing something with someone on WhatsApp, or online and I am expecting a call or message from them within the next 30 minutes. This doesn' happen regularly, so I do not make the schedule "turn on at 10pm". But DND is on, so I turn DND off, (no matter which method). Once the discussion is over, I turn it back on. Since 9:30pm for this 24hour period is passed, the settings DND will not reactivate DND. Thus the only way to not be disturbed by sounds is to turn it on, so I use the quick toggle to turn it back on. This means it will let not turn OFF automatically when:

-the alarm sounds or

-when a starred contact calls me or

-when DND was scheduled to end.

And so it remains on until I decide to look at my phone, causing me to miss calls either the next morning or the night before.

 

Seems like I can either have DND on and leave it on me wait for it to turn off automatically, or turn it on be off manually. This all or nothing rigidity is really bad. Any help?

 

Hi Stephanie. Yes, you're 100% correct in your analysis here. This is how Google designed the feature. If your scheduled DND turns on and you turn it off and then manually enable it again from Quick Toggle, it will not turn off automatically. This same behaviour is seen even on Pixel phones. The enhancements to the DND functionality would have to come from Google.  I wish I could help further, but this is how it works. 

 

Thanks,

Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms