Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto G PhonesMoto G6 / Moto G6 Plus / Moto G6 Play
All Forum Topics
Options

13 Posts

03-31-2019

United Kingdom of Great Britain and Northern Ireland

16 Signins

160 Page Views

  • Posts: 13
  • Registered: ‎03-31-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 160
  • Message 11 of 21

Re: Wi-Fi causing some apps not to send pictures/video files after 9.0 update

2019-04-18, 1:30 AM

I captured the bug report a few minutes after the bug occured

 

I've tried my own and a friends Wi-Fi network and the issue is still there. My router is a TP-Link Archer C2 v1 and the firmware is 0.9.1 5.0

 

It works fine on other devices. I tried it on my old Moto X Play and worked just fine.

 

It's only ever on Wi-Fi where this happens but the strange part is if I turn on a VPN while on the Wi-Fi network, it starts working fine. When I turn the VPN off, it stops sending anything. This issue has only started occuring after the Anrdoid 9.0 update. Worked fine before that.

 

I've checked app permissions and everything is fine. It's all up to date

 

Matt

Reply
Options

5996 Posts

12-04-2017

India

1170 Signins

77328 Page Views

  • Posts: 5996
  • Registered: ‎12-04-2017
  • Location: India
  • Views: 77328
  • Message 12 of 21

Re: Wi-Fi causing some apps not to send pictures/video files after 9.0 update

2019-04-19, 12:08 PM

Hi matt_baker,

 

Thanks for the additional information, we have shared the same with our product team for further review. Will keep you posted.

 

Regards,

Swaraj

Motorola Support

If you need a reference in updating your profile, please click this link. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943
Reply
Options

1 Posts

04-21-2019

United Kingdom of Great Britain and Northern Ireland

3 Signins

10 Page Views

  • Posts: 1
  • Registered: ‎04-21-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 10
  • Message 13 of 21

Moto G6 Plus - Android 9 - Apps does not work with WiFi but does on Mobile Data

2019-04-21, 14:37 PM

Hi All,

 

I have recently updated my phone from Andriod 8 to Andriod 9 and have discovered the Amazon app I use only works properly on mobile data. I have factory reset both my phone and my router with no joy, has anyone else expericed these issues and if so is there a fix? 

Another issue with Andriod 9 includes the fact my Fitbit is now unable to pair with the phone, has anyone seen this issue also, the phone will see the device but is unable to connect.

Reply
Options

5996 Posts

12-04-2017

India

1170 Signins

77328 Page Views

  • Posts: 5996
  • Registered: ‎12-04-2017
  • Location: India
  • Views: 77328
  • Message 14 of 21

Re: Moto G6 Plus - Android 9 - Apps does not work with WiFi but does on Mobile Data

2019-04-22, 12:15 PM

 wrote:

Hi All,

 

I have recently updated my phone from Andriod 8 to Andriod 9 and have discovered the Amazon app I use only works properly on mobile data. I have factory reset both my phone and my router with no joy, has anyone else expericed these issues and if so is there a fix? 

Another issue with Andriod 9 includes the fact my Fitbit is now unable to pair with the phone, has anyone seen this issue also, the phone will see the device but is unable to connect.


Hi Oliver2278,

 

Sorry to hear about that, let me try to help you. Just to narrow down—have you tried with any different WiFi router to see if that makes any difference? 

 

For your other questions, have you tried removing and repairing again to see if that helps you connect the Fitbit? If not, try performing Network Reset under Apps & Notification > Settings.

 

Let us know how it goes?

 

Regards,

Swaraj

Motorola Support

If you need a reference in updating your profile, please click this link. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943
Reply
Options

3 Posts

04-22-2019

United Kingdom of Great Britain and Northern Ireland

6 Signins

43 Page Views

  • Posts: 3
  • Registered: ‎04-22-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 43
  • Message 15 of 21

Re: Moto G6 Plus - Android 9 - Apps does not work with WiFi but does on Mobile Data

2019-04-22, 13:48 PM

I've got exactly this same issue on my G6 plus. Since the update to android 9.0 pie, Amazon shopping, Amazon music, LinkedIn don't have an internet connection using WiFi (different WiFi too), as soon as I switch to mobile data everything is fine. I've uninstalled/reinstalled all the apps and just done a factory reset on the phone. Still the same issues. I can't see an option to roll back to android 8.0.

I'm a bit happier knowing it's not just me, but still massively frustrated that the update to piepie  made my phone not fit for purpose.

Reply
Options

13 Posts

03-31-2019

United Kingdom of Great Britain and Northern Ireland

16 Signins

160 Page Views

  • Posts: 13
  • Registered: ‎03-31-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 160
  • Message 16 of 21

Re: Moto G6 Plus - Android 9 - Apps does not work with WiFi but does on Mobile Data

2019-04-22, 13:56 PM

Yes, it is indeed incredibly frustrating. I don't like that there isn't a rollback feature, so if the update didn't go well, there's always a contingency.

 

I've also done everything you have, I've found that it'll work on some wireless networks, but not others. It must be something to do with either DNS or ports. I can say this because it works with a VPN and that's changing your DNS to be routed somewhere else.

 

P.S. I've just tried Amazon shopping too and that doesn't appear to work

 

I've tried changing my DNS to different addresses to no prevail. I've tried tweaking some router settings to do with DNS, again to no prevail.

 

If I want to send something like a Snapchat, I have to use cellular but over time it eats up data and gets annoying

Reply
Options

3 Posts

05-25-2019

Germany

7 Signins

58 Page Views

  • Posts: 3
  • Registered: ‎05-25-2019
  • Location: Germany
  • Views: 58
  • Message 17 of 21

Re: Moto G6 Plus - Android 9 - Apps does not work with WiFi but does on Mobile Data

2019-06-08, 12:48 PM

Hi, I have similar problems. Since the Upgrade to Android9 on my Moto g 6 some Apps ( Amazon and Yahoo ) don't work correctly any more. Sing in is blocked somehow. 

Most Other Apps Work correctly.

I did all kind of de- and reinstalling actions without success.

Hope they find a solution fast  - that really spoils the phone...!

 

Thanks!

Reply
Options

3 Posts

04-22-2019

United Kingdom of Great Britain and Northern Ireland

6 Signins

43 Page Views

  • Posts: 3
  • Registered: ‎04-22-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 43
  • Message 18 of 21

Re: Moto G6 Plus - Android 9 - Apps does not work with WiFi but does on Mobile Data

2019-06-18, 19:27 PM

I've submitted my bug report so we'll hopefully see soon what they say. They can't ignore it if there are more of us submitting this issue, so please submit a ticket if you're having this same issue.

 

Interesting find this week was I couldn't get on to curry's website, even on cellular data. However, using a VPN got me on thier site.

Reply
Options

13 Posts

03-31-2019

United Kingdom of Great Britain and Northern Ireland

16 Signins

160 Page Views

  • Posts: 13
  • Registered: ‎03-31-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 160
  • Message 19 of 21

Re: Wi-Fi causing some apps not to send pictures/video files after 9.0 update

2019-07-21, 16:59 PM

Have you got any more news on this situation?

Reply
Options

3 Posts

04-22-2019

United Kingdom of Great Britain and Northern Ireland

6 Signins

43 Page Views

  • Posts: 3
  • Registered: ‎04-22-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 43
  • Message 20 of 21

Re: Wi-Fi causing some apps not to send pictures/video files after 9.0 update

2019-07-21, 17:03 PM

Nothing Yet Matt. Just got fobbed off on last chat session with "tech support are looking into it." I sent a bug report as requested ages ago. I said that it was unacceptable and wanted to know how to return the phone under warranty as it is not fit for purpose. I'll message them again tomorow. I really don't know what to do or who to speak to, this is absolute rubbish.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms