Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto G PhonesMoto G6 / Moto G6 Plus / Moto G6 Play
All Forum Topics
Options

8 Posts

07-23-2018

United States of America

13 Signins

48 Page Views

  • Posts: 8
  • Registered: ‎07-23-2018
  • Location: United States of America
  • Views: 48
  • Message 1 of 11

G6 and Android Auto requires swipe up before connecting

2018-07-23, 0:17 AM

I recently purchased a Moto G6 to replace an LG G5.. I am having a problem with the phone and Android Auto when connected via USB to my vehicle. Android Auto will not start or be available to the vehicle until the screen is swiped up. If I use Smart Lock to unlock the phone when connected to my vehicle Bluetooth, it will unlock the phone — but still require that I swipe up to show the home screen before any communication to the vehicle over USB takes place and Android Auto launches. I have not had to do this with previous Android phones. Any help would be appreciated. 

Reply
Options

5996 Posts

12-04-2017

India

1170 Signins

77328 Page Views

  • Posts: 5996
  • Registered: ‎12-04-2017
  • Location: India
  • Views: 77328
  • Message 2 of 11

Re: G6 and Android Auto requires swipe up before connecting

2018-07-23, 16:02 PM

 wrote:

I recently purchased a Moto G6 to replace an LG G5.. I am having a problem with the phone and Android Auto when connected via USB to my vehicle. Android Auto will not start or be available to the vehicle until the screen is swiped up. If I use Smart Lock to unlock the phone when connected to my vehicle Bluetooth, it will unlock the phone — but still require that I swipe up to show the home screen before any communication to the vehicle over USB takes place and Android Auto launches. I have not had to do this with previous Android phones. Any help would be appreciated. 


Hi RNY71,

 

Thank you for reporting, yes you have to be at the home screen, this is by design as the phone doesn't enumerate USB connections when it's at the lock screen.

 

It would be a security risk to allow USB connection form the lock screen, as someone could get ahold of your phone and take data from the storage or run commands via ADB.

 

Hope this helps.

 

Thanks,

Swaraj

Moto Support

If you need a reference in updating your profile, please click this link. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943
Reply
Options

8 Posts

07-23-2018

United States of America

13 Signins

48 Page Views

  • Posts: 8
  • Registered: ‎07-23-2018
  • Location: United States of America
  • Views: 48
  • Message 3 of 11

Re: G6 and Android Auto requires swipe up before connecting

2018-07-23, 16:22 PM

Doesnt USB Debugging have to be turned on to enable ADB commands over it?

 

And if the phone is unlocked -- why does it still not enumerate USB until swiped?  That really makes no sense.  The phone is already unlocked via Smart Lock.

Reply
Options

10 Posts

06-11-2020

United States of America

11 Signins

70 Page Views

  • Posts: 10
  • Registered: ‎06-11-2020
  • Location: United States of America
  • Views: 70
  • Message 4 of 11

Re:G6 and Android Auto requires swipe up before connecting

2020-06-12, 16:11 PM

I'm having the same issue.  Did you ever find a fix for this?

 

It is baffling that they seem have this set up this way when every other phone manufacturer doesn't.

Reply
Options

3 Posts

04-04-2020

United States of America

5 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎04-04-2020
  • Location: United States of America
  • Views: 35
  • Message 5 of 11

Re:G6 and Android Auto requires swipe up before connecting

2021-04-04, 21:44 PM

I finally figured out a fix: I bought a Samsung.

 

I like my Moto G6 better in all other respects, but this nuisance was enough to make me switch.

Reply
Options

10 Posts

06-11-2020

United States of America

11 Signins

70 Page Views

  • Posts: 10
  • Registered: ‎06-11-2020
  • Location: United States of America
  • Views: 70
  • Message 6 of 11

Re:G6 and Android Auto requires swipe up before connecting

2021-04-04, 23:20 PM

Same solution.  I bought a Pixel.

Reply
Options

13492 Posts

03-05-2018

United States of America

1277 Signins

173335 Page Views

  • Posts: 13492
  • Registered: ‎03-05-2018
  • Location: United States of America
  • Views: 173335
  • Message 7 of 11

Re:G6 and Android Auto requires swipe up before connecting

2021-04-05, 19:47 PM

Hi,

 

Sorry to hear about that. When Android Auto is activated, it basically locks down the phone. To address this, Google rolled out a new swipe-to-unlock option. When enabled, instead of attempts to unlock the device simply displaying the Android Auto logo, it now displays instructions to “Swipe up to unlock.” After swiping up, users will have access to the device’s standard home screen and apps. This additional upward swipe will be required for each unlock as long as the phone is connected to the car. That's what I have read and know so regarding the behavior when using Android Auto.

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Click the thumbs up button to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

3 Posts

04-04-2020

United States of America

5 Signins

35 Page Views

  • Posts: 3
  • Registered: ‎04-04-2020
  • Location: United States of America
  • Views: 35
  • Message 8 of 11

Re:G6 and Android Auto requires swipe up before connecting

2021-04-05, 20:10 PM

Hi Rich -

 

I think you misunderstand the issue we're describing.  It's not about accessing the phone's other functions while Android Auto is operating, it's that Android Auto won't connect to the vehicle unless the phone is unlocked.  Every time I get back into my car, I have to swipe up to unlock the phone before Android Auto will connect, even if I use Smart Lock to bypass the lock screen when the phone is in the car.

 

Other brands of phones don't have the problem.  My old Sony connected fine whenever it was plugged in, unlocked or not.  My new Samsung S10e does too.  And from Mrallen's response above, the Pixel doesn't have the problem either.

 

I would love to see this fixed, because I'll switch back to my Moto G6.  I much prefer it to the Samsung except for this problem.

 

George

Reply
Options

10 Posts

06-11-2020

United States of America

11 Signins

70 Page Views

  • Posts: 10
  • Registered: ‎06-11-2020
  • Location: United States of America
  • Views: 70
  • Message 9 of 11

Re:G6 and Android Auto requires swipe up before connecting

2021-04-06, 1:08 AM

George is correct.

 

No other phone that I've had has had this issue. This caused me to change phones. 

Reply
Options

10 Posts

06-11-2020

United States of America

11 Signins

70 Page Views

  • Posts: 10
  • Registered: ‎06-11-2020
  • Location: United States of America
  • Views: 70
  • Message 10 of 11

Re:G6 and Android Auto requires swipe up before connecting

2021-04-06, 1:12 AM
While it may seem like a small thing to have to unlock it manually, it's NOT a small thing when you have to do it multiple times a day. When one comes from a previous workflow on my Pixel where all I had to do is 1) put plug it in, 2) put phone on the phone holder, and 3) drive off with AA automatically starting on my stereo to a new workflow where now I have to 1) plug it in, 2) hold the phone in my hand and wait for AA to start up, 3) allow the phone to go back to the lock screen, 4) then manually unlock the phone again, 5) then place the phone in the holder, and 6) then finally be able to drive, it's simply unacceptable.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms