Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto G PhonesMoto G6 / Moto G6 Plus / Moto G6 Play
All Forum Topics
Options

19 Posts

08-18-2019

United States of America

30 Signins

130 Page Views

  • Posts: 19
  • Registered: ‎08-18-2019
  • Location: United States of America
  • Views: 130
  • Message 351 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-19, 3:41 AM

My hardware is xt1925-6. Software version is amz. But if you're still on oreo I would stay there. While I've gotten mine to a pretty solid state. It really shouldn't be this much of a pain to get the phone into a working state. The benefits if any of going pie really aren't worth the headache. But if you did update like I did, I'd say give it a shot and see if it fixes the issue for you as well. 

Reply
Options

7 Posts

08-08-2019

United States of America

9 Signins

50 Page Views

  • Posts: 7
  • Registered: ‎08-08-2019
  • Location: United States of America
  • Views: 50
  • Message 352 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-19, 13:39 PM

Hi folks. Wanted to share a fix I came across inadvertently. Since pie update, voice detection had been broken for me ("OK Google" , etc). The "Access with voice match" setting within Google assistant settings was toggled off and would not allow me to turn it back on. There is a thread on this topic as well, as it is affecting many users.

 

While searching for a fix to that issue, I did the following:

 

1) Moto App > Moto voice (beta) > gear icon > Retrain moto voice > toggle 'Voice control' to OFF.

 

2) Open Google assistant / now / whatever it's called > three dots > settings > Google assistant > assistant > scroll down to device-phone > toggle voice match to ON.

 

3) Optionally, re-enable moto voice. 

 

I was happy to find that Google voice match now worked again, but surprisingly all the Pie freezing/lagging was instantly fixed as well. Hope this helps some people. 

Reply
Options

10 Posts

04-30-2019

United Kingdom of Great Britain and Northern Ireland

33 Signins

150 Page Views

  • Posts: 10
  • Registered: ‎04-30-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 150
  • Message 353 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-21, 8:47 AM

OK. So I've been posting to this thread since it was launched with a clogged up laggy unlocked G6 in the UK. The June update was finally offered to me yesterday and after backing up everything to Google cloud and factory reset.

 

So far.. lag has gone and phone is back up to previous speeds! Will report back in a week or so if this is still the case.

 

It appears we got there in the end...!

Reply
Options

4 Posts

08-21-2019

Brazil

8 Signins

171 Page Views

  • Posts: 4
  • Registered: ‎08-21-2019
  • Location: Brazil
  • Views: 171
  • Message 354 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-21, 21:20 PM

After updating accidently to PIE,. read the whole forum to find a solution 

I'm even more frustrated now

 

i have an Unlocked G6 plus  xt1926-3 

updated to PPWS29.116-20-8 (in Brazil)

 

Before I was totaly happy with Oreo and my G6 

The update ruind it in a day,. every few minutes or seconds got a reboot, frozen screens and all the other mentioned problems with brightness volume etc 

 

Totaly no support of value from moto 

Last option is factory install and otherwise it will be exit moto 

 

 

Reply
Options

232 Posts

03-28-2019

United States of America

344 Signins

5423 Page Views

  • Posts: 232
  • Registered: ‎03-28-2019
  • Location: United States of America
  • Views: 5423
  • Message 355 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-21, 21:37 PM
Well there's the problem. Change your last option to first and it'll be all good.

~us retail g6~no lifeguard on duty
Reply
Options

4 Posts

08-21-2019

Brazil

8 Signins

171 Page Views

  • Posts: 4
  • Registered: ‎08-21-2019
  • Location: Brazil
  • Views: 171
  • Message 356 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-21, 21:45 PM

maybe but it is not guaranteed. 

before i finished this and can tell if it really helped need to backup all stuff first

and thats very hard to do if phone crashes in less than a minute

 

had several Samsung and Sony before and never had any of these kind of problems that an update cuts you off and the phone becomes totaly useless. 

Reply
Options

232 Posts

03-28-2019

United States of America

344 Signins

5423 Page Views

  • Posts: 232
  • Registered: ‎03-28-2019
  • Location: United States of America
  • Views: 5423
  • Message 357 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-22, 12:22 PM
Guaranteed, every few minutes or seconds got a reboot, frozen screens and all the other mentioned problems with brightness volume etc.

~us retail g6~no lifeguard on duty
Reply
Options

4 Posts

08-21-2019

Brazil

8 Signins

171 Page Views

  • Posts: 4
  • Registered: ‎08-21-2019
  • Location: Brazil
  • Views: 171
  • Message 358 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-22, 12:47 PM

ok I did the factory restore 

so clean install (the same update PPWS29.116-20-8) and guess what?

same problem.... absoutely no way to use this phone anymore ... even with first setup screens had several frozens screens and reboots.

 

so only 1 conclusion here... this update to 9 completely f***ed up my phone. from good working and never had any reboots or frozens to this,...

 

Thanks moto ,...NEVER AGAIN ! 

(hardly could save my wifes phone, she was with here finger on the button to accept the same update, otherwise 2 new phones)

Reply
Options

19 Posts

08-18-2019

United States of America

30 Signins

130 Page Views

  • Posts: 19
  • Registered: ‎08-18-2019
  • Location: United States of America
  • Views: 130
  • Message 359 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-22, 14:43 PM

Try the fix I posted on page 35. I don't believe that a hard reset fixes it. Was reading on xda forums that flashing the phone with a stock rom fixes it but that's way more in depth than I think most people want to go. It seems to be a combination of software bugs that cause this to occur. The fix I posted basically disables a bunch of the moto crap that they install by default. Let me know if my fix works for you. 

Reply
Options

10 Posts

07-23-2019

United States of America

19 Signins

148 Page Views

  • Posts: 10
  • Registered: ‎07-23-2019
  • Location: United States of America
  • Views: 148
  • Message 360 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-22, 15:35 PM

I finally took the chance and factory reset my US amazon-branded G6 last week (model XT1925-6, hardware version PVT2) and that seems to have corrected all issues for me.

 

OS version PPS29.118-11-1

Security patch level May 1, 2019

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms