Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto G PhonesMoto G6 / Moto G6 Plus / Moto G6 Play
All Forum Topics
Options

5 Posts

08-06-2019

Argentina

12 Signins

67 Page Views

  • Posts: 5
  • Registered: ‎08-06-2019
  • Location: Argentina
  • Views: 67
  • Message 371 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-22, 22:37 PM

Yesterday update to PPS version 29.55-37-4. Security patch June 1, 2019. Hardware Version PVT2, model number XT1925-1. Disabled ALL Motorola software. After rebooting a few times, the phone works perfect. I will wait a few days and report if there are changes. Definitely part of the problem (if not all) is in Motorola apps.

Reply
Options

19 Posts

08-18-2019

United States of America

30 Signins

130 Page Views

  • Posts: 19
  • Registered: ‎08-18-2019
  • Location: United States of America
  • Views: 130
  • Message 372 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-23, 7:35 AM

I took the plunge and did the recovery mode reset. Am happy to say that it definitely works almost at the oreo level of performance. Definitely faster than all the little hacks I did before. Anyways for those of you who are doing this, keep in mind it is a complete wipe so make sure you have all your stuff backed up before you do this. Also on a side note when I went into recovery mode I ended up with a message "no command". All you have to do to proceed is press and hold the power button and then press volume up and release both buttons. This will continue into recovery mode if you run into this error. Definitely worth it for the phone to function smoothly again. Best of luck

Reply
Options

232 Posts

03-28-2019

United States of America

344 Signins

5423 Page Views

  • Posts: 232
  • Registered: ‎03-28-2019
  • Location: United States of America
  • Views: 5423
  • Message 373 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-23, 11:39 AM
Amazing!

~us retail g6~no lifeguard on duty
Reply
Options

8 Posts

06-05-2019

Poland

112 Signins

283 Page Views

  • Posts: 8
  • Registered: ‎06-05-2019
  • Location: Poland
  • Views: 283
  • Message 374 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-27, 15:58 PM

My current firmware version is PPS29.55-37-4. Finally decided to do the update from previous version of Pie (it was laggy but thanks to some tweaks from this thread I got used to it). For a few days after the update I didn't see any changes - not better, not worse. But few more days later it became almost unusable - especially the camera. Nightmare! So I backed up everything and did the factory reset from settings menu and then again from recovery mode. Of course all Moto apps were all running again but after two days I see no need to disable them. The phone is smooth again and I hope it will stay that way till next update. In my case, applying factory reset (and wiping cache partition) did help. For now...

Reply
Options

6 Posts

02-21-2016

australia

10 Signins

37 Page Views

  • Posts: 6
  • Registered: ‎02-21-2016
  • Location: australia
  • Views: 37
  • Message 375 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-27, 23:40 PM

My G6 was running terrible after the Pie update - lots of hangs

 

I was going to put a custom ROM on it so i unlocked the bootloader and got ready to do it.

 

After unlocking the bootloader i saw the "factory reset" option from the Fastboot menu and thought i'd try that first

 

After that "factory reset" and a format of my SD card, the phone is back to being snappy and fast.

 

It has only been 5 days, but so far, so good.

Reply
Options

19 Posts

08-18-2019

United States of America

30 Signins

130 Page Views

  • Posts: 19
  • Registered: ‎08-18-2019
  • Location: United States of America
  • Views: 130
  • Message 376 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-27, 23:49 PM

yah i've been running about a week now and everything still is fine. I'm surprised Motorola hasn't just told everyone to go down that route and backup then do the factory reset. Such an easy fix and so worth it. Seems like something in the upgrade process messes up the phone. I noticed that even for my dialer when receiving calls, I now have the "screen call" option while after the upgrade, that never popped up. My guess is that doing the update they don't properly update all the files and that's what's causing the phone to break. I love that we are better QA people for motorola than their own people. 

Reply
Options

22 Posts

06-16-2019

United Kingdom of Great Britain and Northern Ireland

43 Signins

195 Page Views

  • Posts: 22
  • Registered: ‎06-16-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 195
  • Message 377 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-28, 7:36 AM

I did factory reset about 3 weeks ago and it was snappy performance but has now started to bog down again and I think it's going to end up as bad as it was again for me. Getting the freezes and lags all over again .

Reply
Options

19 Posts

08-18-2019

United States of America

30 Signins

130 Page Views

  • Posts: 19
  • Registered: ‎08-18-2019
  • Location: United States of America
  • Views: 130
  • Message 378 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-28, 8:05 AM

Did you do the reset in android through settings or did you reset it from recovery mode? 

Reply
Options

22 Posts

06-16-2019

United Kingdom of Great Britain and Northern Ireland

43 Signins

195 Page Views

  • Posts: 22
  • Registered: ‎06-16-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 195
  • Message 379 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-28, 8:25 AM

Through settings, but last time it was bad I did one through recovery (prior to June patch ) and it went the same way after about 3 week's.

Reply
Options

19 Posts

08-18-2019

United States of America

30 Signins

130 Page Views

  • Posts: 19
  • Registered: ‎08-18-2019
  • Location: United States of America
  • Views: 130
  • Message 380 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-28, 8:27 AM

I'm sitting at 10 days and still smooth as butter. I guess I'll give it another week or two and let you guys know. But so far no hiccups at all

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms