Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto G PhonesMoto G6 / Moto G6 Plus / Moto G6 Play
All Forum Topics
Options

2 Posts

08-29-2019

United States of America

1 Signins

18 Page Views

  • Posts: 2
  • Registered: ‎08-29-2019
  • Location: United States of America
  • Views: 18
  • Message 381 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-29, 22:59 PM

Well.....I created an account solely to post up how frustrating it is to have my phone be so laggy.  Does throwing it against a wall fix it?!

Reply
Options

13 Posts

08-11-2012

United States of America

72 Signins

1015 Page Views

  • Posts: 13
  • Registered: ‎08-11-2012
  • Location: United States of America
  • Views: 1015
  • Message 382 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-29, 23:17 PM

Have you tried a factory reset from Recovery mode (not the Settings menu)? That seems to be the one thing that has worked for several people, although not a very large sample size yet. Let us know if you do, and if it fixes the lag and other problems. (You can find tips and instructions for this in the last few pages of the comments.)

Reply
Options

2 Posts

08-29-2019

United States of America

1 Signins

18 Page Views

  • Posts: 2
  • Registered: ‎08-29-2019
  • Location: United States of America
  • Views: 18
  • Message 383 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-29, 23:32 PM

I mjust tried the instructions on page 35.....lets see how that works first.

Reply
Options

19 Posts

08-18-2019

United States of America

30 Signins

130 Page Views

  • Posts: 19
  • Registered: ‎08-18-2019
  • Location: United States of America
  • Views: 130
  • Message 384 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-30, 0:27 AM

Just to make it easier on everyone else i'm going to summarize how to do the recovery mode reset. Keep in mind this is a complete wipe of your phone and SD card if you have it. So please backup your phone, photos, contacts etc beforehand. You can backup the main stuff on your phone in Settings -> System -> Backup. Other apps might need individual backups as well so just be aware.

 

To initiate the recovery mode reset please do the following steps

 

1) Hold down the power button. Select "Power Off". This will turn off your phone

 

2) When the phone is completely powered off. Press and hold the Power Button and the Volume Down Button. This will start your phone into Fast Boot Mode

 

3) On the next screen, use the volume up and volume down buttons to scroll through the options. Find the option that says "Recovery Mode". From here use the power button to select this option

 

4) The next screen you might get a picture of the android logo lying down and a message that says  "No Command" If you get this, click and hold the power button then press volume up and then release both buttons. This will proceed into recovery mode.

 

5) From the recover mode screen. Use the Volume Up/Down buttons to select the option that says "Wipe Data/Factory Reset". Use the power button to select it once it's highlighted.

 

6) Next Screen you will be prompted to select what you want to delete. Select the user data and personalized content option. Use the power button to select this option

 

7) You will be back on the recovery mode screen and the "Reboot System Now" should be highlighted. Click the power button on this and your system will start back up like brand new. 

 

8) After android boots up and you log back in with your google account, the backup that you made before you reset should automatically be detected. You can restore your system more or less back to the state it was in. 

 

Hopefully you should now have a fully functioning phone again. This worked for me. Best of Luck

Reply
Options

5 Posts

08-13-2018

United Kingdom of Great Britain and Northern Ireland

11 Signins

117 Page Views

  • Posts: 5
  • Registered: ‎08-13-2018
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 117
  • Message 385 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-08-31, 18:53 PM

Factory reset after the last update also has made a massive difference here. Just in time too as I was about to hit the button on a new phone. 

About a week so far hopeful it stays this way! 

Reply
Options

1 Posts

09-01-2019

United Kingdom of Great Britain and Northern Ireland

2 Signins

19 Page Views

  • Posts: 1
  • Registered: ‎09-01-2019
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 19
  • Message 386 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-09-01, 17:43 PM

The phone had lags and freezes lasting several seconds and quite frequent after upgrading to Pie. But then, on Friday August 23, another update kicked in and it made a mess.

 

After the update, the touch screen became nearly completely unresponsive and in order to use it I had to lock and unlock the screen several times. When finally it worked, it worked for a few minutes, then again unresponsive. Basically I could not use the phone while on holiday.

 

Tried to restart, do a safe mode reboot - nothing. Same problems, phone unusable.

 

Then I read this thread and I performed a factory reset. Now everything works fine!

 

Shame on Lenovo for not informing of the issue (I saw it reported by many users) and how to fix the problem. I am really questioning whether my  next phone will be a Motorola.

 

 

Reply
Options

11 Posts

04-29-2019

Australia

38 Signins

198 Page Views

  • Posts: 11
  • Registered: ‎04-29-2019
  • Location: Australia
  • Views: 198
  • Message 387 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-09-02, 4:16 AM

I've tried all of the fixes (as far as I can tell) and nothing worked until I did a factory reset. It seems to be working fine now, although it's only been a few hours. Getting the phone back to how it was before the reset wasn't too much hassle at all. I popped out my SD card before I did it, just to be safe.

 

Also, cheers to dpvball for the detailed instructions. I'm sure that will help a lot of people out.

Reply
Options

13 Posts

07-16-2019

Mexico

48 Signins

238 Page Views

  • Posts: 13
  • Registered: ‎07-16-2019
  • Location: Mexico
  • Views: 238
  • Message 388 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-09-05, 20:43 PM

So, I already had the June 1st security patch and a new security patch has just downloaded to my phone. I don't know the date of it, as I'm not installing it just now, I'll install it later tonight.

I don't expect much from it but I'll let you know how it goes. Maybe a couple of days of somewhat improved performance, before going back to hell, who knows.

I understand the best solution seems to be a factory reset, but I've been putting it off for different reasons, depending on how the update goes I may factory reset my phone tonight or in the next few days to a week, but I'm pretty sure I'll end up down that road.

Anyway, I'm one of those who has decided no more Moto for me after the G6, it's been a long journey from analog to digital to smart phones but enough is enough, I only hope this update and/or a factory reset will give some half good performance as it wasn't in my plans changing phones until March or April 2020, at least.

With Android 10 coming to some phones in the market, such as Samsung Galaxy A50, I don't want any more surprises, I really want to wait for either a new model with Android 10 out of the box or something that has being tested, updated and thoroughly tested again after the update.



On an unrelated note, if anyone knows of someone wanting to buy a used Moto G6 in prime condition, please me know.

Also, has anyone heard anything from Agent_Swaraj? It's been at least a month and and I'm starting to worry something may have happend to him, as he wouldn't just quit on us, or would he?

Reply
Options

13 Posts

07-16-2019

Mexico

48 Signins

238 Page Views

  • Posts: 13
  • Registered: ‎07-16-2019
  • Location: Mexico
  • Views: 238
  • Message 389 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-09-05, 21:26 PM

So, I already had the June 1st security patch and a new security patch has just downloaded to my phone. I don't know the date of it, as I'm not installing it just now, I'll install it later tonight.

I don't expect much from it but I'll let you know how it goes. Maybe a couple of days of somewhat improved performance, before going back to hell, who knows.

I understand the best solution seems to be a factory reset, but I've been putting it off for different reasons, depending on how the update goes I may factory reset my phone tonight or in the next few days to a week, but I'm pretty sure I'll end up down that road.

Anyway, I'm one of those who has decided no more Moto for me after the G6, it's been a long journey from analog to digital to smart phones but enough is enough, I only hope this update and/or a factory reset will give some half good performance as it wasn't in my plans changing phones until March or April 2020, at least.

With Android 10 coming to some phones in the market, such as Samsung Galaxy A50, I don't want any more surprises, I really want to wait for either a new model with Android 10 out of the box or something that has being tested, updated and thoroughly tested again after the update.



On an unrelated note, if anyone knows of someone wanting to buy a used Moto G6 in prime condition, please me know.

Also, has anyone heard anything from Agent_Swaraj? It's been at least a month and and I'm starting to worry something may have happend to him, as he wouldn't just quit on us, or would he?

Reply
Options

6 Posts

02-21-2016

australia

10 Signins

37 Page Views

  • Posts: 6
  • Registered: ‎02-21-2016
  • Location: australia
  • Views: 37
  • Message 390 of 653

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

2019-09-05, 23:23 PM

i did factory reset - good for about 2 weeks then lag started again

 

just reset again :/

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms