cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
fazzled
Paper Tape
Posts: 3
Registered: ‎11-08-2018
Location: CA
Views: 150
Message 1 of 5

G6 not detecting headphone removal

Hello,

 

I just got a G6 and have found that it does not detect the removal of headphones.  I have tried the Audio Connection test in the Moto Help app and the checkmark appears when the headphones are inserted but does not change back to the when they are removed.  I have also enabled the headphone notification via the System UI Tuner and it is always displayed.  I also tried to make a call after removing the headphones and no sound comes through the phone's speaker.  I have found that power cycling the phone fixes the problem.  Has anyone else run into this?  If so, have you found a solution?

 

 

Thanks

Senior MotoAgent
Senior MotoAgent
Posts: 3,747
Registered: ‎12-04-2017
Location: IN
Views: 114
Message 2 of 5

Re: G6 not detecting headphone removal


@fazzled wrote:

Hello,

 

I just got a G6 and have found that it does not detect the removal of headphones.  I have tried the Audio Connection test in the Moto Help app and the checkmark appears when the headphones are inserted but does not change back to the when they are removed.  I have also enabled the headphone notification via the System UI Tuner and it is always displayed.  I also tried to make a call after removing the headphones and no sound comes through the phone's speaker.  I have found that power cycling the phone fixes the problem.  Has anyone else run into this?  If so, have you found a solution?

 

 

Thanks


Hello fazzled,

 

Thank you for posting here, this is odd and if you have already tested in 'Moto Help' with a negative result. It indicates a hardware issue to me. You can, however, proceed for exchange if it's in exchange window.

 

Also, as you say that a restart fixes the issue, could you help us understand how frequently do you see this? We want to look further into this, if you can update your profile with the IMEI of your device, this can help us investigate and see what's causing the disconnect. Also, kindly send a bug report regarding this. Bug report will collect information about your current device state

Go to Settings ->Developer options -> Enable USB debugging > Toggle On

Enable Settings -> Developer options -> Enable Bug Report shortcut > Toggle On

Once the issue is reproduced: Go to Settings -> Developer options -> Click on take bug report or Press Power button and then choose Bug Report from the Power down menu.

Wait for some time until the bug report is collected. It takes around 3 to 4 minutes to collect the Bug Report.

Then upload the BugReport to your personal Google Drive and then share the link to the BugReport on the forums in a reply.

Provide observations of what you saw happen right before the bug report was taken. Please indicate the local time when you observed the behavior.

 

Let us know if you have any questions?


Regards,

Swaraj

Moto Support

fazzled
Paper Tape
Posts: 3
Registered: ‎11-08-2018
Location: CA
Views: 99
Message 3 of 5

Re: G6 not detecting headphone removal

Hi Swaraj,

 

I have added my IMEI to my profile.  I have also tried different headsets and have found that if a cable with four contacts (for a headset with a mic) is plugged in, it's removal is detected.  However after plugging in a three contact cable, plugging in and removing a four contact cable does not resolve the issue.  Also, plugging in a four contact cable after a three contact cable does not change the notification icon from a headset to a headset with a mic.

 

Doing a restart or power off & on always resolves the issue for me.  So far it has happened every time I've used a three contact cable.

 

 

Thanks

Senior MotoAgent
Senior MotoAgent
Posts: 3,747
Registered: ‎12-04-2017
Location: IN
Views: 58
Message 4 of 5

Re: G6 not detecting headphone removal


@fazzled wrote:

Hi Swaraj,

 

I have added my IMEI to my profile.  I have also tried different headsets and have found that if a cable with four contacts (for a headset with a mic) is plugged in, it's removal is detected.  However after plugging in a three contact cable, plugging in and removing a four contact cable does not resolve the issue.  Also, plugging in a four contact cable after a three contact cable does not change the notification icon from a headset to a headset with a mic.

 

Doing a restart or power off & on always resolves the issue for me.  So far it has happened every time I've used a three contact cable.

 

 

Thanks


Hi fazzled,

 

Thank you for trying, not sure which headset you are trying with? Could you share us make and model of the headset you have tested with? If it's working with one, I don't think the device has an issue? 


Regards,

Swaraj

Moto Support

fazzled
Paper Tape
Posts: 3
Registered: ‎11-08-2018
Location: CA
Views: 24
Message 5 of 5

Re: G6 not detecting headphone removal

Hi Swaraj,

 

The headsets that work are the ones that have four contacts (TRRS) .  The ones that only have three contacts (TRS) are the issue.  I have tried multiple of both with the same result.  When the TRRS are removed, that is detected; The notification icon goes away and sound will come from the phone when making a call. When the TRS are removed this is not detecter; The notification icon stays and sound does not come from the phone when making a call.  The phone is properly detecting the type of headset as the headset icon includes a microphone when TRRS headsets are plugged in and no microphone when a TRS headset is plugged in.

 

 

Thanks

Top Kudoed Authors