cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tinnickels
Blue Screen Again
Posts: 7
Registered: ‎01-23-2019
Location: US
Views: 622
Message 11 of 18

Re: Hotspot won't turn on after Pie update

Whoa, genius. This not only works, but I have a simpler version. Go to network and internet / SIM card and disable the SIM. Restart the phone. Turn on the hotspot (indirectly by long pressing the hotspot icon in the notification bar). Go back and enable the SIM. Bingo. Hotspot.

 

Too bad that once you turn it off you have to do all this again. But this way you don't have to screw around removing and reinserting the SIM.

 

And yes, my SIM has a hotspot on other phones and had one on this under Oreo. This pretty much much is the nail in the coffin that Moto killed the hotspot on Pie. Hopefully they fix it soon. But thanks for the workaround!

Moto G6 Plus (int'l unlocked on AT&T)
G6Intl
Paper Tape
Posts: 9
Registered: ‎01-29-2019
Location: US
Views: 617
Message 12 of 18

Re: Hotspot won't turn on after Pie update

That's awesome, I literally came back here to report that I found the the same thing.  I turned off the Sims, powered down, powered up, turned on the hotspot, activated the Sims and it worked!  

Jleeblanch
Serial Port
Posts: 13
Registered: ‎04-29-2012
Location: US
Views: 611
Message 13 of 18

Re: Hotspot won't turn on after Pie update

I actually noticed this issue after updating to Pie (PPW29.116-11) and for a while thought it was just me, but turns out at least a few are effected. 

 

I also found a permanent solution, but unfortunately 

 

😉

Please don't ask for or encourage modding discussions.  There are other good sites where you can find such information, but those discussions are no allowed here.  Sorry.

G6Intl
Paper Tape
Posts: 9
Registered: ‎01-29-2019
Location: US
Views: 588
Message 14 of 18

Re: Hotspot won't turn on after Pie update

I'm unlocked but I haven't had a need to root, until now.    There's a fix below that doesn't require root.  Modding discussions are not permitted in this forum.

Jaygee33
Blue Screen Again
Posts: 7
Registered: ‎02-06-2019
Location: US
Views: 535
Message 15 of 18

Re: Hotspot won't turn on after Pie update

This workaround worked for me too. Thanks G6Intl for directing me to this post. I also have a G6 Plus on AT&T. I had hotspot working when I was on G4 Plus. I don't use it often so I hadn't tried it on my new phone until after the Pie update.
Once I followed the workaround though, when hotspot was on, my previous Hotspot settings (name and password) were already set as I had in my G4 Plus. So I know how to get this working every time I need it, until a permanent fix is available.
Motorola Admin Motorola Admin
Motorola Admin
Posts: 1,948
Registered: ‎02-11-2016
Location: US
Views: 525
Message 16 of 18

Re: Hotspot won't turn on after Pie update


@G6Intl wrote:

I'm unlocked but I haven't had a need to root, until now.    There's a fix below that doesn't require root.  Modding discussions are not permitted in this forum.


I'm glad you were able to find a workaround. However, provisioning is handled by the carrier. Also, there is nothing we did to prevent users from using hotspot. That being said, the Moto G6 Plus was never intended to be sold or used in the US. We can not guarantee support or compatibility with any US carrier. If you purchased the phone from Amazon and the listing was misleading then please share the link with me and we will take a look. 

 

-Tom

Need help updating your profile? See here. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943
Jleeblanch
Serial Port
Posts: 13
Registered: ‎04-29-2012
Location: US
Views: 504
Message 17 of 18

Re: Hotspot won't turn on after Pie update


@MotorolaTom wrote:

@G6Intl wrote:

I'm unlocked but I haven't had a need to root, until now.    There's a fix below that doesn't require root.  Modding discussions are not permitted in this forum.


I'm glad you were able to find a workaround. However, provisioning is handled by the carrier. Also, there is nothing we did to prevent users from using hotspot. That being said, the Moto G6 Plus was never intended to be sold or used in the US. We can not guarantee support or compatibility with any US carrier. If you purchased the phone from Amazon and the listing was misleading then please share the link with me and we will take a look. 

 

-Tom


Out of curiosity, why wouldn't you sell the best G6 variant in the US? This seems like a trend you guys are continuing with the G7 serious, not selling the G7 Plus in the US 🤔. Makes no sense. You sold the G5 Plus, and G5S Plus in the US...so why stop the selling the "Plus" variants here? 

 

Anyway, back on topic. When using the G6 Plus on Oreo, this wasn't an issue. Updating to Pie, hopspot just stopped working. Some thing has changed. 

cbcalhoun
Paper Tape
Posts: 2
Registered: ‎01-10-2019
Location: US
Views: 477
Message 18 of 18

Re: Hotspot won't turn on after Pie update

Same problem here on my G6 Plus after Oreo upgraded to Pie. AT&T is useless for support. WiFi  teathering works fine on my old G5 with the same sim. This may be the last Moto I buy. I wasn't aware I bought a non US version on eBay until after I opened it... Quit blocking phone support in the US market.

Top Kudoed Authors