cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Barons40
802.11n
Posts: 449
Registered: ‎07-13-2017
Location: GB
Views: 1,396
Message 341 of 409

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]


@sc000 wrote:

I need to buy a new laptop. I've crossed off Lenovo from my buying list due to the apalling software support to my G6. That's how a Chinese firm loses a customer for life.

 


What ever will they do 🤣🤣

D412
Punch Card
Posts: 15
Registered: ‎02-13-2019
Location: US
Views: 1,335
Message 342 of 409

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

You


@Dude777 wrote:
Moto, modifying Android 9, creating their own version of the one button navigation surely must not have been a simple task. And, for most of us, is working flawlessly. Moto is plenty competent enough to fix things via patchs if not a whole new rom. Anyway, everyone giving feedback here should also give the same to Google via the phone's settings. It impacts patches being created and the next os release too.

Not trying to be rude but anyone can create their own One Button Nav on any phone with a fingerprint sensor with automation apps, add root/xposed and you can make a better one button nav without being a dev. Really all of the Moto actions can be easily replicated with automation apps, chop light, twist camera, pick up to silence, etc.  Point being nothing Moto added to stock Android is a big acccomplishment, nor time consuming  for a huge company like Lenovo.

 

Independent rom developers that get paid nothing released Pie for phones in a fraction of the time it was released for the G6. The Moto G3 is 4 years old and is still more actively updated by unpaid developers than the 1 year old G6 is updated by Lenovo. Lenovo has basically made a policy of completely abandoning phones that aren't brand new. The shame is people hate Moto so much now and there are so many other budget options that the G6 has basically had no device specific rom development.

Dude777
HDMI
Posts: 198
Registered: ‎03-28-2019
Location: US
Views: 1,325
Message 343 of 409

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

Thanks for that insight! I do see the lack of rom options. I'm hoping that'll improve in time. Do you think we got plenty of good hardware for US $150, assuming you're also one that has no issues with it and Pie?

~us retail g6~no lifeguard on duty
dpvball
Fanfold Paper
Posts: 16
Registered: ‎08-18-2019
Location: US
Views: 924
Message 344 of 409

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

So I've got my phone basically working in a pretty snappy state without having to do a reset or anything. i'm on PPSS29.118-11-1 and May 1 2019 Security Patch Level.

 

1) I'm running Microsoft Launcher. This was installed even before the Pie lagginess. But I enabled High Performance Mode under Advanced Settings. Other people have had success with Nova Launcher but it works for me with Microsoft Launcher

 

2) Under Settings -> System -> Motorola Privacy. Disable both "Help Improve Motorola Products" and "Enhanced Device Support"

 

3) Under Settings -> System -> Developer Options -> Hardware accelerated rendering. Enable "Force GPU rendering"

 

4) Under Settings -> App info. Disable the following items

Demo mode

Digital Wellbeing

Moto Help

Motorola Notifications

 

4) Under Settings -> App info. Disable the notifications for each motorola app 

Moto

Moto Actions

Moto App Launcher

Moto Help

Moto Voice for Alexa (If you have the amazon version)

Motorola Notifications

 

5) Under Settings -> Storage. If you have a SD card, move all the apps you have on the card back to your internal storage if possible. At least move the ones that you use frequently. The ones you don't use frequently can be left on your SD card.

 

6) Under Settings -> Storage -> internal storage. Disable Storage manager. 

 

7) Under Settings -> App Info. This is the tedious one. I went through and manually clicked into each app and cleared the cache on every single app in here. You can get to the clear cache button by clicking on the app, then storage. 

 

After all this, my phone is running fast now. There is still the occassional freeze, but even then it's only for like a half second before it starts responding again. Doesn't hang for like 10 seconds anymore. Anyways best of luck to you all. At least I have a functional phone again and don't need to throw it out the window. Clearly it's one or the combination of all these things that are causing the slow down. Just wish motorola would actually take their customers seriously and fix this issue. 

junasie_T130
Vacuum Tubes
Posts: 12
Registered: ‎08-10-2012
Location: US
Views: 878
Message 345 of 409

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

Can you please tell us the model number of your phone, your carrier, and whether the phone is unlocked or purchased through that carrier? Those things may be effecting the Pie update as well. Was your phone a big mess right after you updated, but before you changed all these settings? Glad it's working well now, but please update us if it starts to lag again. I'm reading reports that even after doing a factory reset, the phone eventually starts to have problems again. Thanks for all the info!

dpvball
Fanfold Paper
Posts: 16
Registered: ‎08-18-2019
Location: US
Views: 870
Message 346 of 409

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

so I have the Amazon Prime Exclusive version which as far as I understand is basically just the unlocked version with extra Amazon stuff loaded on and unremovable. I'm currently on AT&T as a carrier. and to answer your questions, my phone was running very smooth prior to the pie update. Then pie hit and basically similar to what everyone else was getting. Lag, freezes, even reboots of my phone from time to time. I checked various forums including here and xda to see what solutions people had. The more extreme scenario that people had which apparently fixes it is to do a complete wipe of the SD card and flash the stock firmware back onto the phone. That seems to fix it for most people. But instead I tried all the minor tweaks to see if I could get it fixed. 

 

Just fyi, I don't know if it just took time for everything to settle down but after I completed all the things. It was another couple hours before it went extremely smooth. Also I believe I did a reboot of the phone at that time. And amazingly almost at the same speed as when it was on Oreo. hopefully mine isn't a fluke and you guys can get the same results trying this. Let me know if it works. 

junasie_T130
Vacuum Tubes
Posts: 12
Registered: ‎08-10-2012
Location: US
Views: 822
Message 347 of 409

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

Thanks so much. Is the model number of your phone, XT-1925-6 (found under System, About phone, Hardware information, SKU)? I purchased an unlocked, 64 GB RAM phone earlier this year (not from Amazon) that I am using with AT&T, as they only sold the Moto g6 Play. I thought that all Moto g6 phones sold in the US and Canada had this model number, while the international version was XT-1925-2. Then I saw that someone on this forum has a phone from Verizon, model XT-1925-12, and his Pie update went smoothly. A few other people on Verizon also reported that they had no (or few) problems, so it got me wondering if there was something different about the unlocked version that made it incompatible. My phone also says Version PVT1. I have no idea what this means, but someone else who had a smooth update posted a screen shot showing hardware version PVT2. 

 

I am holding off on Pie for fear of irreparably breaking my phone, since I have had the phone for less than 6 months and have no complaints under Oreo. I have seen some Amazon reviews about problems with unlocked phones on AT&T after the May 1 patch update, but I can't remember if they specified the Amazon Prime version or not. There is talk of a June 1 security patch released in Europe that may (or may not) fix some of the problems with Pie, but I don't think it's out in the US yet.  If anyone knows how to get rid of the annoying system update prompt from Motorola, I would be forever grateful, as I am constantly swiping it away, all day long.

dpvball
Fanfold Paper
Posts: 16
Registered: ‎08-18-2019
Location: US
Views: 813
Message 348 of 409

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

My hardware is xt1925-6. Software version is amz. But if you're still on oreo I would stay there. While I've gotten mine to a pretty solid state. It really shouldn't be this much of a pain to get the phone into a working state. The benefits if any of going pie really aren't worth the headache. But if you did update like I did, I'd say give it a shot and see if it fixes the issue for you as well. 

gsorensen55
Paper Tape
Posts: 5
Registered: ‎08-08-2019
Location: US
Views: 721
Message 349 of 409

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

Hi folks. Wanted to share a fix I came across inadvertently. Since pie update, voice detection had been broken for me ("OK Google" , etc). The "Access with voice match" setting within Google assistant settings was toggled off and would not allow me to turn it back on. There is a thread on this topic as well, as it is affecting many users.

 

While searching for a fix to that issue, I did the following:

 

1) Moto App > Moto voice (beta) > gear icon > Retrain moto voice > toggle 'Voice control' to OFF.

 

2) Open Google assistant / now / whatever it's called > three dots > settings > Google assistant > assistant > scroll down to device-phone > toggle voice match to ON.

 

3) Optionally, re-enable moto voice. 

 

I was happy to find that Google voice match now worked again, but surprisingly all the Pie freezing/lagging was instantly fixed as well. Hope this helps some people. 

Mooskleo
Fanfold Paper
Posts: 10
Registered: ‎04-30-2019
Location: GB
Views: 507
Message 350 of 409

Re: Moto G6 - Lag / Irresponsive - Post Pie Update [G6 Users pls share your reviews here]

OK. So I've been posting to this thread since it was launched with a clogged up laggy unlocked G6 in the UK. The June update was finally offered to me yesterday and after backing up everything to Google cloud and factory reset.

 

So far.. lag has gone and phone is back up to previous speeds! Will report back in a week or so if this is still the case.

 

It appears we got there in the end...!

Top Kudoed Authors