Motorola Community

Moto G Phonesmoto g8 plus
All Forum Topics
Options

8 Posts

12-31-2019

FI

16 Signins

121 Page Views

  • Posts: 8
  • Registered: ‎12-31-2019
  • Location: FI
  • Views: 121
  • Message 1 of 8

Bluetooth/wifi lag/interference

2019-12-31, 19:01 PM

I bought a Moto G8 Plus, and a Bluetooth headset (Audio-Technica M50XBT) to go with it. Now whenever I'm out walking and listening to music with wifi on, the sound lags with ~10 second intervals. It gets even worse when I'm close to a public access point that I've previously connected to. Also, the phone has a hard time connecting to said access point when Bluetooth is active. When I turn off Bluetooth on the phone, or turn off my headphones, it instantly connects.

 

My question: is it possible to enjoy stutter-free music via Bluetooth while using Wifi on the Moto G8 Plus? 

Reply
Options

1462 Posts

03-11-2019

US

545 Signins

38370 Page Views

  • Posts: 1462
  • Registered: ‎03-11-2019
  • Location: US
  • Views: 38370
  • Message 2 of 8

Re: Bluetooth/wifi lag/interference

2020-01-02, 14:13 PM

Hi pizzajet,

 

Thanks for posting. Have you tried unpairing the Bluetooth device and repair it again? Does the sound lag happen when playing video as well? What music app are you using and if you tried other music apps? Can you test connecting to a Wi-Fi access point with the Bluetooth turned on but do not connect it to your headset. You may also try using a different Bluetooth device and check if the same thing would happen. 

 

Best regards,
Zeke
Motorola Support


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

8 Posts

12-31-2019

FI

16 Signins

121 Page Views

  • Posts: 8
  • Registered: ‎12-31-2019
  • Location: FI
  • Views: 121
  • Message 3 of 8

Re: Bluetooth/wifi lag/interference

2020-01-02, 22:34 PM

 wrote:

Hi pizzajet,

 

Thanks for posting. Have you tried unpairing the Bluetooth device and repair it again? Does the sound lag happen when playing video as well? What music app are you using and if you tried other music apps? Can you test connecting to a Wi-Fi access point with the Bluetooth turned on but do not connect it to your headset. You may also try using a different Bluetooth device and check if the same thing would happen. 

 

Best regards,
Zeke
Motorola Support


Thanks for replying :smileyhappy:

I have tried unpairing and pairing again, and resetting the network settings, but wifi still lags when connected to these headphones. However, I did try connecting a couple of other Bluetooth devices and the wi-fi was actually fine then.

Is it possible the headphones themselves are faulty and doing this to my Moto? I realise this is not an Audio-Technica support forum, but I've never used a bluetooth device before that made my phone's wifi half unusable, so I am kind of at a loss here

Best wishes, 

Gustav

Reply
Options

1462 Posts

03-11-2019

US

545 Signins

38370 Page Views

  • Posts: 1462
  • Registered: ‎03-11-2019
  • Location: US
  • Views: 38370
  • Message 4 of 8

Re: Bluetooth/wifi lag/interference

2020-01-03, 16:10 PM

Hi pizzajet,

 

We cannot tell if the Bluetooth headphones are the main cause of the issue but we would like to further investigate. Please do send us a Wi-Fi and Bluetooth Bug report. You will need access to the phone's developer settings to create a Bug report. 

 

BLUETOOTH BUG REPORT:
1. Go to Settings -> About Phone -> Tap on Build number 7 times on the build number to go into the developer options mode]
2. After the above steps Developer options will be enabled.
3. Go to Settings ->Developer options -> Enable USB debugging > Toggle On
4. Enable Settings -> Developer options -> Enable Bug Report shortcut > Toggle On
5. Enable Settings -> Developer options -> Enable Enable Bluetooth HCI snoop log > Toggle On

6.Enable Settings -> Developer options -> Enable Wi-Fi Verbose Logging > Toggle On
7. Once the issue is reproduced, Go to Settings -> Developer options -> Click on take bug report or Press Power button and then choose Bug Report from the Power-down menu.
8. Wait for some time until the bug report is collected. It takes around 3 to 4 minutes to collect the Bug Report.
9. Then upload the BugReport to your personal Google Drive
10. Open the File Manager app on your phone and tap on Local on the top right. Browse to internal.
11. Upload the btsnoop_hci.log to your Google Drive as well
12. Share the link to the bug report and btsnoop_hci.log via a private message.
13. Provide observations of what you saw happen right before the bug report was taken. Please indicate the time that you observed the behavior in local time.
14. One completed to Settings-> Developer options -> Enable Bluetooth HCI snoop log > Toggle Off

 

We would also suggest reporting your concern to Audio Technica if they have some steps to fix the issue. 

 

Best regards,
Zeke
Motorola Support


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

8 Posts

12-31-2019

FI

16 Signins

121 Page Views

  • Posts: 8
  • Registered: ‎12-31-2019
  • Location: FI
  • Views: 121
  • Message 5 of 8

Re: Bluetooth/wifi lag/interference

2020-01-03, 16:44 PM

Hi

 

I followed the steps and managed to extract a bug report, but I can't find the HCI log anywhere. I opened up Internal storage in the Files app but there are only folders ("Alarms", "DCIM", "Download", "Movies", "Pictures", etc) showing up. No file. I tried installing Solid File Explorer and then searched for "btsnoop_hci.log" but found nothing. I tried toggling Bluetooth off and on. I tried toggling "enable bluetooth hci snoop log" on and off again, and looked for a log file once again, and then toggled back to on again, and again looked for a file. Nothing. Where is this file supposed to generate?

 

Thank you

Reply
Options

1462 Posts

03-11-2019

US

545 Signins

38370 Page Views

  • Posts: 1462
  • Registered: ‎03-11-2019
  • Location: US
  • Views: 38370
  • Message 6 of 8

Re: Bluetooth/wifi lag/interference

2020-01-03, 16:58 PM

Hi pizzajet,

 

Maybe the Bluetooth snoop is not yet done being generated. Usually, the Bluetooth snoop log file will show up in your notifications will show up after the Bug Report and provide you the option to save it to Google Drive. Try generating another one again. 

 

Best regards,
Zeke
Motorola Support


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"!
This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Reply
Options

8 Posts

12-31-2019

FI

16 Signins

121 Page Views

  • Posts: 8
  • Registered: ‎12-31-2019
  • Location: FI
  • Views: 121
  • Message 7 of 8

Re: Bluetooth/wifi lag/interference

2020-01-04, 17:47 PM

Okay, so this problem seems to be mostly alleviated if I open the Bluetooth settings by long-pressing the BT icon, view the settings of my device (M50XBT), and toggle off "Input device". I have no idea what this means, but now I can use BT and Wifi at the same time without too much lag.

 

But  regardless I'd be interested to hear if the engineers found anything of interest in those bug reports I sent you

 

Thanks again!

Reply
Options

0 Posts

06-13-2015

Argentina

1 Signins

5 Page Views

  • Posts: 0
  • Registered: ‎06-13-2015
  • Location: Argentina
  • Views: 5
  • Message 8 of 8

Re: Bluetooth/wifi lag/interference

2020-02-03, 14:23 PM

I have had two G8's and the Bluetooth performance in my car is very poor. When I call someone I hear the ring tone and I also hear a ditorted ring tone. When I get an answer the distorted ring tone continues and the audio keeps cutting out. I have tried a G4, G5 and Motorola one in the car and they work with no trouble. This G8 also turns off when I'm making calls, which is a completely seperate issue.

 

I'm at the point of returning the phone to the vendor which is a shame because as a phone I really like it, but when I'm in my car its virtually unusable.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete