cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
abilogan
Fanfold Paper
Posts: 6
Registered: ‎06-09-2019
Location: GB
Views: 186
Message 11 of 16

Moto X Play only charging in factory mode or when switched off

This seems to be an old issue common to this phone but wondered if anyone had managed to resolve it, a search doesn't come up with anything definite.  Seemingly software related as occurred after an update, people originally could only charge the phone in factory mode, then after an update they could charge when switched off.  My phone follows same pattern.

 

Only charges up to about 77%, and charges slowly.  Bit of a problem.  Replacement battery hasn't done anything.  My Moto G6 is out of action possibly permanently, so would be a great help if this could be resolved to get the X back in use!! 

KarlBeckman
802.11n
Posts: 223
Registered: ‎10-12-2012
Location: US
Views: 165
Message 12 of 16

Re: Moto X Play only charging in factory mode or when switched off

First, clear the cache memory, which forces the phone to recalibrate during the next charging cycle. 

Then charge the battery using the Motorola fast charger provided with the phone. The phone must stay on charge for at least one hour after reaching 100%.

Though Motorola says "it shouldn't be necessary," I suggest that you run this process once a month. I run it overnight on the first Sunday evening of each month. Fixes app memory leaks as well as the charging setpoints. 

abilogan
Fanfold Paper
Posts: 6
Registered: ‎06-09-2019
Location: GB
Views: 147
Message 13 of 16

Re: Moto X Play only charging in factory mode or when switched off

Thanks for reply but tried this and didn't work, cache cleared a few times (as well  as multiple factory resets) but never charges beyond the 77%.  Battery drains quickly too.  Just wondering if anyone who's had this problem ever found a solution in the end, there are enough of them.

Highlighted
Senior MotoAgent
Senior MotoAgent
Posts: 5,622
Registered: ‎03-05-2018
Location: US
Views: 138
Message 14 of 16

Re: Moto X Play only charging in factory mode or when switched off

Hi abilogan,

 

We usually suggest performing a factory data reset without restoring apps/files. Observe the phone with its default apps, see if there's any improvement with the battery. Make sure the brightness isn't set high. Consider the mobile network strength. And try installing your apps one at a time until you find out which app causes the draining. Let me know if you have a question. Thanks.

 

Best regards,
Rich
Motorola-Lenovo Support

abilogan
Fanfold Paper
Posts: 6
Registered: ‎06-09-2019
Location: GB
Views: 135
Message 15 of 16

Re: Moto X Play only charging in factory mode or when switched off

Done all this, it's had countless resets and nothing makes it charge properly, seems to be a known issue with this phone and sounds like the problem lies within Motorola's software as everyone seems to say it happened after an update. If you read the post it's a lot more complex than battery draining too quickly.  Also tried a new battery to no avail.

Senior MotoAgent
Senior MotoAgent
Posts: 5,622
Registered: ‎03-05-2018
Location: US
Views: 109
Message 16 of 16

Re: Moto X Play only charging in factory mode or when switched off


@abilogan wrote:

Done all this, it's had countless resets and nothing makes it charge properly, seems to be a known issue with this phone and sounds like the problem lies within Motorola's software as everyone seems to say it happened after an update. If you read the post it's a lot more complex than battery draining too quickly.  Also tried a new battery to no avail.


I appreciate all the troubleshooting steps you've tried. We have isolated the software side as one of the factors and this is more likely a hardware failure. Repair would be the next option I would recommend. 

 

Best regards,
Rich
Motorola-Lenovo Support