cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
xandey
Punch Card
Posts: 44
Registered: ‎05-04-2018
Location: US
Views: 4,894
Message 6 of 128

Android Auto random disconnects 8.1.0 OPW28.2

After going a month without usb data working at all. I got the 28.2 update on my phone and now I experience a great many AA disconnects.

 

I am still trying to work out what is causing this, but maybe someone else has a work-around until either AA or Moto go ahead and produce a real fix.

 

I connect to a 2016 VW GTI. I've tried many cables, including the cable which came with my moto x4 and hasn't been used much. Also two other cables that worked fine with my old nexus 5x.

 

It's possible that _stometimes_ the disconnects are correlated with the phone beginning to charge, but definitely not all the time.

 

I currently use google map and Smart Audio book player during my drives.

 

Ideas:

- enable usb debugging

- disable doze for apps (battery saver?)

- new cable (think I've covered this one)

- bug report with google

- bug report with motorola

- car? (i've seen other people with similar symptoms usually with different cars).

 

So motorola, who's responsibility is this? Google? Fi? You? Nobody?

 

Bug report has been sent via pm to agent jm, and IMEI in profile.

 

I experienced repeated disconnecting/reconnect attempts as stated by my car infotainment system around 530pm June 19. I captured the big report after the first disconnect though. I can grab another if needed. I also had a depleted battery so I don't think this triggered the switching charging on/off condition.

commguy101
What's DOS?
Posts: 2
Registered: ‎06-15-2018
Location: US
Views: 5,099
Message 1 of 128

Re: 8.1 Broke USB Transfer Capabilities

Agent_JM ... patch came through and Android Auto once again recognizes phone, BUT the connection does not hold. Within five to fifteen minutes (with no discernable pattern) the phone disconnects from the car. Requires pulling the plug, allowing AA to close on the phone, then plugging it back in. I will disconnect while playing music, while on a phone call, so it is not a sleep issue. Disabling screen lock is not a solution because it affects Google Pay, etc.

 

Is anyone else experiencing the same thing? Moto X4, Android One, 2017 Honda Civic Touring

 

Thanks! (Frustrated, still.)

Mike0001
Fanfold Paper
Posts: 19
Registered: ‎05-09-2018
Location: US
Views: 5,081
Message 2 of 128

Re: 8.1 Broke USB Transfer Capabilities

I too have random disconnects with using Android Auto.  This problem was prior to the breaking/fixing of the USB issue and still seems about the same.  I drive an hour each way to work and most days have at least 1 disconnect.  I usually give up when the disconnect happens and just unplug and switch to bluetooth.  I agree its really annoying but don't think its directly related to this issue.


@commguy101
vicnam
Vacuum Tubes
Posts: 30
Registered: ‎06-27-2014
Location: US
Views: 5,161
Message 3 of 128

Re: 8.1 Broke USB Transfer Capabilities

I have been experiencing the random disconnects on Android Auto on a Hyundai after installing the May update.

 

ROM3000
Punch Card
Posts: 4
Registered: ‎05-08-2018
Location: US
Views: 5,140
Message 4 of 128

Re: 8.1 Broke USB Transfer Capabilities

Same here, but in my case on a Ford Focus.
abatishchev
Fanfold Paper
Posts: 16
Registered: ‎05-31-2018
Location: US
Views: 5,097
Message 5 of 128

Re: 8.1 Broke USB Transfer Capabilities

So (un)fortu fortun I'm not alone. I'm experiencing random disconnects on my Hyundai too. They started to happen two months back when I turned off the security and continued after installing the patch, nothing has changed. Very frustrating.

 

So what we have on total? June security patch is not a final fix but temporal buggy workaround. Work hard and finally give us normal device. Asap!

 

Next time it disconnects and doesn't connect back fast enough - I'll call Google Fi and claim my phone is "lemon". Because that's what it is!!

Senior MotoAgent
Senior MotoAgent
Posts: 5,397
Registered: ‎07-12-2014
Location: US
Views: 4,884
Message 7 of 128

Re: Android Auto random disconnects 8.1.0 OPW28.2

This is odd but we'd certainly look deeper into it. I will be raising this to our product team. Please help me with a few more information to forward to them. Kindly send a bug report regarding this. Bug report will collect information about your current device state.

 

Below are the steps for getting bug report:

 

1. Go to Settings -> About Phone -> Tap on Build number seven times on the build number to enable a new Settings item, Developer options.
2. Go to Settings ->Developer options -> Enable USB debugging > Toggle On
3. Enable Settings -> Developer options -> Enable Bug Report shortcut > Toggle On
4. Once the issue is reproduced: Go to Settings -> Developer options -> Click on take bug report or Press Power button and then choose Bug Report from the Power down menu.
5. Wait for some time until the bug report is collected. It takes around 3 to 4 minutes to collect the Bug Report.
6. Then upload the BugReport to your personal Google Drive and then share the link to the BugReport on the forums in a reply or via a private message..
7. Provide observations of what you saw happen right before the bug report was taken. Please indicate the local time when you observed the behavior.

 

Regards,
JM
Motorola Support

**Please don't ask me questions by Personal Message; questions belong in the forums.

xandey
Punch Card
Posts: 44
Registered: ‎05-04-2018
Location: US
Views: 4,858
Message 8 of 128

Re: 8.1 Broke USB Transfer Capabilities


@abatishchev wrote:

So (un)fortu fortun I'm not alone. I'm experiencing random disconnects on my Hyundai too. They started to happen two months back when I turned off the security and continued after installing the patch, nothing has changed. Very frustrating.

 

So what we have on total? June security patch is not a final fix but temporal buggy workaround. Work hard and finally give us normal device. Asap!

 

Next time it disconnects and doesn't connect back fast enough - I'll call Google Fi and claim my phone is "lemon". Because that's what it is!!


I know we're all frustrated. Please realize that these messages come into all our inboxes. I (and Motorola, and AgentJM) are trying to get bug reports and see if we can figure out a workaround. Please try to post things which may be helpful.

 

I had a similar but not exact issue with my Nexus 5X for a while, google eventually fixed it. It will take time, but I would like to follow this thread to see if anyone gets this to work and reading messages like this make us all depressed.

xandey
Punch Card
Posts: 44
Registered: ‎05-04-2018
Location: US
Views: 4,780
Message 9 of 128

Re: Android Auto random disconnects 8.1.0 OPW28.2

I edited the original post with bug report info.

Senior MotoAgent
Senior MotoAgent
Posts: 5,397
Registered: ‎07-12-2014
Location: US
Views: 4,774
Message 10 of 128

Re: Android Auto random disconnects 8.1.0 OPW28.2


@xandey wrote:

I edited the original post with bug report info.


Hello xandey. I got the bug report and have already forwarded it to our product team. I will post back once I receive some feedback from them. Thanks for your cooperation. 

 

Regards,
JM
Motorola Support

**Please don't ask me questions by Personal Message; questions belong in the forums.

Top Kudoed Authors