Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto X PhonesMoto X4
All Forum Topics
Options

16 Posts

11-02-2017

United States of America

53 Signins

726 Page Views

  • Posts: 16
  • Registered: ‎11-02-2017
  • Location: United States of America
  • Views: 726
  • Message 1 of 125

[Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

2018-12-20, 21:40 PM

I have an Android One X4 running Pie and my carrier is Google Fi. Around the time when the November 1st security patch came out for Oreo (8.1) I stared seeing "Invalid SIM" notifications pop up. I've tolerated those for a few weeks but recently did some testing and noticed that this message pops up whenever my device tries to associate with Sprint. 

Followed all of the recommended steps to clear cache, reset network settings, etc. Even ordered a new Google Fi SIM but that made no difference. 

Any ideas what's up and how to fix?
 
I see a bunch of others on Reddit saying that this is happening to them as of the Pie update. But I, and a few others, have seen this happen before Pie. 

Reply
Options

25 Posts

12-13-2017

United States of America

120 Signins

359 Page Views

  • Posts: 25
  • Registered: ‎12-13-2017
  • Location: United States of America
  • Views: 359
  • Message 2 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

2018-12-22, 2:58 AM

I'm having the same issue too. Any update on this? It's really annoying and happening to both my phone and my wife's phone.

Reply
Options

4 Posts

05-08-2018

United States of America

169 Signins

1067 Page Views

  • Posts: 4
  • Registered: ‎05-08-2018
  • Location: United States of America
  • Views: 1067
  • Message 3 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

2018-12-25, 7:26 AM

I'm having this same issue after upgrading to Android P. Any update? 

Reply
Options

7 Posts

10-28-2017

United States of America

43 Signins

144 Page Views

  • Posts: 7
  • Registered: ‎10-28-2017
  • Location: United States of America
  • Views: 144
  • Message 4 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

2018-12-25, 14:57 PM
Also having this problem after updating wife's Android One to Pie. Error message, especially when changing to Sprint. Upgrade to Pie not yet available on my Amazon Prime X4, but I will not update until error is fixed. Very disappointed in Lenovo for letting upgrade out with this level of problems.
Reply
Options

6 Posts

05-28-2015

United States of America

9 Signins

156 Page Views

  • Posts: 6
  • Registered: ‎05-28-2015
  • Location: United States of America
  • Views: 156
  • Message 5 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

2018-12-26, 18:13 PM

My wife and I are getting the same error. Hasn't actually caused any connectivity issues from what I can tell. Seems to coincide with weak wireless coverage areas around my house and workplace. So that's probably when it's trying to switch to Sprint.

Reply
Options

9 Posts

07-13-2017

United States of America

11 Signins

89 Page Views

  • Posts: 9
  • Registered: ‎07-13-2017
  • Location: United States of America
  • Views: 89
  • Message 6 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

2018-12-27, 3:25 AM

I bought my X4 about a month ago from Google Fi, and it has the same problem switching to Sprint. Started with Pie update. Invalid Sim Card errors, then falls back to TMobile. (I'm switching with dialer codes.) Very frustrating for a new phone. Hoping for a quick fix. The problem seems quite wide spread. Luckily TMobile is the best service in my area.

Reply
Options

9 Posts

07-13-2017

United States of America

11 Signins

89 Page Views

  • Posts: 9
  • Registered: ‎07-13-2017
  • Location: United States of America
  • Views: 89
  • Message 7 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

2018-12-27, 3:28 AM
Fi has a Maximize Coverage option in their app, but it always fails with the same errors, apparently on the Sprint network. I am sometimes able to switch using the Sprint code, but the switch doesn't hold.
Reply
Options

25 Posts

12-13-2017

United States of America

120 Signins

359 Page Views

  • Posts: 25
  • Registered: ‎12-13-2017
  • Location: United States of America
  • Views: 359
  • Message 8 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

2018-12-27, 16:20 PM

I finally received a reply from Google Fi support. A "specialist" is going to look into the issue.

Reply
Options

1 Posts

12-28-2018

United States of America

2 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎12-28-2018
  • Location: United States of America
  • Views: 5
  • Message 9 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

2018-12-28, 22:57 PM

Exact same issue here. Following for help. I thought maybe I had done something to the phone.

Reply
Options

9 Posts

07-13-2017

United States of America

11 Signins

89 Page Views

  • Posts: 9
  • Registered: ‎07-13-2017
  • Location: United States of America
  • Views: 89
  • Message 10 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

2018-12-29, 18:27 PM

Actually I'm unsure when this actually started. It could have been happening since I got the phone, which had 8.1 installed on it. I got it in early December, and it did several updates immediately, then Pie update much later. I have contact Fi support several times and they say it is a known issue and they are working on it. Very dissappointing! Both Lenovo and Google have seriously dropped the ball on this phone.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms