cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mac24
Serial Port
Posts: 20
Registered: ‎11-02-2017
Location: US
Views: 5,989
Message 1 of 125

[Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

I have an Android One X4 running Pie and my carrier is Google Fi. Around the time when the November 1st security patch came out for Oreo (8.1) I stared seeing "Invalid SIM" notifications pop up. I've tolerated those for a few weeks but recently did some testing and noticed that this message pops up whenever my device tries to associate with Sprint. 

Followed all of the recommended steps to clear cache, reset network settings, etc. Even ordered a new Google Fi SIM but that made no difference. 

Any ideas what's up and how to fix?
 
I see a bunch of others on Reddit saying that this is happening to them as of the Pie update. But I, and a few others, have seen this happen before Pie. 

hainersa
Punch Card
Posts: 24
Registered: ‎12-13-2017
Location: US
Views: 5,806
Message 2 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

I'm having the same issue too. Any update on this? It's really annoying and happening to both my phone and my wife's phone.

ROM3000
Punch Card
Posts: 4
Registered: ‎05-08-2018
Location: US
Views: 5,563
Message 3 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

I'm having this same issue after upgrading to Android P. Any update? 

jj31234
Fanfold Paper
Posts: 6
Registered: ‎10-28-2017
Location: US
Views: 5,541
Message 4 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

Also having this problem after updating wife's Android One to Pie. Error message, especially when changing to Sprint. Upgrade to Pie not yet available on my Amazon Prime X4, but I will not update until error is fixed. Very disappointed in Lenovo for letting upgrade out with this level of problems.
JAMES_BOSSMAN
Blue Screen Again
Posts: 2
Registered: ‎05-28-2015
Location: US
Views: 5,418
Message 5 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

My wife and I are getting the same error. Hasn't actually caused any connectivity issues from what I can tell. Seems to coincide with weak wireless coverage areas around my house and workplace. So that's probably when it's trying to switch to Sprint.

KenMo
Paper Tape
Posts: 9
Registered: ‎07-13-2017
Location: US
Views: 5,361
Message 6 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

I bought my X4 about a month ago from Google Fi, and it has the same problem switching to Sprint. Started with Pie update. Invalid Sim Card errors, then falls back to TMobile. (I'm switching with dialer codes.) Very frustrating for a new phone. Hoping for a quick fix. The problem seems quite wide spread. Luckily TMobile is the best service in my area.

KenMo
Paper Tape
Posts: 9
Registered: ‎07-13-2017
Location: US
Views: 5,359
Message 7 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

Fi has a Maximize Coverage option in their app, but it always fails with the same errors, apparently on the Sprint network. I am sometimes able to switch using the Sprint code, but the switch doesn't hold.
hainersa
Punch Card
Posts: 24
Registered: ‎12-13-2017
Location: US
Views: 5,301
Message 8 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

I finally received a reply from Google Fi support. A "specialist" is going to look into the issue.

Peajay
What's DOS?
Posts: 1
Registered: ‎12-28-2018
Location: US
Views: 5,175
Message 9 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

Exact same issue here. Following for help. I thought maybe I had done something to the phone.

KenMo
Paper Tape
Posts: 9
Registered: ‎07-13-2017
Location: US
Views: 5,125
Message 10 of 125

Re: [Google Fi / Android One] Moto X4 "Invalid SIM Card" notification while on Sprint

Actually I'm unsure when this actually started. It could have been happening since I got the phone, which had 8.1 installed on it. I got it in early December, and it did several updates immediately, then Pie update much later. I have contact Fi support several times and they say it is a known issue and they are working on it. Very dissappointing! Both Lenovo and Google have seriously dropped the ball on this phone.

Top Kudoed Authors