cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Hogerio
Fanfold Paper
Posts: 6
Registered: ‎01-11-2018
Location: BR
Views: 408
Message 1 of 12

Moto X4 - Bluetooth codec AAC não funciona

My Moto X4, while on Android Oreo the bluetooth audio worked with the AAC codec, but once it upgraded to the Android Pie, it is not changing to AAC, it stays on the SBC. In the developer options, when you force the AAC codec, it automatically returns to the SBC. In the bluetooth settings when switching to "Audio HD: AAC", the sound continues with SBC quality.

 

I tried connecting the same headset on another Android Nougat smartphone and connected normally with AAC codec.
 

I researched in some other brands forums, the same problem happens after upgrading to Android Pie. Probably a development problem for the new system version, but I did not find a solution.

 
Headphone: Pioneer SE-MJ553BT
K1512
What's DOS?
Posts: 2
Registered: ‎01-03-2019
Location: PL
Views: 332
Message 2 of 12

Re: Moto X4 - Bluetooth codec AAC não funciona

The same observations with Bose QC35ii.

Nyland
Paper Tape
Posts: 2
Registered: ‎01-03-2019
Location: NO
Views: 328
Message 3 of 12

Re: Moto X4 - Bluetooth codec AAC não funciona

Same observation with a JVC car headunit.

It works again if i go into the connection settings, and turns the connections on/off a random number of times. Seems totally random.

 

FIX THIS!!! Drives me nuts!

Senior MotoAgent
Senior MotoAgent
Posts: 5,397
Registered: ‎07-12-2014
Location: US
Views: 292
Message 4 of 12

Re: Moto X4 - Bluetooth codec AAC não funciona


@Hogerio wrote:

My Moto X4, while on Android Oreo the bluetooth audio worked with the AAC codec, but once it upgraded to the Android Pie, it is not changing to AAC, it stays on the SBC. In the developer options, when you force the AAC codec, it automatically returns to the SBC. In the bluetooth settings when switching to "Audio HD: AAC", the sound continues with SBC quality.

 

I tried connecting the same headset on another Android Nougat smartphone and connected normally with AAC codec.
 

I researched in some other brands forums, the same problem happens after upgrading to Android Pie. Probably a development problem for the new system version, but I did not find a solution.

 
Headphone: Pioneer SE-MJ553BT

Hi Hogerio,

 

Thanks for reaching out to us. We are ready to assist here. The Pioneer SE-MJ553BT, as per its product manual, does not support AAC, hence it falls back to SBC.

 

Regards,
JM
Motorola Support

**Please don't ask me questions by Personal Message; questions belong in the forums.

Senior MotoAgent
Senior MotoAgent
Posts: 5,397
Registered: ‎07-12-2014
Location: US
Views: 291
Message 5 of 12

Re: Moto X4 - Bluetooth codec AAC não funciona


@K1512 wrote:

The same observations with Bose QC35ii.


The Bose QC35ii does support AAC, so AAC should get preference unless you override to SBC in developer options. Can you confirm if you have selected SBC in developer options for codec priority? Would you please update your profile with the IMEI number of your phone as well as your carrier? If you need a reference in updating your profile, please click this link. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943

 

What is the current software version and build number of your phone?

Regards,
JM
Motorola Support

**Please don't ask me questions by Personal Message; questions belong in the forums.

Senior MotoAgent
Senior MotoAgent
Posts: 5,397
Registered: ‎07-12-2014
Location: US
Views: 289
Message 6 of 12

Re: Moto X4 - Bluetooth codec AAC não funciona


@Nyland wrote:

Same observation with a JVC car headunit.

It works again if i go into the connection settings, and turns the connections on/off a random number of times. Seems totally random.

 

FIX THIS!!! Drives me nuts!


Not all JVC car units support AAC. Please provide the specific model details of the car unit you are using. In addition, if you haven't yet, please update your profile with the IMEI number of your phone? If you need a reference in updating your profile, please click this link. https://forums.lenovo.com/t5/Forum-Feedback/Complete-your-forums-profile/td-p/3339943

 

What is the software version and build number of your phone?

Regards,
JM
Motorola Support

**Please don't ask me questions by Personal Message; questions belong in the forums.

Nyland
Paper Tape
Posts: 2
Registered: ‎01-03-2019
Location: NO
Views: 284
Message 7 of 12

Re: Moto X4 - Bluetooth codec AAC não funciona

Build version: PPW29.69-26
Android 9

Headunit: JVC KW-DB92BT

AAC worked perfectly stable untill i updated to Android 9.0...
As i said, i can get AAC to work, but it requires me to turn Media Audio on and off a couple of times until AAC appears next to HD audio. Then everything work fine untill i reconnect. Then i have to do the same thing over again.

Hope you can patch this quickly.
Regards
Hogerio
Fanfold Paper
Posts: 6
Registered: ‎01-11-2018
Location: BR
Views: 281
Message 8 of 12

Re: Moto X4 - Bluetooth codec AAC não funciona

Hi, JM! Before buying my product I researched a lot about it:

 

https://pioneer-headphones.com/outdoor/se-mj553bt.html

 

So he has yes AAC codec support.

 

The product I purchase is legitimate. If I am saying that in Android 8.0 it worked, I did a series of tests with both codecs (SBC and AAC), the quality is quite different. Already in Android 9.0 does not rise to the AAC quality.

K1512
What's DOS?
Posts: 2
Registered: ‎01-03-2019
Location: PL
Views: 266
Message 9 of 12

Re: Moto X4 - Bluetooth codec AAC não funciona

S/W: Android 9 build PPW29.69-26

How to duplicate the bug?
1. Clear the paired devices list in headphones and forget the headphones from telephone BT devises list.
2. Pair the QC35ii headphones following the standard procedure
3. Everytin works (almost) as expected now:
- in "Connected devices" => "Device details" there are four items, one of them is "HD audio: AAC [enabled]"
- in "Developer options" BT audio codec is listed as SBC, despite 'AAC enabled" in "Device details"
4. Switch the headphones off.
5. Switch the headphones back on, now it's not good anymore:
- in "Connected devices" => "Device details" there are three items only, the them is "HD audio" disappeared
- switching back and forth in "Developer option" the codec from AAC to SBC doesn't give any sonic effect (don't hear the little sound pause during codec switching).

To have the "HD audio: AAC [enabled]" in "Device list" back again, you need to forget the paired device and pair it again (i.e. go to item #1 from described above procedure)

I hope this helps.

Thanks in advance for fixing, I love your phone!
Senior MotoAgent
Senior MotoAgent
Posts: 5,397
Registered: ‎07-12-2014
Location: US
Views: 242
Message 10 of 12

Re: Moto X4 - Bluetooth codec AAC não funciona

Thank you for all the information guys. I'd like some more information to forward to our product team regarding this. Kindly send a bug report regarding this. Bug report will collect information about your current device state. Below are the steps for getting bug report:

1. Go to Settings -> About Phone -> Tap on Build number 7 times on the build number to go in to the developer options mode]
2. After the above steps Developer options will be enabled.
3. Go to Settings ->Developer options -> Enable Usb debugging > Toggle On
4. Enable Settings -> Developer options -> Enable Bug Report shortcut > Toggle On
5. Enable Settings -> Developer options -> Enable Enable Bluetooth HCI snoop log > Toggle On
6. Once the issue is reproduced, Go to Settings -> Developer options -> Click on take bug report or Press Power button and then choose Bug Report from the Power down menu.
7. Wait for some time until the bug report is collected. It takes around 3 to 4 minutes to collect the Bug Report.
8. Then upload the BugReport to your personal Google Drive
9. Open the File Manager app on your phone and tap on Local on the top right. Browse to internal.
10. Upload the btsnoop_hci.log to your Google Drive as well
11. Share the link to the BugReport and btsnoop_hci.log on the forums in a reply or via a private message.
12. Provide observations of what you saw happen right before the bug report was taken. Please indicate the time that you observed the behavior in local time.
13. One completed to Settings-> Developer options -> Enable Bluetooth HCI snoop log > Toggle Off

 

Regards,
JM
Motorola Support

**Please don't ask me questions by Personal Message; questions belong in the forums.

Top Kudoed Authors