Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto X PhonesMoto X4
All Forum Topics
Options

5 Posts

12-17-2018

Germany

4 Signins

125 Page Views

  • Posts: 5
  • Registered: ‎12-17-2018
  • Location: Germany
  • Views: 125
  • Message 1 of 3

Moto X4 bricked during flash of lineageOS and OpenGApps with TWRP

2018-12-17, 22:05 PM

Hello,

I unlocked my new Moto X4 (XT1900-7, Type M2A7A) following the steps on motorola's website and tried to install LineageOS.
On my PC I use Linux Mint, ADB, Fastboot.

 

First I installed and started TWRP (twrp-3.2.3-1-payton.img).

 

In TWRP I tried to install these to files queued / in one step:

lineage-15.1-20181207-nightly-payton-signed.zip
open_gapps-arm64-8.1-nano-20181207.zip

Everything went according to plan until TWRP called the second file.
My phone thereby hardbricked, but I had success starting the display again with blankflash on a friends' Win7-PC.
Now I'm stuck in some kind of bootloop not able to flash or boot anything.

fastboot finds my device, but adb does not


lsusb says:

Bus 003 Device 006: ID 22b8:2e80 Motorola PCS


On my Moto_X4 I see this on the Display:

Bootloader logs
Start Up Failed: Your device didn't start up successully.
Use the Software Repair Assistant on computer to repair ...
AP Fastboot Flash Mode (Secure)
Not bootable A/B slot
Fastboot Reason: Fall-through from normal boot mode
Fastboot Reason: Fall-through from recovery boot mode

 

Tried single steps aswell without success:

sudo fastboot flash partition gpt.bin
fastboot flash bootloader bootloader.img
fastboot reboot-bootloader


This is what I see on my PC:

target reported max download size of 536870912 bytes
sending 'partition' (37 KB)...
OKAY [  0.005s]
writing 'partition'...
(bootloader) Validating 'gpt.default.xml'
(bootloader) Committing 'gpt.default.xml'
(bootloader) - flashing 'gpt_main0.bin' to 'partition:0'
FAILED (status read failed (No such device))
finished. total time: 5.114s
...


Can you help me to reflash official firmware/stockROM?

Thank you very much!

Reply
Options

57 Posts

10-09-2016

India

177 Signins

2342 Page Views

  • Posts: 57
  • Registered: ‎10-09-2016
  • Location: India
  • Views: 2342
  • Message 2 of 3

Re: Moto X4 bricked during flash of lineageOS and OpenGApps with TWRP

2018-12-18, 16:07 PM

 wrote:

Hello,

I unlocked my new Moto X4 (XT1900-7, Type M2A7A) following the steps on motorola's website and tried to install LineageOS.
On my PC I use Linux Mint, ADB, Fastboot.

 

First I installed and started TWRP (twrp-3.2.3-1-payton.img).

 

In TWRP I tried to install these to files queued / in one step:

lineage-15.1-20181207-nightly-payton-signed.zip
open_gapps-arm64-8.1-nano-20181207.zip

Everything went according to plan until TWRP called the second file.
My phone thereby hardbricked, but I had success starting the display again with blankflash on a friends' Win7-PC.
Now I'm stuck in some kind of bootloop not able to flash or boot anything.

fastboot finds my device, but adb does not


lsusb says:

Bus 003 Device 006: ID 22b8:2e80 Motorola PCS


On my Moto_X4 I see this on the Display:

Bootloader logs
Start Up Failed: Your device didn't start up successully.
Use the Software Repair Assistant on computer to repair ...
AP Fastboot Flash Mode (Secure)
Not bootable A/B slot
Fastboot Reason: Fall-through from normal boot mode
Fastboot Reason: Fall-through from recovery boot mode

 

Tried single steps aswell without success:

sudo fastboot flash partition gpt.bin
fastboot flash bootloader bootloader.img
fastboot reboot-bootloader


This is what I see on my PC:

target reported max download size of 536870912 bytes
sending 'partition' (37 KB)...
OKAY [  0.005s]
writing 'partition'...
(bootloader) Validating 'gpt.default.xml'
(bootloader) Committing 'gpt.default.xml'
(bootloader) - flashing 'gpt_main0.bin' to 'partition:0'
FAILED (status read failed (No such device))
finished. total time: 5.114s
...


Can you help me to reflash official firmware/stockROM?

Thank you very much!


hey bro sorry to hear that but you need to visit service centre and get your mobile repaired there only. you had to first do

 

fastboot boot twrp.img

then flash the twrp.zip file via twrp recovery

then reboot and boot into recovery again then wipe everything and install and wipe data  and then again flash the twrp.zip file.

 

you ended up doing everything wrong

Reply
Options

5 Posts

12-17-2018

Germany

4 Signins

125 Page Views

  • Posts: 5
  • Registered: ‎12-17-2018
  • Location: Germany
  • Views: 125
  • Message 3 of 3

Re: Moto X4 bricked during flash of lineageOS and OpenGApps with TWRP

2018-12-22, 22:43 PM

Thanks for your answer, Sagar_1401!

 So there's nothing that I could do myself to save my phone?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms