cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Sam170
Fanfold Paper
Posts: 4
Registered: ‎11-24-2017
Location: US
Views: 726
Message 1 of 3

Turbo Power

I very recently recieved an unlocked US Moto X4 that I purchased in the mail.  Startup went fine and when I was playing around with it later I noiticed that it was charging very slowly.  I then later on took note that the turbo power had kicked in and it began charging rapidly.  I thought, "Fine.  Probably just a bug because the phone is new."  I quickly realized that the turbo power would only activate when the USB-C connector was inserted one way.  I mean what side it was flipped around to.  USB-C is a reversible connector, but when inserted one way it would charge at a slow pace, and if i flipped it around turbo power would kick in.  Is this a common issue?  Should I send for a new phone?  Or will a software update fix this that I haven't gotten yet?  Also on a side note, right out of the box the phone's animations, such as opening folders and bringing up the app drawer appear to be too snappy, like the animations are nonexistent.  Almost as if the phone is reducing performance for low battery mode, except the phone is not in low battery mode.  New to moto phones, would appriciate some help.  Thanks!

adityagoenka
SCSI Port
Posts: 53
Registered: ‎11-15-2017
Location: IN
Views: 711
Message 2 of 3

Re: Turbo Power

Try using other Moto USB Type C cable by borrowing it from your friends if they have one and check whether the problem is with the cable you have got or the phone itself. As a Type C Reversible cable both the ways should support fast charging. Kindly check using other Moto Type C Fast charger and if the problem is still the same, get your product replaced by the retailer or visit the nearest Service Center to get it checked by them

iglenday
Punch Card
Posts: 12
Registered: ‎05-21-2016
Location: US
Views: 668
Message 3 of 3

Re: Turbo Power

 


@Sam170 wrote:

I very recently recieved an unlocked US Moto X4 that I purchased in the mail.  Startup went fine and when I was playing around with it later I noiticed that it was charging very slowly.  I then later on took note that the turbo power had kicked in and it began charging rapidly.  I thought, "Fine.  Probably just a bug because the phone is new."  I quickly realized that the turbo power would only activate when the USB-C connector was inserted one way.  I mean what side it was flipped around to.  USB-C is a reversible connector, but when inserted one way it would charge at a slow pace, and if i flipped it around turbo power would kick in.  Is this a common issue?  Should I send for a new phone?  Or will a software update fix this that I haven't gotten yet?  Also on a side note, right out of the box the phone's animations, such as opening folders and bringing up the app drawer appear to be too snappy, like the animations are nonexistent.  Almost as if the phone is reducing performance for low battery mode, except the phone is not in low battery mode.  New to moto phones, would appriciate some help.  Thanks!


Here is the official response: 

How to properly charge the moto x4

 https://mobilesupport.lenovo.com/us/en/Solution/MS123455

Top Kudoed Authors