cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Brent27
Paper Tape
Posts: 7
Registered: ‎11-01-2015
Location: US
Views: 8,224
Message 2 of 96

Update to 8.1 broke Android auto

My moto x4 updated to andorid 8.1 and now my car does not recognize it when I plug it in for andorid auto.  How do I fix it?

dhardeman
Ctrl-Alt-Del
Posts: 10
Registered: ‎05-04-2018
Location: US
Views: 8,218
Message 1 of 96

Android Auto & USB 8.1 Bug

***Do not install the 8.1 update if you need Android Auto to work!***

 

After installing the Android 8.1 update this morning on my X4 (U.S. androidone version), Android Auto no longer launches upon connection and cannot be manually activated. My vehicle (2017 Mitsubishi Outlander) won't even recognize that the phone is connected via USB. It worked perfectly yesterday, and now I can't use Android Auto on my brand new phone. It also will not mount to a computer for file transfers.

 

You need to fix this now, or send me a new replacement. Android Auto is a major feature that many people use daily. It's ridiculous that Lenovo/Motorola released this update without adequately testing and confirming proper functionality of such a significant feature. I really liked this phone until now. What an embarrassing oversight.

dhardeman
Ctrl-Alt-Del
Posts: 10
Registered: ‎05-04-2018
Location: US
Views: 8,178
Message 3 of 96

Re: Update to 8.1 broke Android auto

I am experiencing the same problem. Lenovo/Motorola needs to fix this asap, and they need to immediately suspend updates until resolved. Do not install the 8.1 update!
Brent27
Paper Tape
Posts: 7
Registered: ‎11-01-2015
Location: US
Views: 8,173
Message 4 of 96

Re: Update to 8.1 broke Android auto

Is there any way to downgrade to 8.0?
dhardeman
Ctrl-Alt-Del
Posts: 10
Registered: ‎05-04-2018
Location: US
Views: 8,162
Message 5 of 96

Re: Update to 8.1 broke Android auto

I don't think so, not without rooting the device and installing a custom rom, anyway. It really sucks. I just got mine last week, and now this. I'm inclined to sell it and just get an iPhone. This sort of stuff has happened with every Android device I've purchased; it's always something. Apple products are ridiculously overpriced for what they are, but they just work. You don't have to worry about an untested update disabling key features of your phone.
Robosledge
Punch Card
Posts: 11
Registered: ‎05-04-2018
Location: US
Views: 8,086
Message 6 of 96

issues after 8.1.0 update - no android auto w/car

I have 2 brand new Moto X4 android one phones. Both updated to 8.1.0. Both are having issues with androind auto not working with the car (2017 hyundai tucson). This is a big problem. I tried new cables, reloaded app, restarted phone, etc et etc + stuff I read online. Nothing works. I need this to work. Android auto via the car head unit is a very helpful tool to have when driving (plus a safety feature).

 

note: my 2 year old Moto Droid Turbo 2 running 7.0 works just fine. Plugged it in to car & android auto started right up.

 

Please help! Thank you.

kordo
Punch Card
Posts: 38
Registered: ‎04-06-2015
Location: EE
Views: 8,065
Message 7 of 96

Re: issues after 8.1.0 update - no android auto w/car

In reddit they talk that usb is not functioning after update. Only charging works, otg also.

snowbeer
Paper Tape
Posts: 7
Registered: ‎05-05-2018
Location: US
Views: 7,985
Message 8 of 96

Re: issues after 8.1.0 update - no android auto w/car

Same problem here. It is clear the 8.1 update broke android auto functionality. This needs to be fixed fast or I'll be selling this phone and moving away from Moto.
smmike
Paper Tape
Posts: 6
Registered: ‎05-06-2018
Location: US
Views: 7,933
Message 9 of 96

Re: Android Auto & USB 8.1 Bug

I also have the same issue and I hope it will be resolved. I remember seeing similar issue on Nexus 5X, but then it was caused by resetting USB protocol option to "Charge only" during upgrade, so reverting it back to MTP (Media Transfer Protocol) helped. Now I checked that my USB transfer protocol is still MTP, but Android Auto is not working anyway.

Sbell63
What's DOS?
Posts: 1
Registered: ‎05-06-2018
Location: US
Views: 7,907
Message 10 of 96

Re: Update to 8.1 broke Android auto

I have the same problem.  Called Motolora tech support and they could not resolve.  I need Android Auto to work!!!  I have a 2017 Ford Escape that will not recognize when I plug in for Android Auto.  Help please!

Top Kudoed Authors