Motorola Community

Moto X PhonesMoto X4
All Forum Topics
Options

4 Posts

08-01-2018

US

7 Signins

92 Page Views

  • Posts: 4
  • Registered: ‎08-01-2018
  • Location: US
  • Views: 92
  • Message 1 of 4

screen will not wake up (blank) during call with moto x4

2019-06-27, 22:13 PM

2 weeks ago something funny happened:

while answering the phone the screen goes black (that's normal).

but also when lowering the phone it is still blank so I can't access the menus/hangup until the call is over by other means.

during the call I sense the fingerprint is working (it vibrates when I use) it but the screen stays blank.

I can even activate screen snapshot (volDown+power) but screen stays blank . I later viewed the screen shot file (after call ended) : it was black too.

the only way right now to end a call is by assigning hangup action to powerBtn.

there is no problem to turn on the screen when device is idle. the problem is only during phone calls.

 

another observation: while phone is charging and stantionary ,it used to be enough to wave my hand few centimeters above it to show the clock for few seconds. today: if I wave my hand above the phone : it will rarely wake up if at all. I must press some button to wake it.

 

(This is XT1900-2 model with 6GB RAM with March 2019 Android 9 build).

 

so I thought:this must be the proximity sensor!

I went to the Moto help and run a hardware test: to my surprise the proximity sensor test passed well.

 

so now I'm clueless, what went wrong ?  any thoughts ?

 

Solved! See the solution
Reply
Options

28302 Posts

02-02-2016

US

5836 Signins

132730 Page Views

  • Posts: 28302
  • Registered: ‎02-02-2016
  • Location: US
  • Views: 132730
  • Message 2 of 4

Re: screen will not wake up (blank) during call with moto x4

2019-06-28, 10:53 AM

 wrote:

2 weeks ago something funny happened:

while answering the phone the screen goes black (that's normal).

but also when lowering the phone it is still blank so I can't access the menus/hangup until the call is over by other means.

during the call I sense the fingerprint is working (it vibrates when I use) it but the screen stays blank.

I can even activate screen snapshot (volDown+power) but screen stays blank . I later viewed the screen shot file (after call ended) : it was black too.

the only way right now to end a call is by assigning hangup action to powerBtn.

there is no problem to turn on the screen when device is idle. the problem is only during phone calls.

 

another observation: while phone is charging and stantionary ,it used to be enough to wave my hand few centimeters above it to show the clock for few seconds. today: if I wave my hand above the phone : it will rarely wake up if at all. I must press some button to wake it.

 

(This is XT1900-2 model with 6GB RAM with March 2019 Android 9 build).

 

so I thought:this must be the proximity sensor!

I went to the Moto help and run a hardware test: to my surprise the proximity sensor test passed well.

 

so now I'm clueless, what went wrong ?  any thoughts ?

 


It could be some app you installed that is interfering. Have you tested in safe mode?

 

To reboot into safe mode, tap the power button until you see power off on screen. Then tap and hold power off (on screen) and a new menu will appear to reboot into safe mode.


* Search box is your friend * I don't respond to PM if question belongs in forum
Reply
Options

4 Posts

08-01-2018

US

7 Signins

92 Page Views

  • Posts: 4
  • Registered: ‎08-01-2018
  • Location: US
  • Views: 92
  • Message 3 of 4

Re: screen will not wake up (blank) during call with moto x4

2019-06-29, 1:11 AM

tried safe mode. still the same.

will try factory reset tomorrow.

update: factory reset didn't help.

Reply
Options

4 Posts

08-01-2018

US

7 Signins

92 Page Views

  • Posts: 4
  • Registered: ‎08-01-2018
  • Location: US
  • Views: 92
  • Message 4 of 4

Re: screen will not wake up (blank) during call with moto x4

2019-06-30, 10:23 AM

ok. today I ran another hardware test with the Moto help app.

this time proximity sensor test failed.

I need a lab to replace it.

 

(BTW: I've used the same case for several months so no real change in case/screen protector)

one last try: I removed the case: now the sensor works. wow. what changed over the  last few months ?

as if that sensor was losing sensitivity and now operates only without case.

on the other side , it was a bit dusty there , so I cleaned and noticed that now works also with case.... case closed !

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save