Motorola Community

Moto Z Phones - Mod CapableMoto Z² Force
All Forum Topics
Options

1 Posts

03-09-2019

US

2 Signins

8 Page Views

  • Posts: 1
  • Registered: ‎03-09-2019
  • Location: US
  • Views: 8
  • Message 1 of 2

Mod Battery won't charge

2019-03-09, 12:53 PM

Moto mod battery won't charge.  I have used both directly charging through port and wireless charging.  I get error message that the mod is not lined up, so I fix it and still nothing . 

Reply
Options

3736 Posts

04-04-2013

US

2716 Signins

25585 Page Views

  • Posts: 3736
  • Registered: ‎04-04-2013
  • Location: US
  • Views: 25585
  • Message 2 of 2

Re: Mod Battery won't charge

2019-03-09, 14:16 PM

Good morning.  That's a bummer.  I assume you have an Incipio Off Grid, Kate Spade, or Tumi since you mentioned wireless charging (those were the only 3 that had wireless charging options).  Have you tried restarting the Mod?  With it attached go into Settings > Connected Devices > Moto Mods > About This Moto Mod > Restart Moto Mod.  Also while you are in those Settings there is an option for Software Updates, click that and see if any updates are available for your Mod.  Probably not since it's been years since there were any battery mod updates, but it doesn't hurt to check.  Also, since you mentioned a wireless charging Battery Mod have you tried just placing the battery only on your wireless charger (detached from the phone)?  Does the green light blink, or does it blink red?  Does it charge disconnected from the phone?  If none of those help, or work, you might just have a defective Battery Mod.  It sucks, but it does happen, all things go bad eventually.

~Scott
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete