Motorola Community

Moto Z Phones - Mod CapableMoto Z² Force
All Forum Topics
Options

2 Posts

09-06-2017

US

3 Signins

28 Page Views

  • Posts: 2
  • Registered: ‎09-06-2017
  • Location: US
  • Views: 28
  • Message 1 of 4

Moto Z2 Force WiFi problem in China

2017-09-06, 3:48 AM

I have a new Moto Z2 Force, T-Mobile version. Brought it on a business trip to China and facing problems with Wi-Fi. When I connect to a Wi-Fi network, the Wi-Fi icon on the Moto shows an "x" and the status says "Connected, no Internet". Here's the strange thing: most apps and the Chrome browser continue to work, even though it says no Internet. Of course Google and Facebook do not work since they are blocked by the Great Firewall. The reason this is problematic is that since my Moto does not think it's connected to the Internet, some apps refuse to work, such as T-Mobile Wi-Fi calling and a few others. Have tested iPhones and other Androids with the exect sames Wi-Fi networks and they do not face this same problem. Because of this troubleshooting, I believe this is a Moto problem, not an Android OS problem. Anybody have any ideas? I'm only in China a few more days so hope to resolve while still here. Thanks in advance. 

Reply
Options

28302 Posts

02-02-2016

US

5838 Signins

132750 Page Views

  • Posts: 28302
  • Registered: ‎02-02-2016
  • Location: US
  • Views: 132750
  • Message 2 of 4

Re: Moto Z2 Force WiFi problem in China

2017-09-06, 3:55 AM

wrote:

I have a new Moto Z2 Force, T-Mobile version. Brought it on a business trip to China and facing problems with Wi-Fi. When I connect to a Wi-Fi network, the Wi-Fi icon on the Moto shows an "x" and the status says "Connected, no Internet". Here's the strange thing: most apps and the Chrome browser continue to work, even though it says no Internet. Of course Google and Facebook do not work since they are blocked by the Great Firewall. The reason this is problematic is that since my Moto does not think it's connected to the Internet, some apps refuse to work, such as T-Mobile Wi-Fi calling and a few others. Have tested iPhones and other Androids with the exect sames Wi-Fi networks and they do not face this same problem. Because of this troubleshooting, I believe this is a Moto problem, not an Android OS problem. Anybody have any ideas? I'm only in China a few more days so hope to resolve while still here. Thanks in advance. 


I first suspect the device you bought. I have not heard of usa models being sold in china. I guess a first good step before to much troubleshooting is determine authenticity. 

 

But t-mo wifi calling will not work without a tmo sim and likely the tmo network. 


* Search box is your friend * I don't respond to PM if question belongs in forum
Reply
Options

2 Posts

09-06-2017

US

3 Signins

28 Page Views

  • Posts: 2
  • Registered: ‎09-06-2017
  • Location: US
  • Views: 28
  • Message 3 of 4

Re: Moto Z2 Force WiFi problem in China

2017-09-06, 4:03 AM
Thanks Alpha -- this is a US phone, bought in US and a T-Mo US SIM. I'm American, just visiting China.
Reply
Options

28302 Posts

02-02-2016

US

5838 Signins

132750 Page Views

  • Posts: 28302
  • Registered: ‎02-02-2016
  • Location: US
  • Views: 132750
  • Message 4 of 4

Re: Moto Z2 Force WiFi problem in China

2017-09-06, 4:21 AM

wrote:
Thanks Alpha -- this is a US phone, bought in US and a T-Mo US SIM. I'm American, just visiting China.

Sorry, i confused brought with bought in your first sentence and that colored my thoughts. 

 

i dont think wifi calling works on other networks as e911 is part of it. Not sure about wifi connection. Could you be using cell data when it says no wifi? Try airplane mode with wifi on? 


* Search box is your friend * I don't respond to PM if question belongs in forum
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save