Motorola Community

Moto Z Phones - Mod CapableMoto Z² Force
All Forum Topics
Options

23 Posts

10-10-2019

DE

24 Signins

126 Page Views

  • Posts: 23
  • Registered: ‎10-10-2019
  • Location: DE
  • Views: 126
  • Message 341 of 396

Re:Moto Z2 Force wifi issues after Android 9 Pie update

2020-06-11, 22:21 PM
Free advice: Release it on one day with Android 9 for Z2 play.... That will be fun....
Reply
Options

6 Posts

02-18-2020

CH

8 Signins

40 Page Views

  • Posts: 6
  • Registered: ‎02-18-2020
  • Location: CH
  • Views: 40
  • Message 342 of 396

Re:Moto Z2 Force wifi issues after Android 9 Pie update

2020-06-12, 9:12 AM

Question to the community: did someone ever try to "rescue" the Moto Z2 Force by using the rescue feature of the Rescue and Smart Assistant (LMSA) tool? Can re-flashing the firmware with this tool potentially help to fix the WiFi bug? 

 

I'm asking also since somehow not all devices seem to be affected the very same way. I have to Z2 Force in the same household and even there are differences, but both have issues with WiFi .

Reply
Options

1 Posts

06-14-2020

CO

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎06-14-2020
  • Location: CO
  • Views: 5
  • Message 343 of 396

Re:Moto Z2 Force wifi issues after Android 9 Pie update

2020-06-14, 6:01 AM
Hello, I've seen some posts on the Spanish forums and it looks like using it is either useless or makes the whole thing even worse. So far, the closest to a real solution seems to be waiting for an update, which hasn't happened since the most recent security update back in July.
Reply
Options

6 Posts

02-18-2020

CH

8 Signins

40 Page Views

  • Posts: 6
  • Registered: ‎02-18-2020
  • Location: CH
  • Views: 40
  • Message 344 of 396

Re:Moto Z2 Force wifi issues after Android 9 Pie update

2020-06-15, 7:24 AM

Thanks for sharing. Actually I do not believe that there will be an update by Motorola anytime. If they really wanted to fix this, they would have done within short time to keep trust in their brand, it's a year now! The strategy here seems to be not to invest time/money and to sit this out, hoping that some will still buy new models.

 

As re-flashing with Moto's own tool does not seem to help: Are there more experiences with official LineageOS? Does flashing Lineage make the WiFi issues disappear or is the bug not in the android firmware itself but on a deeper level?

 

Thanks for your contributions.

Reply
Options

49 Posts

07-18-2019

IT

81 Signins

570 Page Views

  • Posts: 49
  • Registered: ‎07-18-2019
  • Location: IT
  • Views: 570
  • Message 345 of 396

Re:Moto Z2 Force wifi issues after Android 9 Pie update

2020-06-15, 8:09 AM

Hello everyone,

I'm hesitant in writing this post but we tried everything to fix the issue so I can report my experience.

 

Currently I have an uptime of 3 days and 20 hours, it means that I didn't reboot the phone in almost 4 days. I don't have wifi issues, even if I went around and changed wifi networks, fact that usually drives at a reboot in a matter of minutes going back home.

As I said I'm hesitant because I'm afraid that the problem will show up sooner or later.

 

So, how did I reach this situation?

 

  • Reboot your phone in factory mode (it seems I can't write instructions in the forum, so google it)
  • Unlock as usual, after that it seems that the phone reboots in the normal system but just wait, in a while a notification appears, "Commserver has started". If you click on the notification it opens a CQAtest app but this action is not needed.
  • Just reboot the phone in normal mode.

 

Let me know if it's useful for somebody of you.

Reply
Options

4 Posts

11-26-2019

UA

10 Signins

180 Page Views

  • Posts: 4
  • Registered: ‎11-26-2019
  • Location: UA
  • Views: 180
  • Message 346 of 396

Re:Moto Z2 Force wifi issues after Android 9 Pie update

2020-06-15, 8:59 AM
What model of your phone XT1789-0X(?)
Reply
Options

49 Posts

07-18-2019

IT

81 Signins

570 Page Views

  • Posts: 49
  • Registered: ‎07-18-2019
  • Location: IT
  • Views: 570
  • Message 347 of 396

Re:Moto Z2 Force wifi issues after Android 9 Pie update

2020-06-15, 12:38 PM
XT1789-06 RETEU
Reply
Options

12 Posts

09-22-2019

DE

37 Signins

137 Page Views

  • Posts: 12
  • Registered: ‎09-22-2019
  • Location: DE
  • Views: 137
  • Message 348 of 396

Re:Moto Z2 Force wifi issues after Android 9 Pie update

2020-06-15, 16:08 PM
Hi Oskar, is that a factory reset which wipes the phone? I can't find another type of factory reset but it sounds like it's just a special type of reboot?
Reply
Options

2 Posts

06-15-2020

PL

2 Signins

5 Page Views

  • Posts: 2
  • Registered: ‎06-15-2020
  • Location: PL
  • Views: 5
  • Message 349 of 396

Re:Moto Z2 Force wifi issues after Android 9 Pie update

2020-06-15, 21:33 PM
Hi guys, I'd like to share with solution that works for me and my XT-1789-06. I suffer of the same lagging and reconnecting WiFi since android 9 update. Try this: Go to settings > localisation and blockades > localisation ( under privacy settings) > advance settings > scanning > turn off both scanning WiFi and scanning Bluetooth. Please note that exact names/wording may differ because I use non-English language settings and it is only my translation. To my huge surprise it works for 5 days until now. WiFi is stable, I don't see reconnecting and I manege to achieve reasonable download upload speeds at 35 ms ping with fibre internet provider and 5ghz TP-Link archer router. If only battery was in slightly better shape... If I find any battery Moto Mods to buy, I will stay with my Moto z2 force for at least few next months.
Screenshot_20200615-232228.png
Reply
Options

49 Posts

07-18-2019

IT

81 Signins

570 Page Views

  • Posts: 49
  • Registered: ‎07-18-2019
  • Location: IT
  • Views: 570
  • Message 350 of 396

Re:Moto Z2 Force wifi issues after Android 9 Pie update

2020-06-16, 8:26 AM

@ BBKoenig wrote:
 

Hi Oskar,is that a factory reset which wipes the phone? I can't find another type of factory reset but it sounds like it's just a special type of reboot?

 

It's factory mode, not reset. It's only a special reboot mode, not wiping at all!

By the way I rebooted this morning, so this solution doesn't work.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete