Motorola Community

Moto Z Phones - Mod CapableMoto Z² Force
All Forum Topics
Options

2 Posts

03-01-2019

US

8 Signins

81 Page Views

  • Posts: 2
  • Registered: ‎03-01-2019
  • Location: US
  • Views: 81
  • Message 1 of 6

Moto Z2 Force won't connect to Android Auto in a 2018 Ford F-150

2019-03-01, 13:14 PM

Hi all,

When I plug into the F-150's USB port my Z2 Force will launch Android Auto then stop.  Bluetooth works but not USB connectivity unless I manually switch the phone to File Transfer.  I have to manually change the USB setting on the phone from USB Charging to File Transfer exactly 3 times before my truck recognizes it via USB.  How do I get USB connectivity and AA working?

Reply
Options

3736 Posts

04-04-2013

US

2714 Signins

25580 Page Views

  • Posts: 3736
  • Registered: ‎04-04-2013
  • Location: US
  • Views: 25580
  • Message 2 of 6

Re: Moto Z2 Force won't connect to Android Auto in a 2018 Ford F-150

2019-03-01, 13:46 PM

Bases on the dozens & dozens of posts like this for Moto Z, Moto Z Force, Moto Z Play, Z2 Play and Z2 Force phones it almost sounds like the Z series just isn't compatible with Android Auto.  Or Oreo 8.0 isn't compatible with Android Auto?

~Scott
Reply
Options

28302 Posts

02-02-2016

US

5838 Signins

132750 Page Views

  • Posts: 28302
  • Registered: ‎02-02-2016
  • Location: US
  • Views: 132750
  • Message 3 of 6

Re: Moto Z2 Force won't connect to Android Auto in a 2018 Ford F-150

2019-03-01, 15:37 PM

I use Android auto with Z2 Force and Z2 Play and previously Moto Z - i have never had to change any settings on the phone. 

 

My car and various rental cars have all worked fine, so I don't think it is the Z phone line. 


* Search box is your friend * I don't respond to PM if question belongs in forum
Reply
Options

3736 Posts

04-04-2013

US

2714 Signins

25580 Page Views

  • Posts: 3736
  • Registered: ‎04-04-2013
  • Location: US
  • Views: 25580
  • Message 4 of 6

Re: Moto Z2 Force won't connect to Android Auto in a 2018 Ford F-150

2019-03-01, 19:37 PM

That's good to know.  Thanks.  I have been looking at upgrading the stereo in my Jeep, and was a little hesitant to gonna Android Auto with all these posts about it not working.  I think yours is the first response I have seen from a Z user confirming that AA does work with Z series phones.

~Scott
Reply
Options

2 Posts

03-01-2019

US

8 Signins

81 Page Views

  • Posts: 2
  • Registered: ‎03-01-2019
  • Location: US
  • Views: 81
  • Message 5 of 6

Re: Moto Z2 Force won't connect to Android Auto in a 2018 Ford F-150

2019-03-09, 14:37 PM

Hard to believe this has been an issue for so long!  I've tried different USB cables, enabled USB Debugging and disabled automatic routing to USB audio peripherals.

Reply
Options

1 Posts

04-27-2019

US

3 Signins

100 Page Views

  • Posts: 1
  • Registered: ‎04-27-2019
  • Location: US
  • Views: 100
  • Message 6 of 6

Re: Moto Z2 Force won't connect to Android Auto in a 2018 Ford F-150

2019-04-27, 21:37 PM

I have a 2019 Chevy Bolt, and despite trying just about every trick I've read online, I can't get Android Auto to connect.  I get to the last screen when plugging the USB in, and when I press continue, the response page evaporates and nothing happens.  I am running Android 8.0.0 with a January 2019 security patch. Needless to say, this is very frustrating.  

 

PS: The sales guy at the dealership was able to get his non-motorola Android phone to run Android Auto without any problem.  It works flawlessly on my son's non-motorola android phone.  Despite assertions to the contrary, this is a problem with the Z phone line, whether it is acknowledged or not.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save