Motorola Community

Moto Z Phones - Mod CapableMoto Z² Force
All Forum Topics
Options

19 Posts

10-03-2018

US

20 Signins

153 Page Views

  • Posts: 19
  • Registered: ‎10-03-2018
  • Location: US
  • Views: 153
  • Message 1 of 13

No bluetooth media

2019-03-25, 22:17 PM

I have a 2015 Jeep Wrangler. When I connect bluetooth I can answer and make calls, and text messages, but no media. For example when I have navigation on my phone and I have bluetooth on there is no sound such as "turn left now" that I would normally have.

 

To rephrase everything works perfect when I turn off bluetooth. When it's and connected to my Jeep media sounds are muted. 

 

I have checked the obvious volumes on bluetooth and it all good. I called Jeep and updated my radio to the newest software and it still does not work. I assumed my Jeep was too old to work with this new phone.

 

I just bought a 2019 Ford F350 and I have the exact same problem. Now I know it's not the vehicle, but rather the phone. Is there a special bluetooth app I need to install to make media compatibe?

 

Also Youtube does not play media through the radio on either vehicle, but works fine when not connected by bluetooth.

Moto Z2 Force on Verizon in USA
Reply
Options

3736 Posts

04-04-2013

US

2716 Signins

25585 Page Views

  • Posts: 3736
  • Registered: ‎04-04-2013
  • Location: US
  • Views: 25585
  • Message 2 of 13

Re: No bluetooth media

2019-03-25, 23:19 PM

There are a lot of Bluetooth issues with Android 8.0, but I don't believe basic media streeaming is one of them.  I have multiple Bluetooth devices connected to my Z2 Force, including my wife's 2017 Jeep Cherokee (with U Connect 8.1) and all play media just fine.  Her Z2 Play works fine with her Jeep also.  In my '11 Wrangler I don't have the Jeep Bluetooth stereo (stupid mistake on my part :smileyhappy:) but use a Bluetooth car kit that hooks to the stereo Aux port, and stream music to it every day.  When you open the Bluetooth SEttings on your phone and tap the gear symbol next to the vehicle name, is Media checked?  Example screenshot attached.  I have seen many times that when connecting to a vehicle for the first time, the on-screen prompts on the phone and on the vehicle can easily be overlooked, or quickly dismissed and we end up missing a crucial prompt to allow a certain connection (Phone calls, media, contact sharing, etc.).

 

~Scott
Reply
Options

19 Posts

10-03-2018

US

20 Signins

153 Page Views

  • Posts: 19
  • Registered: ‎10-03-2018
  • Location: US
  • Views: 153
  • Message 3 of 13

Re: No bluetooth media

2019-03-25, 23:24 PM

Thank you for the reply. Yes I checked that.

Moto Z2 Force on Verizon in USA
Reply
Options

3736 Posts

04-04-2013

US

2716 Signins

25585 Page Views

  • Posts: 3736
  • Registered: ‎04-04-2013
  • Location: US
  • Views: 25585
  • Message 4 of 13

Re: No bluetooth media

2019-03-25, 23:34 PM

Do you use the Google app much / Assistant?  A recent Google app update messed up my Bluetooth media playing, and none of my devices would play music.  The phone said music was playing, but no sound on any Bluetooth device.  I uninstalled all updates from the Google app > rebooted my phone and all was good again.  Then I let the Google app update again through the Play Store and it's been good ever since.  I have seen so many weird problems caused by the Google app and / or Assistant (and posted quite a few here on the forum).  Something to think about & consider.

 

The other possibility is that the Ford (and the Wrangler if it had the smaller Bluetooth stereo - not the U Connect 8 version) use the older AVRCP Bluetooth protocols, then the phone will not be compatible until you recieve either Android 8.1 or 9.0 Pie.  Like I mentioned previously there are many Bluetooth issues with Android 8.0, and Google fixed them with 8.1.  But we never received 8.1 unfortunately.

~Scott
Reply
Options

19 Posts

10-03-2018

US

20 Signins

153 Page Views

  • Posts: 19
  • Registered: ‎10-03-2018
  • Location: US
  • Views: 153
  • Message 5 of 13

Re: No bluetooth media

2019-03-26, 0:12 AM

Is this what you are referring to?

Moto Z2 Force on Verizon in USA
Reply
Options

3736 Posts

04-04-2013

US

2716 Signins

25585 Page Views

  • Posts: 3736
  • Registered: ‎04-04-2013
  • Location: US
  • Views: 25585
  • Message 6 of 13

Re: No bluetooth media

2019-03-26, 0:38 AM

That's the app, yes.  But if you don't use Google hands free voice commands a lot it may not be the issue.  It never hurts to uninstall app updates, reboot and then re-update an app.  But it might not help, just throwing that out there.  There is a long thread on here (and many other Moto phones running Android 8.0) about the many Bluetooth issues.  I don't remember basic media pkayiplbeing one of them, but it is possible.  If that is the case there is no fix until we get Android 9 Pie

~Scott
Reply
Options

835 Posts

02-20-2009

US

1012 Signins

6096 Page Views

  • Posts: 835
  • Registered: ‎02-20-2009
  • Location: US
  • Views: 6096
  • Message 7 of 13

Re: No bluetooth media

2019-03-27, 15:20 PM

If you are using Google Maps, do you have the option in Maps of Settings > Navigation Settings > Play voice over Bluetooth enabled?

Reply
Options

19 Posts

10-03-2018

US

20 Signins

153 Page Views

  • Posts: 19
  • Registered: ‎10-03-2018
  • Location: US
  • Views: 153
  • Message 8 of 13

Re: No bluetooth media

2019-03-27, 18:41 PM

Yes that option is turned on. I also have this problem with other media such as YouTube.

Moto Z2 Force on Verizon in USA
Reply
Options

19 Posts

10-03-2018

US

20 Signins

153 Page Views

  • Posts: 19
  • Registered: ‎10-03-2018
  • Location: US
  • Views: 153
  • Message 9 of 13

Re: No bluetooth media

2019-03-28, 12:43 PM

@sajokaz I tried that and it did not help.

Moto Z2 Force on Verizon in USA
Reply
Options

3736 Posts

04-04-2013

US

2716 Signins

25585 Page Views

  • Posts: 3736
  • Registered: ‎04-04-2013
  • Location: US
  • Views: 25585
  • Message 10 of 13

Re: No bluetooth media

2019-03-28, 14:26 PM

Check out this thread It's 19 pages long and started as just about the Bluetooth - AVRCP issue with Android 8.0, but later morphed into all Bluetooth issues with Android 8.0.  I think somehwere in there some folks even mentioned some of the vehicles that don't work well with Android 8.0.  If your issues are like the posts in that thread then there is no fix until we receive Android 9.0 Pie.

 

https://forums.lenovo.com/t5/Moto-Z-Force/Bluetooth-Issue-Introduced-With-Oreo-8-0-Moto-Z2-Force/td-p/3993570

~Scott
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete