Motorola Community

Moto Z Phones - Mod CapableMoto Z² Play
All Forum Topics
Options

1 Posts

10-16-2020

US

2 Signins

0 Page Views

  • Posts: 1
  • Registered: ‎10-16-2020
  • Location: US
  • Views: 0
  • Message 1 of 2

Moto Z Play USB issues

2020-10-16, 13:13 PM

So I've been having this problem with my moto z play phone. 

 

When I attach the USB cable it says "turbo power connected" repeated.  After about a few minutes, it ceases fast charge and starts charging slowly.  After awhile it stops charging entirely.

 

Things I have tried:

 

Resetting the phone

 

Different usb cords

 

Different plug in chargers

 

Antivirus

 

Factory reset

 

Deleting superfluous apps

 

Help!

Screenshot_20201016-090639.png
Reply
Options

2196 Posts

03-11-2019

US

608 Signins

44055 Page Views

  • Posts: 2196
  • Registered: ‎03-11-2019
  • Location: US
  • Views: 44055
  • Message 2 of 2

Re:Moto Z Play USB issues

2020-10-16, 16:43 PM

Hi Jlvd,

 

I will try my best to help you fix this. Since you have already tried multiple chargers and USB connectors, we suggest to have the phone sent to a service center for repair. Kindly go to this link to get started: https://motorola-global-portal.custhelp.com/app/mcp/service/open/request?linkId=54149943

 

Best regards,
Zeke
Motorola Support



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete