Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto Z Phones - Mod CapableMoto Z² Play
All Forum Topics
Options

3 Posts

01-17-2020

United States of America

3 Signins

15 Page Views

  • Posts: 3
  • Registered: ‎01-17-2020
  • Location: United States of America
  • Views: 15
  • Message 1 of 6

HELP PLEASE!! Problem putting phone back together after replacing battery - ribbon cable problem

2021-02-28, 23:06 PM

So I followed all of the steps for replacing a battery.  https://www.ifixit.com/Guide/Motorola+Moto+Z2+Play+Battery+Replacement/103354

 

I believe I did everything correctly but cannot figure how to reconnect/place the ribbon cable.  (Step 7)  I cannot figure out if it connects somewhere, whether I can just push it down randomly, etc.  So I just pushed it down.

 

When I tried to turn the phone back on, I just kept getting some strange colored lines under the screen and nothing else.  The only thing I can figure it that it has to do with the ribbon cable because I'm sure everything else is connected and in place.  This may be the difference between a good fix and a new phone.  :((((

 

I apologize if it is obvious but I just can't figure it out.  I was patting myself on the back left and right for have gotten the battery replaced - and then that.  The ribbon is currently disconnected.

 

Any help will be greatly appreciated.

 

Thank you.

 

Trisha

Reply
Options

6799 Posts

02-11-2016

United States of America

3410 Signins

85846 Page Views

  • Posts: 6799
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 85846
  • Message 2 of 6

Re:HELP PLEASE!! Problem putting phone back together after replacing battery - ribbon cable problem

2021-03-01, 1:57 AM

@ trisha3121 wrote:

So I followed all of the steps for replacing a battery.  https://www.ifixit.com/Guide/Motorola+Moto+Z2+Play+Battery+Replacement/103354

 

I believe I did everything correctly but cannot figure how to reconnect/place the ribbon cable.  (Step 7)  I cannot figure out if it connects somewhere, whether I can just push it down randomly, etc.  So I just pushed it down.

 

When I tried to turn the phone back on, I just kept getting some strange colored lines under the screen and nothing else.  The only thing I can figure it that it has to do with the ribbon cable because I' sure everything else is connected and in place.  This may be the difference between a good fix and a new phone.  :((((

 

I apologize if it is obvious but I just can' figure it out.  I was patting myself on the back left and right for have gotten the battery replaced - and then that.  The ribbon is currently disconnected.

 

Any help will be greatly appreciated.

 

Thank you.

 

Trisha

 

Hi Trisha. this is outside the scope of our support here in the community, but I'll do my best to help. Based on Step 7 in the ifixit guide, that ribbon cable coming from the front LCD should slide into the black connector. 

 

Note if you accidentally damage the cable or the pins in the connector during your assembly or re-assembly it might be why you're getting random colored lines. That or the LCD was inadvertently damaged during the process. Maybe you can take a picture of your phone in the current state and I can get a better idea. I can't promise it, but I'll try.

 

-Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

3 Posts

01-17-2020

United States of America

3 Signins

15 Page Views

  • Posts: 3
  • Registered: ‎01-17-2020
  • Location: United States of America
  • Views: 15
  • Message 3 of 6

Re:HELP PLEASE!! Problem putting phone back together after replacing battery - ribbon cable problem

2021-03-01, 2:24 AM

Tom, thank you so much for responding.  My first thought was to take a picture of it and then I quickly remembered that my cell phone isn't working so I couldn't take a picture!  However, I will be able to take a picture first thing in the morning when I will have access to a cell phone, and I will send it along.  Thank you for any help you are able to offer, and also the fact that you are willing to even give it a try!

 

:)

 

Trisha

Reply
Options

6799 Posts

02-11-2016

United States of America

3410 Signins

85846 Page Views

  • Posts: 6799
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 85846
  • Message 4 of 6

Re:HELP PLEASE!! Problem putting phone back together after replacing battery - ribbon cable problem

2021-03-03, 1:14 AM

@ trisha3121 wrote:

Tom, thank you so much for responding.  My first thought was to take a picture of it and then I quickly remembered that my cell phone isn' working so I couldn' take a picture!  However, I will be able to take a picture first thing in the morning when I will have access to a cell phone, and I will send it along.  Thank you for any help you are able to offer, and also the fact that you are willing to even give it a try!

 

:)

 

Trisha

 

Hi Trisha, I'm just checking in. Did you have any luck with getting a photo for me? 

 

-Tom



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

3 Posts

01-17-2020

United States of America

3 Signins

15 Page Views

  • Posts: 3
  • Registered: ‎01-17-2020
  • Location: United States of America
  • Views: 15
  • Message 5 of 6

Re:HELP PLEASE!! Problem putting phone back together after replacing battery - ribbon cable problem

2021-03-03, 1:30 AM

Tom, I sent it the very next day!  Let me try again.

 

Reply
Options

6799 Posts

02-11-2016

United States of America

3410 Signins

85846 Page Views

  • Posts: 6799
  • Registered: ‎02-11-2016
  • Location: United States of America
  • Views: 85846
  • Message 6 of 6

Re:HELP PLEASE!! Problem putting phone back together after replacing battery - ribbon cable problem

2021-03-09, 2:22 AM

@ trisha3121 wrote:

Tom, I sent it the very next day!  Let me try again.

 

 

Sorry, I just saw your reply.  So that ribbon cable should be plugged/slid back into the smaller black and white connector. I circled where it should slide/plug-in. Based on the ifixit guide, it should slide back in from the side or top if looking at the phone from the same direction as the photo. The arrow I put on the picture should be the direction it slides into the connector. 

 

Let me know if that helps.

 

-Tom

 

 



Did someone help you today? Press the thumbs up icon on the bottom right to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms