cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
platypie101
Punch Card
Posts: 10
Registered: ‎08-23-2016
Location: US
Views: 7,232
Message 1 of 194

Bluetooth Issue Introduced With Oreo 8.0 - Moto Z2 Force

Since the initial Oreo update (and the recent update) I've lost the ability to rewind and fast-forward Google Play Music using my car's receiver (Pioneer DEH-X6800BT). I installed this stereo in 2017, and everything functioned as it should from when I bought the Z2 Force in September until this update. I've reset bluetooth in my phone and rebooted, I've tried simply re-pairing the phone to the car stereo, I've tried clearing app caches, uninstalling and reinstalling GPM and other apps I thought might be involved, I've tried various so-called "bluetooth fix" apps - and I've rebooted between each different attempt. I really hoped the latest update we received a few days ago might address it. But no, it's still not working.

 

I think I may have narrowed the problem down to the Audio/Video Remote Control Profile (or AVRCP) version available in Oreo 8.0. This version of Oreo gives us the option to choose between AVRCP versions 1.4 (default), 1.5 and 1.6 using Developer options. The last version of Android we were on (Nougat 7.1.1) supported AVRCP version 1.3, and was compatible with most bluetooth receivers sold over the last few years. While Android 8.0 allows users to choose between the new improved versions and potentially sets us up for the most up-to-date receivers and future receivers, the receivers in most cars are not forward-compatible. They are made to be compatible with accepted standards at the time they are made or earlier. My stereo works with version 1.3 and I'm pretty sure this is why I've lost the rewind and fast-forward functionality. Some users seem to be experiencing a variety of issues since updating to Oreo - connection issues, functionality and issues with built-in GPS/stereos.

 

The next version of Oreo, 8.1, has restored the capability to go back to using AVRCP version 1.3 (at least that is what Pixel owners are saying). Some users of other phones that have recently received updates to 8.1 are reporting that certain bluetooth functionalities in their cars have been restored because of this. I think you never know with bluetooth, but hopefully Lenovo/Moto is not going to wait too long to get us up to Oreo 8.1. I'm not holding my breath, but there's hope. 

 

If anyone can chime in and let me know if I'm on the right track, it would be great. 

aravitz90
Punch Card
Posts: 65
Registered: ‎04-23-2012
Location: US
Views: 7,151
Message 2 of 194

Re: Bluetooth Issue Introduced With Oreo 8.0 - Moto Z2 Force

I posted a fix look up on the topics page

-Avrumi Ravitz
platypie101
Punch Card
Posts: 10
Registered: ‎08-23-2016
Location: US
Views: 7,068
Message 3 of 194

Re: Bluetooth Issue Introduced With Oreo 8.0 - Moto Z2 Force

I looked at your posts about Oreo, and it looks like your suggesting a full factory reset. I've done the safe mode thing already. No luck there. But I don't have the stomach for a factory reset. It's very time consuming, and if my theory is right, it isn't going to have an effect on my issue. I think the later available AVRCP versions changed the profile instructions for certain headphones and car stereos. I mean the internal instructions assigning a given Bluetooth device's buttons to functions of the phone. The only solution, I think, is if the earlier version (1.3) of AVRCP is made available again for a user to select. I know I could be wrong, but a factory reset wouldn't address this. This is available in the latest version of Oreo (8.1), which isn't available for the Z2 Force yet.

Former Employee
Posts: 2,430
Registered: ‎12-19-2016
Location: PH
Views: 7,011
Message 4 of 194

Re: Bluetooth Issue Introduced With Oreo 8.0 - Moto Z2 Force

Hi platypie101

 

That's unusual but let me see what I can do. Does it happen with the music files saved on your phone? 

 

Please update your profile with the serial/IMEI/MEID number of your phone? This will help us investigate. Make sure that your Motorola Privacy is enabled under Settings. Let me know (just reply here) if it's okay for me to look at your apps to see if they are a source of problems.

Need help updating your profile? Click on this link.

 

Regards,
Ella
Motorola Support

 

 

Motoz2jim
Ctrl-Alt-Del
Posts: 19
Registered: ‎02-28-2018
Location: US
Views: 6,969
Message 5 of 194

Re: Bluetooth Issue Introduced With Oreo 8.0 - Moto Z2 Force

My Moto z2 force (verizon) updated to Oreo 8.0 a second time on 2/1/18. Ever since my Kia 2012 Sportage UVO Bluetooth connects only for phone calls but keeps disconnecting and reconnecting when I want to play music through any app like I heart...and prime music...and Google music! 

I've tried all the forum fixes to no avail! Is there a patch forthcoming soon? I miss my music!

Motoz²jim

platypie101
Punch Card
Posts: 10
Registered: ‎08-23-2016
Location: US
Views: 6,874
Message 6 of 194

Re: Bluetooth Issue Introduced With Oreo 8.0 - Moto Z2 Force

I'm just reading your reply now, Moto_Ella. Thank you for your response. On my way out the door for work. I'll try to update that info later this afternoon. Another thing I now discovered. I'm a subscriber to Google Play Music, and that's almost the only app I use for music. However ,I installed Power Amp (music app) and rewind and fast-forward functions when using that player from the buttons on the car stereo (Pioneer DEH-X6800BT). I can't use Power Amp as my regular player though. I'll add more about this later. Gotta run. Thanks.

platypie101
Punch Card
Posts: 10
Registered: ‎08-23-2016
Location: US
Views: 6,871
Message 7 of 194

Re: Bluetooth Issue Introduced With Oreo 8.0 - Moto Z2 Force

Oh ,and yes, this occurs with downloaded music. I mostly download the music I want to hear ahead of time to save data use.

Former Employee
Posts: 2,430
Registered: ‎12-19-2016
Location: PH
Views: 6,861
Message 8 of 194

Re: Bluetooth Issue Introduced With Oreo 8.0 - Moto Z2 Force

Hi platypie101 & Motoz2jim

 

Thanks for bringing this up. We'll share your feedback with the team.

 

- Ella

platypie101
Punch Card
Posts: 10
Registered: ‎08-23-2016
Location: US
Views: 6,840
Message 9 of 194

Re: Bluetooth Issue Introduced With Oreo 8.0 - Moto Z2 Force

FYI, I've updated my profile with the information you've requested.
Ageocaris
Paper Tape
Posts: 8
Registered: ‎02-10-2018
Location: US
Views: 6,750
Message 10 of 194

Re: Bluetooth Issue Introduced With Oreo 8.0 - Moto Z2 Force

I have posted a similar issue and would appreciate your help.

Top Kudoed Authors