Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

Motorola Community

Moto Z Phones - Mod CapableMoto Z Force
All Forum Topics
Options

5 Posts

05-18-2019

United States of America

4 Signins

40 Page Views

  • Posts: 5
  • Registered: ‎05-18-2019
  • Location: United States of America
  • Views: 40
  • Message 1 of 17

Moto Z Force Oreo 8.0 - Crazy Battery Drain & Audio Issues

2019-05-18, 13:39 PM

Phone is a Motor Z-Force "Droid" (Verizon). After the Oreo 8.0 update, I'm having some crazy battery drain & audio/phone/earpiece issues.

 

Battery Drain - I have removed or disabled just about all the bloatware on the phone. This morning, I woke up early and removed the phone from the charger. 2 & a half hours later, down to nearly 80% with only 1m of screen usage. This is a pretty frequent issues. Some days are worse than others.

 

Audio Issues - A while after a reboot, the phone will loose audio through the earpiece during phone calls. The "speaker phone" works - though on a Z-Force, the "speaker" is the earpiece speaker... 

 

I've already removed a few suspect apps (Pandora, Instagram) but both issues seem to persist.

 

 

 

I have "Developer Options" enabled, and have a bug report from this morning that I can share if it's useful. I would have rooted this phone & installed a custom ROM long ago, except for Verizon locking the bootloader...

 

 

Any help would be greatly appreciated before I ditch this phone and my carrier.

 

Thank you

 

-JAshley73

Reply
Options

3764 Posts

04-04-2013

United States of America

2725 Signins

25655 Page Views

  • Posts: 3764
  • Registered: ‎04-04-2013
  • Location: United States of America
  • Views: 25655
  • Message 2 of 17

Re: Moto Z Force Oreo 8.0 - Crazy Battery Drain & Audio Issues

2019-05-18, 14:11 PM

Same thing happened to my Z Force Droid, the day after upgrading to Oreo.  I even did a factory reset and installed NO apps and adjusted no settings and didn't even enter my Google account.  The battery drain was less but still noticeable.  Just sitting there doing nothing, Android OS was chewing up battery.  So I put it in a drawer as a spare and bought a Z2 Force.  No battery issues for me with a new phone running Oreo right out of the box.  I think it's a combination of an old (and failing battery) and the Oreo software just isn't good on older phones.  You could try a battery replacement, it might help.  Some users have reported that a new battery helped them

~Scott
Reply
Options

5 Posts

05-18-2019

United States of America

4 Signins

40 Page Views

  • Posts: 5
  • Registered: ‎05-18-2019
  • Location: United States of America
  • Views: 40
  • Message 3 of 17

Re: Moto Z Force Oreo 8.0 - Crazy Battery Drain & Audio Issues

2019-05-18, 14:52 PM

I've already done a factory reset since the oreo update. Ran the phone in safe mode for a day, and the problems seemed cured. So, I removed the suspect apps (Pandora, Instagram) only to see the problem creep back up.

 

I did stumble onto something just now. In Settings, I discovered...

 

Settings > Apps > Apps & Notifications > Advanced > Special App Access > "Unrestricted Data Access" & "Usage Access"

 

In "Unrestricted Data Access" I disabled "Carrier Services", "Google Play Services" "Mobile Services Manager" as these almost always showed up as heavy battery users, and in the running services... (If you choose to do this, make sure to click Menu > Show System Apps as well to see everything..." 

 

In "System > Usage Access" I also turned nearly everything off.`

 

 

I also cleared several cache', rebooted, and will re-charge, and see how the battry life does.

 

 

-JA

 

 

 

 

I'll 

Reply
Options

5 Posts

05-18-2019

United States of America

4 Signins

40 Page Views

  • Posts: 5
  • Registered: ‎05-18-2019
  • Location: United States of America
  • Views: 40
  • Message 4 of 17

Re: Moto Z Force Oreo 8.0 - Crazy Battery Drain & Audio Issues

2019-05-20, 18:59 PM

Update...

 

Since changing which apps have "unrestricted data useage" (none now...) and "useage access" (only storeage manager was granted access here...)  the battery life is drastically improved.

 

 

The audio issue still persists though... Just to reiterage - After an arbitrarty amount of time, I lose audio on voicecalls through the earpiece speaker, and callers cannot hear me through the microphone either. Using the "speakerphone" allows me to hear callers via the speaker (the earpiece & speakerphone are one & the same on Moto Z Force...)  and they can hear me as well...

 

 

Hoping someone from Motorola will pickup on this thread, and help dig a little deeper. I can share a "bug report as well if that helps.

 

 

Someone from Motorola, please help!

Reply
Options

14293 Posts

03-05-2018

United States of America

1313 Signins

178190 Page Views

  • Posts: 14293
  • Registered: ‎03-05-2018
  • Location: United States of America
  • Views: 178190
  • Message 5 of 17

Re: Moto Z Force Oreo 8.0 - Crazy Battery Drain & Audio Issues

2019-05-29, 17:15 PM

Hi JAshley73,

 

Thanks for posting. Glad you've seen improvements with the battery. As per the earpiece, have you tried testing it in the Moto Help app? Just open Moto Help > Device Diagnosis > Hardware Test > Receiver. You can also test the microphone there. Let me know if there's a sound. 

 

Best regards,
Rich
Motorola-Lenovo Support



Did someone help you today? Click the thumbs up button to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

We value your opinion. Read More

Reply
Options

101 Posts

05-26-2010

United States of America

175 Signins

2095 Page Views

  • Posts: 101
  • Registered: ‎05-26-2010
  • Location: United States of America
  • Views: 2095
  • Message 6 of 17

Re: Moto Z Force Oreo 8.0 - Crazy Battery Drain & Audio Issues

2019-06-13, 12:44 PM

Over the last couple of weeks my Z Force has been experiencing rapid battery drain, shutting down with 90%+ battery charge, and driving me absolutely nuts!  I've done the standard stuff of powering off and charging it for hours to "reset" the battery gauge, clearing system cache, even backign up my data and doing the dreaded FDR to wipe and rebuild.  It is STILL dying on me shrtly after an unplug.  Even with a charged Tumi wireless charging Motomod battery it dies off.  I just ordered a Z4 for pickup today.

 

The latest nonsense data is the battery stats screen:

 

 

 

259 days?????? That is a lie.  

 

I went to my Verizon Cloud app to modify settings and my phone shut down with over 90% charge on the internal battery and 100% charge on the Tumi pack. The phone is NOT overheating. At this point my Z Force is more useful as a paperweight or for target pracice than as a smartphone.

Reply
Options

101 Posts

05-26-2010

United States of America

175 Signins

2095 Page Views

  • Posts: 101
  • Registered: ‎05-26-2010
  • Location: United States of America
  • Views: 2095
  • Message 7 of 17

Re: Moto Z Force Oreo 8.0 - Crazy Battery Drain & Audio Issues

2019-06-13, 12:50 PM

And right after taking the phone off the charging stand where it said 90% and rebooting the phone the battery gauge in the status bar says 68% and the "app usage since full charge" screen says 4m ago for the full charge (and it was not fully charged).  And now it's at 65%.

Reply
Options

101 Posts

05-26-2010

United States of America

175 Signins

2095 Page Views

  • Posts: 101
  • Registered: ‎05-26-2010
  • Location: United States of America
  • Views: 2095
  • Message 8 of 17

Re: Moto Z Force Oreo 8.0 - Crazy Battery Drain & Audio Issues

2019-06-13, 13:08 PM

NOW with a Motorola Turbo charger attached to the phone since my previous post and shutting down & clearing system cache the main battery has gone DOWN to 48% and the battery icon in the status bar shows the charging lightning bolt on it.  WTH?????

 

Reply
Options

3764 Posts

04-04-2013

United States of America

2725 Signins

25655 Page Views

  • Posts: 3764
  • Registered: ‎04-04-2013
  • Location: United States of America
  • Views: 25655
  • Message 9 of 17

Re: Moto Z Force Oreo 8.0 - Crazy Battery Drain & Audio Issues

2019-06-13, 15:30 PM

It sounds like the battery is failing.  It's probably time for a new battery or a new phone.... unfortunately.  My Z Force battery died a year ago when we received Oreo 8.0

~Scott
Reply
Options

101 Posts

05-26-2010

United States of America

175 Signins

2095 Page Views

  • Posts: 101
  • Registered: ‎05-26-2010
  • Location: United States of America
  • Views: 2095
  • Message 10 of 17

Re: Moto Z Force Oreo 8.0 - Crazy Battery Drain & Audio Issues

2019-06-13, 16:09 PM

It's whacked that it will just drop dead with a fully charged Tumi pack attached.  What I forgot to mention is if I start in Safe Mode the phone hangs on a LOG longer and drops at about 10% charge left, almost like a normal duration drop.

 

My Z4 was ordered online this morning and is ready for pickup at a Verizon shop near home.  Once I get it up and running with my data restored I'm doing another FDR on this Z Force not through the powered up menu but from recovery mode  Then leave it powered on before even doing a setup and see how long it takes to croak.  That will tell me if it's the battery or bogus firmware/software.

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms